우분투에서 10.04에서 dist-upgrade로 10.10으로 바뀐분 있으신가요?

이번 bash쉘 취약점 때문에 우분투 서버 업그레이드 작업중입니다.
우분투 10.04 LTS버전을 apt-get dist-upgrade bash 이렇게 해주었더니
우분투 버전이 10.10으로 바뀌어 버렸습니다.

그리고 업그레이드 완료 후 에도 취약점이 패치 되지 않았습니다.
테스트 해보면 계속 vulnerable 메시지가 나오네요

LTS버전이 지원기간이 5년이라서 업그레이드 진행한건데
10.10으로 업그레이드가 되버리면 이제 더이상 패치도 안되고 지원도 못받게 되버렸네요

취약점 테스트 해서 vulnerable이 계속 나오고
dist-upgrade를 다시 입력해도 업그레이드 할 내용이 없다고 나온다면
10.10이 지원이 끝나서 그런걸까요?

이럴경우 보안 취약점 패치는 어떻게 진행을 해야 할까요?ㅜㅜ

최신 bash 패키지 파일을 다운로드 해서 설치하셔야 할듯요?