10.10에서 ati 드라이버 문제

10.04에서 ATI 제한된 드라이버(fglrx)를 사용하여 잘 사용하고 있었습니다.
10.10으로 버전 갱신한 후, 재부팅하니 X 윈도우 실행이 안됩니다.
aticonfig 실행해 보면 다음과 같은 메시지가 나옵니다.

[code:2pmrb9f8]$ sudo aticonfig
Unable to open /etc/ati/control, please reinstall the driver.
aticonfig: No supported adapters detected
[/code:2pmrb9f8]
GPU는 ATI 내장 그래픽인 HD3300입니다.

[quote="misari":3hwtvz1y]10.04에서 ATI 제한된 드라이버(fglrx)를 사용하여 잘 사용하고 있었습니다.
10.10으로 버전 갱신한 후, 재부팅하니 X 윈도우 실행이 안됩니다.
aticonfig 실행해 보면 다음과 같은 메시지가 나옵니다.

[code:3hwtvz1y]$ sudo aticonfig
Unable to open /etc/ati/control, please reinstall the driver.
aticonfig: No supported adapters detected
[/code:3hwtvz1y]
GPU는 ATI 내장 그래픽인 HD3300입니다.[/quote:3hwtvz1y]

메시지 그대로 ATI 제한된 드라이버를 새롭게 설치해야할거에요.

ATI는 엔비디아하고는 달리 우분투에서 잡아주는거보다

직접 AMD(ATI) 싸이트가서 매달 나오는 카탈리스트 받아서 수동으로 설치해서 쓰는게

나을거에요. 인터넷 검색해보면 설치법/지우는 법/업데이트 하는 법 찾을 수 있을 것입니다.

물론 드라이버 재설치 여러번 해 봤습니다.

[code:1a5x65wc]
$ sudo aptitude purge fglrx
$ sudo rm /etc/X11/xorg.conf
$ sudo rm -rf /usr/lib/fglrx
$ sudo rm -rf /usr/lib32/fglrx
$ sudo rm -rf /etc/ati
$ sudo reboot
$ sudo apt-get install fglrx
$ aptitude search fglrx
i fglrx - ATI 그래픽 가속기 비디오 드라이버
i A fglrx-amdcccle - ATI 그래픽 가속기 Catalyst Control Center
p fglrx-dev - ATI 그래픽 가속기 비디오 드라이버 (개발 파일)
i fglrx-modaliases - Identifiers supported by the ATI graphics driver
$ sudo aticonfig --initial -f
Unable to open /etc/ati/control, please reinstall the driver.
aticonfig: No supported adapters detected
[/code:1a5x65wc]
우분투 10.10에 포함된 카탈리스트 버전은 10.9 버전으로 최신 버전이었구요. Release Note에 확인해보니, 분명 HD3300 지원으로 나와있던데, 이상하네요.

그냥 10.10 깔구 ATI드라이버 설치해보세요 어덴가 꼬인듯 한데 일단 설치가 제대로 안된거에요.

$ sudo modprobe -f fglrx

해본담에 해보시구요 그래두 안되면 그냥 새로 까심이

그리고 ATI(AMD) 싸이트에서 받아서 깔아보세요 시냅틱 말구요.

하루 지나고 다시 시도해보니 되는군요.

아무튼 ati 그래픽카드는 항상 말썽이군요.

10.10 우분투를 통해서 설치되는 제한 드라이버는 카탈리스트 10.10 pre 버전이라고 하네요.

AMD(ATI)가 우분투를 위해서 특별히 먼저 제공해준거라고 합니다.

이거 깔면 ATI 비디오카드는 문제가 없을거에요.

이전 10.9 버전과 비교해서 괄목한 성능향상과 버그픽스가 되었다고 합니다.