10.10에서 구글어스가 어디갔죠?

10…4까지 구글어스를 잘 사용하다가 10.10으로 업그레이드하였는데
최근에 알아볼 것이 있어서 구글어스를 설치하려고 보니 설치가 되지 않네요.

[우분투 소프트웨어 센터]에 보면 [구글어스] 설치 아이콘은 보이지 않고
[구글어스 패키지]만 보이더군요. 설치를 누르니 설치되어 있는 것으로 나타나기는 하는데 메뉴에는 나타나지 않았습니다.

그래서 구글링을 하면서 콘솔에서 설치를 하는 방법을 시도한라고 나름 노력을 했는데
이번에는 메뉴에 나타나는 것까지는 성공을 했는데 실행해 보면 역시 무소식;;

제가 가지고 있던 정보들이 있어서 폴더를 날릴 수는 없는데 어떻게 하면 새롭게 설치할 수 있나요?
그리고 왜 [우분투 소프트웨어 센터]에 [구글어스] 설치 아이콘이 사라진 것일까요?

[url:hzpmg3uw]http://www.howtoforge.com/how-to-install-google-earth-on-ubuntu-10.10[/url:hzpmg3uw]

[quote="ahavatar":2qt5h9nx][url:2qt5h9nx]http://www.howtoforge.com/how-to-install-google-earth-on-ubuntu-10.10[/url:2qt5h9nx][/quote:2qt5h9nx]

네, 감사합니다.
그런데 제가 참고한 곳이 위 링크 랍니다.
설치하는 도중 무슨 무슨 에러가 있다고 뜬 것 같기는 한데 …
나중에 설치 되었다고 뜨기에 잘 된 줄 알았지요.
그런데 안되더라구요. ㅠ.ㅠ

howto 보니깐 라이브러리가 미리 설치되이ㅆ어야 하고 그러네요. 에러 메시지를 보고 필요한 패키지를 찾아서 설치하고 다시 해보세요. 설치중 에러가 나면 당연히 설치가 안되게ㅆ죠.

[quote:cmrc96yj]choi@choi-laptop:~$ sudo apt-get install ia32-libs
패키지 목록을 읽는 중입니다… 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다… 완료
E: ia32-libs 패키지를 찾을 수 없습니다
[/quote:cmrc96yj]

이렇게 뜨네요 …

[quote="cklove":2f079bow][quote:2f079bow]choi@choi-laptop:~$ sudo apt-get install ia32-libs
패키지 목록을 읽는 중입니다… 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다… 완료
E: ia32-libs 패키지를 찾을 수 없습니다
[/quote:2f079bow]

이렇게 뜨네요 …[/quote:2f079bow]

64비트 우분투는 ia32-libs 설치해줘야 하구요 이건 구글어스가 32비트 앱이여서 호환성모드에서 돌아가게끔 해주죠. 32비트면 ia32-libs 설치 할 필요가 없죠.

아 그렇군요. 그 다음에 …이렇게 하였죠.

[quote:1drvsnlp]choi@choi-laptop:~$ sudo gdebi googleearth_6.0.0.1735+0.5.7-1_i386.deb[/quote:1drvsnlp]

그랬더니 …

[quote:1drvsnlp]choi@choi-laptop:~$ sudo gdebi googleearth_6.0.0.1735+0.5.7-1_i386.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Building data structures… Done
Building data structures… Done

Google Earth, a 3D map/planet viewer
Package built with googleearth-package.
소프트웨어 패키지를 설치하기를 원하십니까? [y/N]:y
(데이터베이스 읽는중 …현재 211773개의 파일과 디렉토리가 설치되어 있습니다.)
googleearth 6.0.0.1735+0.5.7-1 패키지를 대체할 준비하는 중입니다 (googleearth_6.0.0.1735+0.5.7-1_i386.deb 사용) …
대체되는 googleearth 패키지를 푸는 중입니다 …
googleearth (6.0.0.1735+0.5.7-1) 설정하는 중입니다 …
shared-mime-info에 대한 트리거를 처리하는 중입니다 …
Unknown media type in type ‘all/all’

Unknown media type in type ‘all/allfiles’

Unknown media type in type ‘uri/mms’

Unknown media type in type ‘uri/mmst’

Unknown media type in type ‘uri/mmsu’

Unknown media type in type ‘uri/pnm’

Unknown media type in type ‘uri/rtspt’

Unknown media type in type ‘uri/rtspu’

Unknown media type in type ‘fonts/package’

Unknown media type in type ‘interface/x-winamp-skin’

desktop-file-utils에 대한 트리거를 처리하는 중입니다 …
python-gmenu에 대한 트리거를 처리하는 중입니다 …
Rebuilding /usr/share/applications/desktop.ko_KR.utf8.cache…
python-support에 대한 트리거를 처리하는 중입니다 …

choi@choi-laptop:~$
[/quote:1drvsnlp]

이렇게 되네요.
그리고 설치된 줄 알고 기분 좋게 실행을 했더니 소식이 없네요 ㅠ.ㅠ

아 해결했습니다.

그 아래 댓글 단 사람도 안되어서 이렇게 하니까 잘 된다고 씌어 있네요.

[quote:1k5cdi4c]sudo apt-get install lsb-core[/quote:1k5cdi4c]

그래서 그대로 했더니 … 성공했습니다!!!
성실한 답변에 깊이 감사드립니다.

크 lsb-core 문제였군요. 이게 Linux Standard Base 일거에요 리눅스 표준에 맞춰서 구글어스 패키지를 만들었기때문에 이게 있어야 잘되는 모양입니다.