11.04에서 error while loading shared libraries: libXm.so.6?

안녕하세요

우분투 얼마전 11.04 64bit를 설치한 유저입니다.
학업상 필요한 툴들을 설치하고난 뒤, 실행해보니 오류메세지를 만나서 질문을 올리게 되네요.

error while loading shared libraries: libXm.so.6: wrong ELF class: ELFCLASS64

xgterm, ximtool이라는 터미널과 그래픽 툴입니다.
이들은 /usr/local/bin/에 설치되었고, 24비트 X11 display support라고 하네요.

혹시 이에 대해 아시는 분 없으신지요?

학업상 필요한 프로그램들이 혹시 32비트용 아닌가요?
libXm.so는 ia32-libs, lesstif2, libmotif4에서 발견되는군요.
64비트에서 안돌아가는 32비트 실행파일일 경우
위와 같은 오류를 내뿜어요
반대의 경우는 ELFCLASS32라고 나오구요

64비트버젼이 없다면… 훔냥… setarch로 가능할지 어떨지
setarch는 프로그램에 프로세서아키텍쳐를 다른것인것처럼 환경을 변경해줍니다.