우분투 11.04 설치후 또 소리가 안들려요

코분투 11.04를 설치하고 첫 느낌이란 '정말 너무 깔끔하고 좋다’는 것이었습니다.
usb로 부팅할 때와는 달리 속도 빠르고, 특히 파이어 폭스 속도는 엄청 빨라진 것 같네요.
유니티는 익숙치는 않은데도, 신선하다는 느낌과 간편할 것 같다는 생각이 드네요.
어쨌든 저는 대 만족입니다.
특히 맘에 든 것은 분도님께서 기본으로 설치해 주신 바탕화면 벽지 !!!
딱 제 스탈입니다. 헤헤 ^^

근데, 제 노트북이 조금 낯가림을 많이 하나 봅니다(특성을 타는가 봅니다.)
전에 제 노트북의 사운드 문제로 한참 고생했었죠.
다음 글타래를 보시면 아시겠지만 10.10을 설치하면 사운드가 잘 잡히다가
업데이트를 하고나면 소리가 전혀 들리지 않는 것입니다.

viewtopic.php?f=20&t=15364

고생 고생하다가 결국 포기하고 10.04를 사용하고 있었지요.

그런데 이번에 11.04에서도 전혀 소리가 들리지 않네요.
처음 부팅할 때 이어폰으로 들어보면 쏴~하는 소리가 들리다가 우분투로 진입하면서 소리가 딱 끊깁니다.

고수님들의 지도 바랍니다.

노트북 모델이 뭔가요?

일단 터미널에서 [code:2x5wi63f] lspci | grep -i audio [/code:2x5wi63f]라고 입력하시고 사운드카드가 설치가 되어있는지 확인해 보세요.

설치가 되어 있다면 임시방편으로 소리가 나게는 할 수 있습니다.

터미널에서 다음 명령어를 치세용

[code:2x5wi63f]alsamixer[/code:2x5wi63f]

그림처럼 모양이 뜨는걸 확인할 수 있을 겁니다.

[attachment=0:2x5wi63f]al.png[/attachment:2x5wi63f]

볼륨을 올려주세요…

임시방편입니다. 부팅마다 설정해 주셔야할거에요…

완벽하게 고치는 방법은;; 잘 모르겠습니다… ㅎㅎㅎ

위 방법이 틀릴수도;;;ㅎㅎㅎ(저도 초보라 ㅋㅋ)

아 처음에 소리는 난다고 하셨지;; ㅎㅎ (모르겠다;;ㅎㅎ) 혹시 모르니 해보세용 ㅋㅋ

[quote="구임수":3i2ccb49]일단 터미널에서 [code:3i2ccb49] lspci | grep -i audio [/code:3i2ccb49]라고 입력하시고 사운드카드가 설치가 되어있는지 확인해 보세요.

설치가 되어 있다면 임시방편으로 소리가 나게는 할 수 있습니다.

[/quote:3i2ccb49]

기종은 삼보 averatec 1500시리즈입니다. 아래처럼 출력되네요.

[quote:3i2ccb49]
cklove@cklove-1500-Series:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
cklove@cklove-1500-Series:~$
[/quote:3i2ccb49]

말씀하신대로 했는데 소리 안 납니다.
전에 10.10에서도 똑같은 고생 했던 기억이 나네요. ㅠ.ㅠ

https://help.ubuntu.com/community/SoundTroubleshooting

[quote="구임수":245dbwcq]https://help.ubuntu.com/community/SoundTroubleshooting

혹시 이 부분을 읽어보셨는지요;; 링크만 겁니다… 저도 잘 몰라서 ㅠ.ㅠ;[/quote:245dbwcq]

죄송해요. 제가 영어를 몰라서 …

그리고 … 조금 전에 다시 확인해 보니 … 이것도 10.10과 같은 증세인데요…
볼륨을 가장 높게 올리고 이어폰으로 들어보면 작게 소리가 들립니다.
물론 음질은 좋지 않아요. 잡음나는 라디오 듣는 느낌이랄까요?

다음의 패키지 설치

[code:20peg9kf]
sudo apt-get install linux-backports-modules-alsa-natty-generic
[/code:20peg9kf]

다음의 파일을 열어 하단에 추가하고 저장

[code:20peg9kf]
1. /etc/modprobe.d/alsa-base.conf
sudo gedit /etc/modprobe.d/alsa-base.conf <—수정할 파일 열기
options snd-hda-intel model=laptop <—추가할 내용

2. /etc/modules
sudo gedit /etc/modules <—수정할 파일 열기
snd-hda-intel <—추가할 내용
[/code:20peg9kf]

alsa 재시작

[code:20peg9kf]
sudo alsa force-reload
[/code:20peg9kf]

될지 안될지는 신만이 압니다 (먼산)

[quote="yemharc":1lgjsik8]다음의 패키지 설치

[code:1lgjsik8]
sudo apt-get install linux-backports-modules-alsa-natty-generic
[/code:1lgjsik8]
[/quote:1lgjsik8]

감사해요. 그런데 첫번째부터 막히네요 ㅠ.ㅠ

[quote:1lgjsik8]cklove@cklove-1500-Series:~$ sudo apt-get install linux-backports-modules-alsa-natty-generic
패키지 목록을 읽는 중입니다… 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다… 완료
E: linux-backports-modules-alsa-natty-generic 패키지를 찾을 수 없습니다
cklove@cklove-1500-Series:~$ [/quote:1lgjsik8]

그러면 시맨틱에서 검색해보세요.

natty를 포함하고 있는 패키지가 없다면

linux-backports-modules-alsa- 자신의 커널 버전 -generic

이라고 된걸 설치하세요.

자신의 커널 버전을 보는 명령어 : uname -r

패키지명의 커널 버전에 대해서…
2.6.37-23
2.6.37-29
2.6.38-31
2.6.38-33

이런 식으로 있는데 그 숫자가 같은걸로 설치하고, 똑같은 숫자가 없다면 끝의 2자리가 더 높은걸 선택하세요.

p.s.
끝에 pae 가 붙은 패키지는 설치 안해도 됩니다.

와~ 실시간이닷 ^^
시냅틱에서 linux-backports-modules-alsa 라고 하고 검색해 봐도 안나오는데요?
이상하네요.

[quote="cklove":1nb5j6pp]와~ 실시간이닷 ^^
시냅틱에서 linux-backports-modules-alsa 라고 하고 검색해 봐도 안나오는데요?
이상하네요.[/quote:1nb5j6pp]

아… 아마 제 기억이 맞으면 10.10부터는

linux-backports-modules-[b:1nb5j6pp]compat[/b:1nb5j6pp] 인가
linux-backports-[b:1nb5j6pp]compat[/b:1nb5j6pp]-modules 인가

여튼 둘 중 하나로 시작하게끔 바뀌었을겁니다. (<–이렇게 말하는 이사람 2주일 전까지 10.10이었음 ㅠㅠ)

[quote:16btqofy]아… 아마 제 기억이 맞으면 10.10부터는

linux-backports-modules-[b:16btqofy]compat[/b:16btqofy] 인가
linux-backports-[b:16btqofy]compat[/b:16btqofy]-modules 인가

여튼 둘 중 하나로 시작하게끔 바뀌었을겁니다. (<–이렇게 말하는 이사람 2주일 전까지 10.10이었음 ㅠㅠ)[/quote:16btqofy]

아, 찾았습니다.!!!
위 두 가지로 검색했는데 찾지 못하네요 …
그래서 linux-backports로 찾아보니 …
linux-backports-modules-net-2.6.38-8-generic
이것 같아서 설치했습니다. 다음 과정으로 가보겠습니다. 충성 !!

아~~~ 어쩌죠? 소용없네요. 아무것도 변화가 없네요.
어쨌든 감사합니다.

다시 도움을 부탁드릴게요.

[quote="cklove":3hw8vkiu][quote:3hw8vkiu]아… 아마 제 기억이 맞으면 10.10부터는

linux-backports-modules-[b:3hw8vkiu]compat[/b:3hw8vkiu] 인가
linux-backports-[b:3hw8vkiu]compat[/b:3hw8vkiu]-modules 인가

여튼 둘 중 하나로 시작하게끔 바뀌었을겁니다. (<–이렇게 말하는 이사람 2주일 전까지 10.10이었음 ㅠㅠ)[/quote:3hw8vkiu]

아, 찾았습니다.!!!
위 두 가지로 검색했는데 찾지 못하네요 …
그래서 linux-backports로 찾아보니 …
linux-backports-modules-net-2.6.38-8-generic
이것 같아서 설치했습니다. 다음 과정으로 가보겠습니다. 충성 !![/quote:3hw8vkiu]

설치하신 드라이버는 네트워크 드라이버입니다;;;
방금 건져올린겁니다만 이걸 한번 시도해보세요.

[code:3hw8vkiu]
wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
[/code:3hw8vkiu]

[quote="yemharc":2ext9jv4]
설치하신 드라이버는 네트워크 드라이버입니다;;;
방금 건져올린겁니다만 이걸 한번 시도해보세요.

[code:2ext9jv4]
wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
[/code:2ext9jv4][/quote:2ext9jv4]

위 대로 했더니 아래처럼 뜨고 소리는 여전히 크게 나지 않네요. 그리고 혹시나 하고 리부팅 했는데, 마찬 가지입니다.

[code:2ext9jv4]cklove@cklove-1500-Series:~$ sudo wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
[sudo] password for cklove:
–2011-05-04 10:36:39-- http://www.alsa-project.org/alsa-info.sh
Resolving www.alsa-project.org... 77.48.224.243
접속 www.alsa-project.org|77.48.224.243|:80... 접속됨.
HTTP request sent, awaiting response... 302 Found
Location: http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh [following]
–2011-05-04 10:36:50-- http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh
Resolving git.alsa-project.org... 77.48.224.243
Reusing existing connection to www.alsa-project.org:80.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/plain]
Saving to: `alsa-info.sh’

&#91; &lt;=&gt;                                   &#93; 27,247      --&#46;-K/s   in 0&#46;04s   

2011-05-04 10:36:51 (755 KB/s) - `alsa-info.sh’ saved [27247]

ALSA Information Script v 0.4.60

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

dmesg
lspci
lsmod
aplay
amixer
alsactl
/proc/asound/
/sys/class/sound/
~/.asoundrc (etc.)

See ‘alsa-info.sh --help’ for command line options.

Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://www.alsa-project.org/db/?f=af4534d4e9ea0386b4fc704d924032582df02eb3

Please inform the person helping you.

cklove@cklove-1500-Series:~$ [/code:2ext9jv4]

아무래도 10.04로 회귀해야 할까 봐요 ㅠ.ㅠ

사운드가 잡히지 않아 고생 고생하다 드는 생각입니다.
부팅 속도가 확실히 체감 되게 느리고,
인터넷 서핑 중 자주 화면 멈춤(프리징이라고 하나요?)현상
프로그램 돌릴 때도 마찬가지 자주 프리징
버추얼 박스 돌려보니 흐그미 … 버박이 완전 버벅이네요.

사용에 아무 문제 없던 10.04를 버리고
완전 실험 정신과 호기심으로 시작했던 11.04의 여행
이틀 동안 매달려 (아내 눈치 보며 ㅠ.ㅠ) 쏟았던 아까운 시간들…
현재로서는 아련한 추억으로 돌려야 할 것 같다는 쪽으로 마음이 자꾸만 기울어가고 있네요.

포럼 올라오는 글들을 보니 저의 말에 동감하실 분이 한 두 분이 아닐 듯 하네요.

그럼,
10.04는 실패작일까요?

아직도 망설이고 있습니다.
누구 도와주실 분 없으신지요?
소리만 들리면 그냥 사용해 보고 싶은데 …

제가 느끼기에는 비슷한(유사한) 사운드 드라이버가 설치 사용되고 있는거 아닌가 봅니다.

8.10부터 우분투가 사용하는 펄스오디오 라는게 기본적으로는 알사를 이용합니다.

해결법으로는
sudo gedit /etc/modprobe.d/alsa-base.conf
하여 모델을 정확히 적어 주는것인데…

저도 사용하시는 노트북의 사운드 칩을 모르니
참고 링크만 적을 수 밖에 없습니다.

https://help.ubuntu.com/community/SoundTroubleshooting https://help.ubuntu.com/community/HdaIntelSoundHowto

[quote="강분도":7ko9sgou]해결법으로는
sudo gedit /etc/modprobe.d/alsa-base.conf
하여 모델을 정확히 적어 주는것인데…
[/quote:7ko9sgou]

위 말씀하신대로 하니 아래와 같은 에러 메세지가 뜨구요 …

[code:7ko9sgou]cklove@cklove-1500-Series:~$ sudo gedit /etc/modprobe.d/alsa-base.conf
[sudo] password for cklove:

(gedit:17249): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel’, but failed: 파일 ‘/root/.local/share/recently-used.xbel.KTUIVV’ 만들기 실패: 그런 파일이나 디렉터리가 없습니다

(gedit:17249): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel’, but failed: 그런 파일이나 디렉터리가 없습니다
^Ccklove@cklove-1500-Series:~$ [/code:7ko9sgou]

gedit가 뜨면서 이런 메시지를 출력하네요. 파일 이름은 alsa-base.conf가 맞습니다.

[code:7ko9sgou]# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

Cause optional modules to be loaded above generic modules

install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }

Workaround at bug #499695 (reverted in Ubuntu see LP #319505)

install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }

Cause optional modules to be loaded above sound card driver modules

install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)

install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }

Prevent abnormal drivers from grabbing index 0

options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-hda-intel model=laptop

Ubuntu #62691, enable MPU for snd-cmipci

options snd-cmipci mpu_port=0x330 fm_port=0x388

Keep snd-pcsp from being loaded as first soundcard

options snd-pcsp index=-2

Keep snd-usb-audio from beeing loaded as first soundcard

options snd-usb-audio index=-2[/code:7ko9sgou]

한 이틀 가까이를 틈틈이 찾아봤는데 도저히 해결법을 모르겠습니다.
일단 [url=http&#58;//www&#46;kernel&#46;org/doc/Documentation/sound/alsa/HD-Audio-Models&#46;txt:105lv530]kernel.org[/url:105lv530]에 정리된 사운드 카드 모듈 리스트는 건져올렸는데, 이번엔 반대로 cklove님의 노트북에 관한 정보를 찾을수가 없습니다!

삼보 에버라텍이 해외에는 다른 이름으로 출시되고 있는건가요?;;

일단 리스트도 있고 바로 위에 분도님의 링크에 있는 howto 문서에 방법도 적혀 있으니 노트북에 관한 정보만 알아내면 될거같습니다. (…)