우분투 11.10 버전에서 업그레이드... 서드 파티 소스는 사용할 수 없습니다

우분투 11.01을 다운받아 12.04로 업그레이드 하려고 했더니…

서드 파티 소스는 사용할 수 없습니다…

source.list 에서 서드 파티 목록의 일부를 이용할 수 없습티다. 업그레이드를 마친 후 ‘소프트웨어 소스’ 도구나 패키지 관리자를 이용해 다시 사용 할 수 있습니다.

라고 뜨는데요… 업그레이드 하고 저 메시지대로 하려면 어찌해야 하나요…

오늘 처음 리눅스 접해보는 초보자 ‘ㅅ’;;

우분투를 업그레이드하게 되면… 배포판이 바뀌는 것이라… 소프트웨어 저장소의 설정을 바꿔버립니다.
11.10인 oneiric에서 12.04인 precise로 바뀌게 되죠.
그리고 서드파티 소프트웨어 목록들은 주석처리 해버립니다.

그래서, 업그레이드 한 후에 저장소를 변경하시려면…
/etc/apt/sources.list 와 /etc/apt/sources.list.d/*.list 파일들을 열어서…
주석처리된 부분을 주석해제하시고(맨앞의 #을 없앰)
oneiric을 precise로 바꿔줘야 합니다. 물론 일부는 precise를 지원하지 않을 수 있습니다.
그럴경우는 그냥 oneiric으로 넵두고… 12.04 지원할 때 까지 기다려 보던가… 다른 소프트웨어 저장소로 변경하셔야 겠죠.

물론 software-properties-gtk를 실행하여 바꾸실 수도 있습니다만…
sed를 이용해 한번에 바꾸는게 편하실 겁니다.

[code:qk1iwqoi]
#백업하기
sudo mkdir /etc/apt/oldsources
sudo cp -Rf /etc/apt/sources.list /etc/apt/sources.list.d /etc/apt/oldsources

#oneiric을 precise로 변경하기
sudo sed -Ei ‘/^#\s*(deb|deb-src) .oneiric/{s/^#\sdeb/deb/g;s/oneirc/precise/g}’ /etc/apt/sources.list /etc/apt/sources.list.d/*

#써드파티 소프트웨어 업그레이드
sudo apt-get update
sudo apt-get upgrade
[/code:qk1iwqoi]

감사합니다. 해결 잘 봤습니다 ^ㅁ^