14.04 에서 다음클라우드 실행 도움바랍니다

밑에 14.04 다음클라우드 실행이 되지 않는다고 글올린사람입니다.

현재 는 xubuntu 14.04 에서 소프트웨어 관리자에서

Java, nautilus, nautilus extenstion, gnome full package 설치이후엔 잘 작동이 됩니다.

그런데 이렇게 설치하니 설치되는 것이 너무 많아서 xubuntu 의 깔끔함이 없어지는 듯 합니다.
(특히 gnome package는 게임까지 설치되더군요)

위에서 설치꾸러미 중에서도 다움 클라우드 실행시 꼭 필요한 것을 알수 있을까요???
(위설치중 하나라도 빠지면 다음 클라우드 실행이 되지 않습니다.)

세가지 명령어로 알 수 있습니다.

  1. 먼저 deb 패키지 내용물을 풉니다.

[code:rkj3cv7u]
yemharc@elpholize:~/test$ ls
daumcloud_1.1.0.45.deb

yemharc@elpholize:~/test$ ar -x daumcloud_1.1.0.45.deb

yemharc@elpholize:~/test$ ls
control.tar.gz data.tar.gz daumcloud_1.1.0.45.deb debian-binary
[/code:rkj3cv7u]

  1. control.tar.gz 파일의 압축을 풉니다.

[code:rkj3cv7u]
yemharc@elpholize:~/test$ tar xvf control.tar.gz
./
./copyright
./control
./postrm
./postinst

yemharc@elpholize:~/test$ ls
control control.tar.gz copyright data.tar.gz daumcloud_1.1.0.45.deb debian-binary postinst postrm
[/code:rkj3cv7u]

  1. control 파일의 내용에서 의존성 부분을 grep하여 뽑아냅니다.

[code:rkj3cv7u]
yemharc@elpholize:~/test$ ls
control control.tar.gz copyright data.tar.gz daumcloud_1.1.0.45.deb debian-binary postinst postrm

yemharc@elpholize:~/test$ grep Depends control
Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.6.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.12.0), libpango1.0-0 (>= 1.20.1), openssl (>= 0.9.8)
[/code:rkj3cv7u]

최종적으로 알 수 있는 의존성 패키지 리스트는 다음과 같습니다.

libatk1.0-0
libc6
libcairo2
libglib2.0-0
libgtk2.0-0
libpango1.0-0
openssl

P.S.
저장소에 이미 있는 패키지들(=apt-get으로 설치 가능한 패키지들)의 경우에는 다음과 같은 방식으로 쉽게 알아낼 수 있습니다.

[code:rkj3cv7u]
=> apt-rdepends (기본설치가 아니니 사용하기 위해서는 먼저 apt-get install apt-rdepends로 설치해주세요)

yemharc@elpholize:~/test$ sudo apt-rdepends tcpdump

Reading package lists... Done
Building dependency tree
Reading state information... Done
tcpdump
Depends: libc6 (>= 2.14)
Depends: libpcap0.8 (>= 1.0.0)
Depends: libssl1.0.0 (>= 1.0.0)
libc6
Depends: libc-bin (= 2.15-0ubuntu10)
Depends: libgcc1
Depends: tzdata
libc-bin
libgcc1
Depends: gcc-4.6-base (= 4.6.3-1ubuntu5)
Depends: libc6 (>= 2.14)
PreDepends: multiarch-support
gcc-4.6-base
multiarch-support
Depends: libc6 (>= 2.3.6-2)
[/code:rkj3cv7u]

참고하세요.