20.0.4 lts에서 그래픽 드라이버 설치 오류

안녕하세요 우분투 운영체제의 노트북에서 그래픽 드라이버를 설치하는데 있어서 망가진 패키지가 있다고 나오며 설치가 되지않아
해당 문제에 있어서 해결 방안을 가지신분이 계실까해서 질문 남깁니다,ㅠㅠ

PC의 사양은 cpu ryzen9 4900H 그래픽 1660Ti 입니다.


ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.1/0000:01:00.0 ==
modalias : pci:v000010DEd00002191sv00001043sd000016FFbc03sc00i00
vendor : NVIDIA Corporation
model : TU116M [GeForce GTX 1660 Ti Mobile]
manual_install: True
driver : nvidia-driver-418-server - distro non-free
driver : nvidia-driver-440-server - distro non-free
driver : nvidia-driver-455 - distro non-free recommended
driver : nvidia-driver-450 - distro non-free
driver : nvidia-driver-450-server - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin





$ sudo apt-get install aptitude
패키지 목록을 읽는 중입니다… 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다… 완료
다음의 추가 패키지가 설치될 것입니다 :
aptitude-common libcgi-fast-perl libcgi-pm-perl libclass-accessor-perl
libcwidget4 libfcgi-perl libio-string-perl libparse-debianchangelog-perl
libsub-name-perl libxapian30
제안하는 패키지:
aptitude-doc-en | aptitude-doc apt-xapian-index debtags tasksel
libcwidget-dev libhtml-template-perl libxml-simple-perl xapian-tools
다음 새 패키지를 설치할 것입니다:
aptitude aptitude-common libcgi-fast-perl libcgi-pm-perl
libclass-accessor-perl libcwidget4 libfcgi-perl libio-string-perl
libparse-debianchangelog-perl libsub-name-perl libxapian30
0개 업그레이드, 11개 새로 설치, 0개 제거 및 343개 업그레이드 안 함.
4,325 k바이트 아카이브를 받아야 합니다.
이 작업 후 19.9 M바이트의 디스크 공간을 더 사용하게 됩니다.
계속 하시겠습니까? [Y/n] Y
받기:1 Index of /ubuntu focal/universe amd64 aptitude-common all 0.8.12-1ubuntu4 [1,711 kB]
받기:2 Index of /ubuntu focal/universe amd64 libcwidget4 amd64 0.5.18-5build1 [306 kB]
받기:3 Index of /ubuntu focal/universe amd64 libxapian30 amd64 1.4.14-2 [661 kB]
받기:4 Index of /ubuntu focal/universe amd64 aptitude amd64 0.8.12-1ubuntu4 [1,323 kB]
받기:5 Index of /ubuntu focal/main amd64 libcgi-pm-perl all 4.46-1 [186 kB]
받기:6 Index of /ubuntu focal/main amd64 libfcgi-perl amd64 0.79-1 [33.1 kB]
받기:7 Index of /ubuntu focal/main amd64 libcgi-fast-perl all 1:2.15-1 [10.5 kB]
받기:8 Index of /ubuntu focal/main amd64 libsub-name-perl amd64 0.26-1 [11.5 kB]
받기:9 Index of /ubuntu focal/universe amd64 libclass-accessor-perl all 0.51-1 [21.2 kB]
받기:10 Index of /ubuntu focal/main amd64 libio-string-perl all 1.08-3 [11.1 kB]
받기:11 Index of /ubuntu focal/universe amd64 libparse-debianchangelog-perl all 1.2.0-13 [49.7 kB]
내려받기 4,325 k바이트, 소요시간 6초 (702 k바이트/초)
Selecting previously unselected package aptitude-common.
(데이터베이스 읽는중 …현재 152353개의 파일과 디렉터리가 설치되어 있습니다.)
Preparing to unpack …/00-aptitude-common_0.8.12-1ubuntu4_all.deb …
Unpacking aptitude-common (0.8.12-1ubuntu4) …
Selecting previously unselected package libcwidget4:amd64.
Preparing to unpack …/01-libcwidget4_0.5.18-5build1_amd64.deb …
Unpacking libcwidget4:amd64 (0.5.18-5build1) …
Selecting previously unselected package libxapian30:amd64.
Preparing to unpack …/02-libxapian30_1.4.14-2_amd64.deb …
Unpacking libxapian30:amd64 (1.4.14-2) …
Selecting previously unselected package aptitude.
Preparing to unpack …/03-aptitude_0.8.12-1ubuntu4_amd64.deb …
Unpacking aptitude (0.8.12-1ubuntu4) …
Selecting previously unselected package libcgi-pm-perl.
Preparing to unpack …/04-libcgi-pm-perl_4.46-1_all.deb …
Unpacking libcgi-pm-perl (4.46-1) …
Selecting previously unselected package libfcgi-perl.
Preparing to unpack …/05-libfcgi-perl_0.79-1_amd64.deb …
Unpacking libfcgi-perl (0.79-1) …
Selecting previously unselected package libcgi-fast-perl.
Preparing to unpack …/06-libcgi-fast-perl_1%3a2.15-1_all.deb …
Unpacking libcgi-fast-perl (1:2.15-1) …
Selecting previously unselected package libsub-name-perl.
Preparing to unpack …/07-libsub-name-perl_0.26-1_amd64.deb …
Unpacking libsub-name-perl (0.26-1) …
Selecting previously unselected package libclass-accessor-perl.
Preparing to unpack …/08-libclass-accessor-perl_0.51-1_all.deb …
Unpacking libclass-accessor-perl (0.51-1) …
Selecting previously unselected package libio-string-perl.
Preparing to unpack …/09-libio-string-perl_1.08-3_all.deb …
Unpacking libio-string-perl (1.08-3) …
Selecting previously unselected package libparse-debianchangelog-perl.
Preparing to unpack …/10-libparse-debianchangelog-perl_1.2.0-13_all.deb …
Unpacking libparse-debianchangelog-perl (1.2.0-13) …
libxapian30:amd64 (1.4.14-2) 설정하는 중입니다 …
libcgi-pm-perl (4.46-1) 설정하는 중입니다 …
libio-string-perl (1.08-3) 설정하는 중입니다 …
libcwidget4:amd64 (0.5.18-5build1) 설정하는 중입니다 …
aptitude-common (0.8.12-1ubuntu4) 설정하는 중입니다 …
aptitude (0.8.12-1ubuntu4) 설정하는 중입니다 …
update-alternatives: using /usr/bin/aptitude-curses to provide /usr/bin/aptitude (aptitude) in auto mode
libsub-name-perl (0.26-1) 설정하는 중입니다 …
libfcgi-perl (0.79-1) 설정하는 중입니다 …
libclass-accessor-perl (0.51-1) 설정하는 중입니다 …
libcgi-fast-perl (1:2.15-1) 설정하는 중입니다 …
libparse-debianchangelog-perl (1.2.0-13) 설정하는 중입니다 …
Processing triggers for man-db (2.9.1-1) …
Processing triggers for libc-bin (2.31-0ubuntu9) …
handeur@handeur:~$ sudo aptitude -f install
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 343 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

~$ sudo apt install nvidia-driver-455
패키지 목록을 읽는 중입니다… 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다… 완료
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다:
nvidia-driver-455 : 의존: libnvidia-gl-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: libnvidia-compute-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: libnvidia-extra-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: nvidia-compute-utils-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: libnvidia-decode-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: libnvidia-encode-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: nvidia-utils-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: xserver-xorg-video-nvidia-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: libnvidia-cfg1-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: libnvidia-ifr1-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
의존: libnvidia-fbc1-455 (= 455.38-0ubuntu0.20.04.1) 하지만 %s 패키지를 설치하지 않을 것입니다
추천: libnvidia-compute-455:i386 (= 455.38-0ubuntu0.20.04.1)
추천: libnvidia-decode-455:i386 (= 455.38-0ubuntu0.20.04.1)
추천: libnvidia-encode-455:i386 (= 455.38-0ubuntu0.20.04.1)
추천: libnvidia-ifr1-455:i386 (= 455.38-0ubuntu0.20.04.1)
추천: libnvidia-fbc1-455:i386 (= 455.38-0ubuntu0.20.04.1)
추천: libnvidia-gl-455:i386 (= 455.38-0ubuntu0.20.04.1)
E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.

리눅스 배포판에선 무엇을 설치하기전에 패키지 목록 데이타베이스언제나 최신상태로 유지해주셔야합니다.

우분투에선 다음과 같은 명령어로 그걸 가능케해줍니다.

sudo apt update

그리고 실제 하드디스크에 설치된 패키지들을 최신상태로 판올림하는 명령어도 실행해줍니다.

sudo apt upgrade

그리고 난 연후에서야, 새롭게 설치하고픈 패키지들을 설치합니다.

[크롬북에서 적었어유~~~]