8.04.1 파폭에서 플래시 플러그인 깔라고 나와서 깔았는데

어제 삼보 넷 북에 8.04.1 클린인스톨을 했습니다. 언제나처럼 파이어폭스로 다음을 들어가니 플러그인 깔겠냐고 나오더군요.

그래서 깔겠다고 했더니 언제나처럼 3개 중에서 Adobe Flash Player가 디폴트로 선택이 되어 있었습니다. 확인을 했더니 flashplugin-nonfree가 깔렸습니다.

그런데 플래시 있는 사이트 들어갈 때마다 계속 노란 메시지가 다시 뜨는 겁니다.

그래서 프로그램 추가/삭제로 가서 확인해 봤더니 "Macromedia flash plugin"이 깔려있더군요. 그래서 이걸 지우고 몇 칸 아래에 있는 Adobe Flash Plugin 10을 설치했더니 해결되었습니다.

예전에는 파폭으로 플래시 있는 사이트 아무데나 간 다음에 깔겠냐는 메시지 나올 때 확인하면 끝이었는데…언제부터 이런 증상이 생겼는지 모르겠네요…

최종적으로 인스톨 된 패키지명은 아래와 같습니다:
adobe-flashplugin (첨부파일 참고)

결론적으로 예전에는 플래시 있는 사이트 들어가서 확인 누르면 adobe-flashplugin을 깔았는데 최근에 와서는 확인하면 flashplugin-nonfree를 까는 걸로 바뀌었다는 것인데…이거 참…왜 그렇게 일관되게 관리를 못하는건지…-_-

예전에도 플래시의 패키지명은 flashplugin-nonfree 였고 지금도 같은 이름으로 제공되고 있습니다.

패키지명이 adobe-flashplugin인거 아마 우분투팀이 아닌 다른곳에서 패키지를 생성하고 이름을 부여한게 아닐까요.

간단합니다. flashplugin-nonfree는 인스톨러일 뿐이고, adobe-flashplugin은 플래쉬를 직접 설치하는 패키지입니다.

두개의 차이가 왜 생겼냐면 플래쉬는 폐쇄 소프트웨어이기 때문입니다. 우분투는 기본적으로 GNU/Linux를 내세우고 있기 때문에 독점 코드가 있는 소프트웨어를 기본으로 설치할 수 없습니다. 그래서 플래쉬 같은 경우도 인스톨러만 설치하고, 패키지 설치하는 과정에서 웹에서 플래쉬를 다운받아서 설치합니다. 근데 이 방식이 몇가지 이유 때문에 잘 안되는 경우가 있습니다.(미러가 막혔거나 파일의 버전이 갑자기 올라갔거나)

프로그램 추가/제거 에서 나오는 저 플러그인은 우분투 파트너 저장소에서 제공하는 것입니다. 캐노니컬은 자유소프트웨어의 한계(?)를 극복하기 위하여 독점 소프트웨어를 제공하는 회사들과 제휴를 하여 파트너 저장소에서 그런 소프트웨어들을 배포합니다. VMWare와 페러렐즈, 야후, 어도비 등등의 회사와 제휴를 하고 있습니다. 어도비의 경우엔 초기엔 어도비 리더가 있었지만 캐노니컬에서 제휴를 파기했다고 합니다.(이유는 잘-_=;)

아…그러니까 flashplugin-nonfree는 단순한 인스톨러일 뿐이고 실제 아도브 플러그인은 adobe-flashplugin이라는거군요…

예전: 파폭에서 3개 중에서 고르라고 할 때 Adobe를 고르면 결과적으로 인스톨러를 선택하는 것이 됨->그 인스톨러가 실제 아도브 플래시를 설치

지금: 인스톨러가 왠일인지 아도브 플래시를 못 가져오고 있음

이렇게 되는 거군요