우분투 9.04를 설치했는데요,,, 절전모드에 문제가 있어요 ㅜ,ㅠ

엊저녁에 우분투 9.04를 설치했습니다.
8.04에서 바로 9.04로 올라간 셈인데요, 불만스런 점이 몇 개 보이네요
컴터는 에버라텍 노트북입니다.

  1. Fn키로 화면조정시 계속 "가장 밝기"로 유지가 됩니다. 재부팅을 해도 마찬가지예요
    (이건 우분투 8.10에서도 있었던 문제입니다 )

  2. Fn키로 음량 조정시 키보드가 먹통이 되어버립니다. 심지어는 마우스가 먹통 되는 일도…
    그래서 눈물을 머금고 재부팅을 시켜야 하는 일이 생기더군요

  3. 가장 큰 문제~~!!!
    9.04 상태에서 절전모드를 들어갔습니다. 그런데 문제는
    절전 모드에서 다시 원래대로 돌아오려고 하니 까만화면에서 그대로 있는 겁니다.
    우분투를 다시 설치해도 그건 마찬가지이더군요
    이거 어떻게 고칠 수 있는 방법이 없을까요~?

새론 버전에 대한 기대가 참 컸었습니다… 8.04를 쓰다가 8.10을 써보니 맘에 안들어서
6개월을 버텼거든요… 근데, 9.04도 위의 문제가 있어서 참 아쉽습니다.
아시는 분 있으시다면, 저와 같은 증세를 겪은 분이 계시다면 도와주세요~~~~

=)

저도 초보라 다른건 잘 모르겠고…
절전모드의 경우는 스왑 파티션의 용량이 램 용량보다 적으면
그런 증상이 발생합니다.

[quote="sdnrui":32lwlxrs]저도 초보라 다른건 잘 모르겠고…
절전모드의 경우는 스왑 파티션의 용량이 램 용량보다 적으면
그런 증상이 발생합니다.[/quote:32lwlxrs]

저의 경우엔,
스왑 파티션을 1기가로 했습니다. 8.04 우분투를 쓸때와 마찬가지로요
그런데 8.04에서는 되던게 9.04에서는 안되어서 걱정이네요…

제 우분투는 2.5GB로 잡아주네요. 램이 2GB라서 자동으로 그런가봅니다.

램 크기와 같거나 램 크기보다 크게 스왑을 잡아보세요.

어디선가 suspend와 hibernate를 제대로 사용하려면,
램 크기와 스왑 크기가 같아야 문제 없다고 본 것 같네요.

절전모드를 정상적으로 사용하실려면, 현재 장착한 램보다 스왑파티션의 크기가 더 커야 합니다…

왜냐하면 절전모드를 쓸때 램에 있는 모든 정보를 모두 스왑파티션에 넣기 때문입니다…
(MS 윈도우즈 시스템은 램 저장파일을 아무데나 때려박습니다.)

저같은 경우에는 램과 스왑파티션의 크기를 같게 잡으니까 절전모드 쓰면 그대로 시스템 정지되었습니다…

스왑 파티션 크기를 장착한 램의 크기보다 500MB 더 크게 잡으시면 문제 없을껍니다… :mrgreen: :mrgreen:

일단 밝기조정 문제는 검색하시면 나오구요…
(저는 해결했음… 별거아님 설정파일 몇글자만 고쳐주면 됨.)

스왑이 물리메모리보다 좀더 커야하는건
평소때 가상메모리 스왑+물리메모리 저장 을 해야해서일겁니다.

제 컴퓨터 램 용량은 2기가 + 512 메가 = 2.5기가 램입니다

그렇다면 램 용량을 3기가로 해주어야겠군요…

8.04에서는 1기가로 스왑 파티션 해도 문제가 없었는데… 2기가나 스왑으로 더 증설해야한다니 고민이네요-

좋은 조언 감사합니다-

아… 절전모드를 안쓰다보니 이걸 몰랐군요. 생각해 보면 당연한건데… ;;; 이것도 모르고 주변에는 스왑크기를 작게잡아도 된다고 해 버렸던… ㅠ.ㅠ

뭐 그 중에 제대로 리눅스 쓰게 된 사람이 없다는건 불행중 다행이려나요. 다들 그냥 깨작거리다 방치… 흑.

암튼 좋은거 배웠습니다. ;;;

절전 모드와 최대 절전 모드는 다릅니다. 최대 절전 모드로 들어갈 때는 메모리에 있는 것을 swap에 모두 때려 넣지만, 절전 모드는 아닌 것으로 아는데요. 참고로 저의 경우 램이 2G이고 swap은 500M입니다. 그런데도 절전 모드는 문제 없이 잠들었다가 문제 없이 깨어납니다. cache를 빼고 메모리 실사용량만을 따져도 대충 500M는 충분히 넘습니다. 물론 최대 절전 모드를 하면 swap이 모자란다는 메시지를 내고 최대 절전모드로 잠드는 것을 중지하죠.

절전 모드 들어갔다가 다시 나오는 것에 문제가 있는 것은 아마 다른 문제일 가능성이 더 큽니다. (이런… 무책임한 발언 ㅠ.ㅠ) 사용하시는 하드웨어에 따른 각종 드라이버 문제거나 할 겁니다. usb라거나 네트웍 카드 드라이버라든가 그런 것이 대체로 문제를 많이 일으키는 것 같더군요. 아무래도 사람 많은 영문 포럼에서 비슷한 하드웨어에 대해서 검색해 보시는 것이 좋을 것 같습니다.

[quote="Lbird":3j67dwgw]물론 최대 절전 모드를 하면 swap이 모자란다는 메시지를 내고 최대 절전모드로 잠드는 것을 중지하죠.
[/quote:3j67dwgw]

우분투 9.04 64비트 쓰는데 제껀 스왑 모자르다는 메시지 내고 죽어버리더군요.( 최대 절전 모드 할때…)

ctrl alt backspace도 안먹어요.

최대 절전모드로 들어가는걸 자동으로 중지 하는건 따로 설정해야 하나요?

[quote="oppor":31awezak][quote="Lbird":31awezak]물론 최대 절전 모드를 하면 swap이 모자란다는 메시지를 내고 최대 절전모드로 잠드는 것을 중지하죠.
[/quote:31awezak]

우분투 9.04 64비트 쓰는데 제껀 스왑 모자르다는 메시지 내고 죽어버리더군요.( 최대 절전 모드 할때…)

ctrl alt backspace도 안먹어요.

최대 절전모드로 들어가는걸 자동으로 중지 하는건 따로 설정해야 하나요?[/quote:31awezak]
음… 잠시 기억을 돌이켜 보자면… 음… 특별히 뭘 설정한 기억은 없는데요. 8.04 때는 VAIO에서 이것 저것 안되는 것이 많아서 손을 많이 댔었는데, 9.04에서는 데스크탑 꾸미기 빼고는 특별히 손을 댄 기억이 없습니다. vaio 사용자로서는 참 만족입니다. 8.04 때는 절전/최대절전 들어갈 때 실행되는 스크립트에 무슨 모듈을 빼고, 깨어나는 스크립트에 그 모듈 다시 올리고 하는 부분들을 몇개 추가했었습니다. 그러고도 최대 절전 모드는 결국 안 됐던 기억이… 일단 비슷한 하드웨어 사용하시는 분들의 경험담을 찾아보는 것이 좋을 것 같군요.

뱀다리: 108번째 글이군요. 번뇌가 밀려 옵니다. ㅠ.ㅠ

스왑파티션의 크기를 램크기보다 크게 해도 '최대절전모드(hibernate)'에 문제가 있는 분은
아래를 참고해보세요…원래는 8.1에서 최대절전후 복구시 사운드 문제있을때 사용하는 방법인데
혹시나 도움이 될 지도 모른다는 생각이 듭니다.

sudo vim(또는 gedit) /etc/default/acpi-support 해서
HIBERNATE_MODE=shutdown 을
HIBERNATE_MODE=platform 로 바꿔주시고 저장

이렇게 해도 효과 없을시 다시 되돌리는거 잊지 마시구요…

http://ubuntuforums.org/showthread.php?t=294275

[quote:1v95hrze]
Another fix working for many users without having to install another kernel seems to set another hibernation mode in the acpi settings.

To try this edit /etc/default/acpi-support
and set ‘HIBERNATE_MODE=shutdown’
to ‘HIBERNATE_MODE=platform’

If hibernation still works, you should have sound again. If not, undo the changes.
This solution was posted in the same bug thread mentioned above.
[/quote:1v95hrze]

위의 말씀처럼 스왑 용량을 램 용량보다 더 많게 하여
우분투 9.04를 다시 설치햇습니다.

그렇게 했는데도, 절전 모드시 노트북이 먹통이 되는 문제는 여전하더군요
(최대 절전 모드는 문제 없이 잘 됩니다)

어떤 문제이려는지… 다른 분들은 최대 절전 모드의 문제를 얘기하시는데
제 컴터만 절전모드의 문제가 아닌가 싶습니다.

이거 어떻게 해야할지… 답답하네요
(정 안되면 이전 8.04.1 버전으로 돌아가려구요…)

전 노트북 사용자는 아니고 데스크탑 사용자입니다.
대부분 사람들이 데스크탑에선 절전/최대절전을 사용하지 않던데요.
전 자주/매일/늘~ 사용하고 있습니다.
그러나… 제가 절전관련 글을 몇개 올렸었는데, 호응도는 빵(!)에 가까왔습니다. ^^

암튼, 각설하고…
저도 Jaunty 를 처음에 설치하고 나서는 절전/최대절전에 문제가 있었습니다.
잠은 드나 깨어나지 못하는 문제가 있었는데요.
그래픽 드라이버를 바꿔준 후로는 그 문제가 해결되었습니다.
(Nvidia 그래픽 카드를 사용합니다.)

그래픽 드라이버는 Nvidia 에서 배포하는 것을 사용했습니다.
제 경우는 우분투에서 기본 제공하는 드라이버가 절전기능과 좀 문제가 있었던 것 같습니다.

그래픽 드라이버 문제도 고려해보시길…

여담으로, Jaunty 를 약 일주일 정도 써본 소감이라면,
충분히 기존 판에서 판올림할 가치가 있다라고 간단히 말씀드리고 싶습니다.

절전/최대절전문제만 해도 Jaunty 에는 별 문제가 없습니다.
Intrepid 에선, 제가 여기에도 올린 글에서 말씀드렸었지만, 설정을 고치지 않으면 이상 동작을 하기도 했습니다.
노틸러스도 아이콘 뷰로 하지 않아도 복사가 되고(Intrepid 까진 파일 복사를 하려면 아이콘 보기로 해야만 가능했었죠.), GUI 동작 속도도 훨씬 빨라진 느낌이 듭니다.

암튼!
꼭 성공하시기 바랍니다.

[quote="nemonein":184v98jt]암튼, 각설하고…
저도 Jaunty 를 처음에 설치하고 나서는 절전/최대절전에 문제가 있었습니다.
잠은 드나 깨어나지 못하는 문제가 있었는데요.
그래픽 드라이버를 바꿔준 후로는 그 문제가 해결되었습니다.
(Nvidia 그래픽 카드를 사용합니다.)

그래픽 드라이버는 Nvidia 에서 배포하는 것을 사용했습니다.
제 경우는 우분투에서 기본 제공하는 드라이버가 절전기능과 좀 문제가 있었던 것 같습니다.

그래픽 드라이버 문제도 고려해보시길…[/quote:184v98jt]

제 노트북은 에버라텍 6800 입니다.
그래픽 드라이버의 문제로 9.04에서 절전모드가 안되는가보군요… 8.04에서는 잘 되었었는데… ㅜ,ㅠ
그래픽 드라이버의 문제라면, 어떻게 드라이버를 다시 잡아줘야할지 모르겠습니다…