Apt-get update 실행시 오류가 납니다

sudo apt-get update 하면 오류가 주르륵 뜹니다. 의미가 있을 만한건 다음과 같습니다…
처음 몇줄은 이런 메시지가 반복됩니다. 구글링 내공이 약해서 그런지 아직 답을 못찾고
벌써 일주일째 해메고 있습니다. T.T 어디를 어떻게 해봐야 좋을지요?

[code:1xynguhv]56% [14 Translation-en_US bzip2 0] [Connecting to kr.archive.ubuntu.com (143.248.234.110)] [Connecting tobzip2: (stdin) is not a bzip2 file.
[/code:1xynguhv]
그리고 죽 내려가다가 이런 메시지가 있습니다.

[code:1xynguhv]Get:58 http://kr.archive.ubuntu.com hardy-backports/universe Sources [18.6kB]
Hit http://kr.archive.ubuntu.com hardy-backports/multiverse Sources
Fetched 251kB in 16s (15.6kB/s)
W: GPG error: http://archive.canonical.com hardy Release: The following signatures were invalid: NODATA 1 NODATA 2
[/code:1xynguhv]
제일 마지막에는 다음 오류가 뜹니다.

[code:1xynguhv]E: Some index files failed to download, they have been ignored, or old ones used instead.[/code:1xynguhv]

apt-get update 가 안되는 이유는

  1. 인터넷이 안된다
    이건 인터넷 되게 고쳐야 겠고
  2. 저장소 서버가 안된다 (위 같이 한국 기본인 카이스트 미러 경우 가끔 잘 안됩니다.)
    저장소를 변경 해보십시요.
    주저장소 또는 다음 미러로…
    다음 저장소 참고 링크 : http://opensea.egloos.com/3702461

이 문제는 방화벽에 가로막혀 인터넷이 안되었기 때문에 나는 오류였습니다. 해결되었습니다.