Apt-get을 이용한 설치 나오는 에러인데요

아래 그림과 같이 에러가 납니다. ㅠㅠ

어떻게 접근해서 해결해야 할지 전혀 모르겠네요…

부탁드립니다.

우선 페키지 업을 하시고
sudo apt-get update && sudo apt-get upgrade

그리고도 같은 메세지 나오면
samba 서버 이용중이면 samba 서버 설정을 해보시기 바랍니다.

sudo apt-get upgrade 를 실행한 결과 아래와 같네요 결국엔 samba를 설정해주면 되는걸까요?

sudo apt-get -f install 해주고 그래도 나오면
cd /var/cache/apt/archives 이동하여 sudo dpkg -i --force-overwrite samba*.deb 해주십시요