망할놈의 bcm 무선랜카드~~~ 도움이 절실하네요.. ㅠ..ㅠ

현재 노트북에 Win7과 Ubuntu를 듀얼부팅으로 사용하고 있습니다.
당연히 Win7에서는 아무런 문제가 없습니다. 윈도 드라이버는 아주아주 잘 만들어내는 것 같네요.
한가지 신기한 것은 Ubuntu에서는 BCM4328로 디바이스가 표시되는데 Win7에서는 BCM4322로
나옵니다. 아무튼 Win7에서는 그리고 이전에 사용하던 WinXP에서도 아무런 문제가 없었습니다.

하지만 우분투에서만은 항상 무선랜 접속이 어려웠습니다. 저도 한 때 ndiswrapper를 사용했지만
그것도 그다지 안정적이지를 못해서 몇 날 며칠을 구글링을 통해서 답을 알 수가 있었죠.
Broadcom에서 제공하는 리눅스용 드라이버가 있더군요. 설명서에 나오는대로 컴파일을 하고
모듈을 띄웠지만 안되더군요. 한참을 더 검색을 해본 결과 /etc/rc.local 파일에

[code:1jlkyr4e]
modprobe -r wl b43 b44 ndiswrapper ssb b43legacy
modprobe ieee80211_crypt_tkip
insmod /home/sfeone/.driver/wl.ko
[/code:1jlkyr4e]
이렇게 적어두면 된더군요. 정말 신기하게 잘 되었습니다. 그리고 한동안 문제없이 사용했습니다.
하지만 그놈의 Early Adaptor 기질이 작동하는 바람에 몽땅 밀고 9.10 Alpha 6를 설치했는데 보기보다
제 노트북에서 문제가 많이 발생하더군요. 화면보호기가 작동을 하지 않는다던지 하는 문제가 있어서
다시 밀어버리고 9.04로 돌아왔는데… 이게 왠일입니까? 조금전만 해도 잘되던 무선랜이 다시 설치를
한 이후로는 접속을 못하고 계속 비밀번호를 물어보는군요. 또한 제가 비밀번호를 입력한 후에 다시
비밀번호 보기를 이용해서 확인해보면 제가 입력한 비밀번호가 아닌 이상한 문자열이 입력이 되어
있다는 것이죠. 원래 그런건가 알 수가 없네요. ㅠ…ㅠ
현재 dmesg를 통해 얻은 것은

[code:1jlkyr4e]
[ 29.008054] Clocksource tsc unstable (delta = 4398045825781 ns)
[ 39.344022] eth0: no IPv6 routers present
[ 96.098156] b43-pci-bridge 0000:03:00.0: PCI INT A disabled
[ 96.185463] ieee80211_crypt: registered algorithm ‘NULL’
[ 96.188424] ieee80211_crypt: registered algorithm ‘TKIP’
[ 96.323004] wl 0000:03:00.0: PCI INT A -> Link[LK4E] -> GSI 19 (level, high) -> IRQ 19
[ 96.323021] wl 0000:03:00.0: setting latency timer to 64
[ 96.341229] eth1: Broadcom BCM4328 802.11 Wireless Controller 5.10.91.9
[ 107.312037] eth1: no IPv6 routers present
[ 112.681454] eth0: link down.
[/code:1jlkyr4e]
입니다. 무선랜에 접속을 못하고 있는 경우이죠…
여기에서 제가 좀더 확인해볼만한게 뭐가 있을까 알여주세요… 혹시 제가 Broadcom 리눅스
드라이버의 버전을 5.10.91.9로 올려서 그런 것일까요?

많은 분들의 소중한 경험담이나 해결책을 기다립니다. ㅠ…ㅠ
그럼 이만…

[quote="sfeone":3rgknrz0]현재 노트북에 Win7과 Ubuntu를 듀얼부팅으로 사용하고 있습니다.
당연히 Win7에서는 아무런 문제가 없습니다. 윈도 드라이버는 아주아주 잘 만들어내는 것 같네요.
한가지 신기한 것은 Ubuntu에서는 BCM4328로 디바이스가 표시되는데 Win7에서는 BCM4322로
나옵니다. 아무튼 Win7에서는 그리고 이전에 사용하던 WinXP에서도 아무런 문제가 없었습니다.

하지만 우분투에서만은 항상 무선랜 접속이 어려웠습니다. 저도 한 때 ndiswrapper를 사용했지만
그것도 그다지 안정적이지를 못해서 몇 날 며칠을 구글링을 통해서 답을 알 수가 있었죠.
Broadcom에서 제공하는 리눅스용 드라이버가 있더군요. 설명서에 나오는대로 컴파일을 하고
모듈을 띄웠지만 안되더군요. 한참을 더 검색을 해본 결과 /etc/rc.local 파일에

[code:3rgknrz0]
modprobe -r wl b43 b44 ndiswrapper ssb b43legacy
modprobe ieee80211_crypt_tkip
insmod /home/sfeone/.driver/wl.ko
[/code:3rgknrz0]
이렇게 적어두면 된더군요. 정말 신기하게 잘 되었습니다. 그리고 한동안 문제없이 사용했습니다.
하지만 그놈의 Early Adaptor 기질이 작동하는 바람에 몽땅 밀고 9.10 Alpha 6를 설치했는데 보기보다
제 노트북에서 문제가 많이 발생하더군요. 화면보호기가 작동을 하지 않는다던지 하는 문제가 있어서
다시 밀어버리고 9.04로 돌아왔는데… 이게 왠일입니까? 조금전만 해도 잘되던 무선랜이 다시 설치를
한 이후로는 접속을 못하고 계속 비밀번호를 물어보는군요. 또한 제가 비밀번호를 입력한 후에 다시
비밀번호 보기를 이용해서 확인해보면 제가 입력한 비밀번호가 아닌 이상한 문자열이 입력이 되어
있다는 것이죠. 원래 그런건가 알 수가 없네요. ㅠ…ㅠ
현재 dmesg를 통해 얻은 것은

[code:3rgknrz0]
[ 29.008054] Clocksource tsc unstable (delta = 4398045825781 ns)
[ 39.344022] eth0: no IPv6 routers present
[ 96.098156] b43-pci-bridge 0000:03:00.0: PCI INT A disabled
[ 96.185463] ieee80211_crypt: registered algorithm ‘NULL’
[ 96.188424] ieee80211_crypt: registered algorithm ‘TKIP’
[ 96.323004] wl 0000:03:00.0: PCI INT A -> Link[LK4E] -> GSI 19 (level, high) -> IRQ 19
[ 96.323021] wl 0000:03:00.0: setting latency timer to 64
[ 96.341229] eth1: Broadcom BCM4328 802.11 Wireless Controller 5.10.91.9
[ 107.312037] eth1: no IPv6 routers present
[ 112.681454] eth0: link down.
[/code:3rgknrz0]
입니다. 무선랜에 접속을 못하고 있는 경우이죠…
여기에서 제가 좀더 확인해볼만한게 뭐가 있을까 알여주세요… 혹시 제가 Broadcom 리눅스
드라이버의 버전을 5.10.91.9로 올려서 그런 것일까요?

많은 분들의 소중한 경험담이나 해결책을 기다립니다. ㅠ…ㅠ
그럼 이만…[/quote:3rgknrz0]

상대적으로 좀 다른거지만… bcm 43xx 계열로 저도 꽤 고생했었는데… xx 번호가 조금씨만 달라도 다 상태 해결 방법이 다른…

제 경우는…

bcm43xx-fwcutter 펌웨어를 쓰고 하는 방법을 사용했었습니다… 최근에는 방법이 좀더 업글 된듯합니다…
사이트도 바뀌고…

http://linuxwireless.org/en/users/Drive ... full_story

에 보시면 혹시 도움 될지 모르겠습니다.