"Checking file systems" 오류로 부팅이 안 됩니다

새 HDD를 사서 이전 HDD를 IDE2에 연결하고 새 HDD를 IDE1에 연결하고 우분투를 설치했는데요.
인터넷이 와이브로 밖에 안 되서 업데이트를 할 수 없어 새 HDD는 자료 저장용으로 쓰고, 이전 HDD에 있던 우분투를 다시 쓰려고 하는데요. 이전 HDD에 있던 우분투로 부팅하면 중간에 오류나면서 부팅이 안 되는데요. 아래가 화면에 뜨는 메시지거든요. 어떻게 해야 하나요?

  • Setting kernel variables (/etc/sysct1.d/30-wine.conf)… [ OK ]

  • Activating swap… [ OK ]

  • Checking root file system…
    134
    fsck 1.41.4 (27-Jan-2009)
    /dev/sda1: clean, 143102/549440 files, 832634/2196880 blocks
    [ OK ]

  • Checking file systems…
    134
    fsck 1.41.4 (27-Jan-2009)
    /dev/sda2: clean, 40192/1844160 files, 447339/7373835 blocks
    fsck.ext3: Unable to resolve ‘UUID=79015fb3-1cdb-466b-b72e-c7ca6309a6f1’
    fsck died with exit status 8
    [fail]

  • File system check failed.
    A log is being saved in /var/log/fsck/checkfs if that location is writable.
    Please repair the file system manually.

  • A maintenance shell will now be started.
    CONTROL-D will terminate this shell and resume system boot.
    bash: no job control in this shell
    root@***-desktop:~#

/dev/sha2: clean, ~ sha 는 머죠 오타인가요 ? sda2 인가요 ?

우선 그냥 전에 하드를 IDE1 로 연결 새하드는 뻬고 부팅 해보십시요 (새하드 끼기전 같은 상황)
그런후 잘 되면 새하드를 IDE2 로 연결 하십시요
BIOS에서 부팅을 전 하드로 주십시요

[quote="강분도":3w0b0o5g]/dev/sha2: clean, ~ sha 는 머죠 오타인가요 ? sda2 인가요 ?

우선 그냥 전에 하드를 IDE1 로 연결 새하드는 뻬고 부팅 해보십시요 (새하드 끼기전 같은 상황)
그런후 잘 되면 새하드를 IDE2 로 연결 하십시요
BIOS에서 부팅을 전 하드로 주십시요[/quote:3w0b0o5g]
sda2 입니다.

새 HDD를 빼고 전에 HDD만 IDE1에 연결했을시 나오는 오류 메시지 입니다.

startx를 하면 화면이 뜨기는 합니다만 UI가 영어로 되어 있고, 키보드, 마우스가 모두 작동을 하지 않습니다.

sda2 가 어떤 파티션인가요 ?
프롬프트에서 fsck -y /dev/sda2 해서 검사 완료 해보십시요
물론 위험 하지만 fail 나면 또 하십시요 …

설치 시디로 라이브 부팅하여 터미널서 sudo -i 후 하셔도 됩니다.

[quote="강분도":32051zsj]sda2 가 어떤 파티션인가요 ?
프롬프트에서 fsck -y /dev/sda2 해서 검사 완료 해보십시요
물론 위험 하지만 fail 나면 또 하십시요 …[/quote:32051zsj]
sda1 /
sda2 /home
sda3 swap 입니다.

fsck -y /dev/sda1 을 하면
Do you really want to continue (y/n)? 라고 뜨는데

fsck -y /dev/sda2 를 하면
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda2/: clean, 40192/1844160 files, 447339/7373835 blocks
root@***-desktop:~#
라고 뜹니다.

새하드 끼고 설치시 전하드에 /home 을 공유 했는지요 ?

음 암튼 UUID 를 알아내서 fstab 내용과 비교 하여 보십시요

vol_id /dev/sda1 , vol_id /dev/sda2 해서 나오는 UUID 번호와
/etc/fstab 에 내용에 마운트 옵션 UUID가 같은지 비교 바랍니다.

[quote="강분도":2b0poy4s]새하드 끼고 설치시 전하드에 /home 을 공유 했는지요 ?

음 암튼 UUID 를 알아내서 fstab 내용과 비교 하여 보십시요

vol_id /dev/sda1 , vol_id /dev/sda2 해서 나오는 UUID 번호와
/etc/fstab 에 내용에 마운트 옵션 UUID가 같은지 비교 바랍니다.[/quote:2b0poy4s]
새 HDD에 /home 파티션을 새로 만들었습니다. 전 HDD는 자료 백업만 하고 빼버릴거라서 설치할때도 그냥 연결만 해두고 있었구요.

오류나는 부분에서 Ctrl + D를 하니까 정상적으로 부팅은 되고 사용하는데도 문제가 없는데요. 부팅할때마다 그 오류 메시지가 뜹니다.

UUID 부분은 비교해보니까 같습니다.

fstab 잘 살펴 보시고 새하드도 UUID 알아내 fatab 잘 설정 해보시기 바랍니다.

재 생각에는 이미 전하드에 /home 있는데 새하드의 파티션 중 하나를 /home 으로 마운트 하고 있는건 아닌지 생각 됩니다.