Eth0:avahi 문제

7.10 에서는 잘 되던 인터넷이 하디에서는 안되는데, 라이브 시디를 각각 돌려서 확인해본결과…

네트워크 설정인가? 관리인가?(위도우라 확인이 안되네요.ㅜㅜ) 거기서 첫번째 탭애서 여러 가지 장치 보니깐 7.10에선 eth0 이라는 장치 하나에 ip4, ip6두개 다 들어가 있더군요.
근데 하디에서는 eth0은 ip6만 잡고 있고 eth0:avahi라는 이상한 놈이 ip4 를 잡구 있더군요… 그래서 생각한게 하디에선 이놈 때문에 인터넷이 안되는구나… 라고 생각중입니다.ㅜㅜ
강분도 님이 제안하신 7.10에서 8.04로 업데이트시, 커널 2.6.22-14에선 인터넷되는데, 역시 2.6.24-16 에서는 안되네요.ㅜㅜ
그냥 22-14 쓰고 싶기도 하지만 그래픽 해상도 문제 때문에 24-16써야겠네요…

하여튼 시냅틱 관리자에서 avahi들어가는 놈들을 지워버렸습니다. 아 eth1:avahi는 사라졌더군요. 문제는 eth0 장치에 ip4에 관한게 아무것도 없네요…ㅜㅜ
검색을 해보니 avahi가 dns를 자동으로 뭐 어쩌고 해주는 거라는데… 저는 그걸 지워버려서 DNS가 셋팅이 안되는거겠죠…?
그럼 7.10에서 쓰던 avahi 같은건 없을까요?? avahi탓으로 돌리기는 뭐하지만… 이거 참… 버저마다 점점 힘들어지네요 우부투.
아시는 분은 꼭 좀 답변 부탁드립니다.

아직 한국에선 저같은 실패자가 없는지 한국어 웹에선 검색해도 안나오고 구글에서 외국인 유저들은 이걸로 고생하는 사람이 꽤 있나보군요.
대충 검색해보니깐 이런 글이 보이네요. 왠지 이 문제가 맞는거 같습니다.
하라는데로 한거 같은데… 제가 영어도 짧고 컴퓨터도 짧아서.ㅜ
보시구 좀 쉽게 정리 좀 해주시면 감사드리겠습니다.

The dreaded eth0:avahi Ubuntu Feisty bug

I have a very simple setup. One wired network card, that’s it. No wireless cards at all. Got a brand new machine with a freshly installed Feisty, on Thursday. Worked like a charm, I could surf the Internet with Firefox, and it was fast.

Immediately after the first reboot, the day after, I couldn’t access the Internet anymore. My other two machines , who uses the same router/DHCP server, were still working, so I knew it wasn’t a network problem. I could ping the router from the Feisty machine, but with packet loss ratios ranging between 40% - 100%. Firefox could not connect to Google or the internal routers webadmin GUI.

Network manager was showing an IP address of 0.0.0.0. If I used System->Administration->Network Tools->Devices, it showed:

* lo
* eth0 (IPv6)
* eth0:avahi (IPv4)

To make a long story short, this is what worked for me, to get it working again:

  1. Network manager works best with only the loopback interface specified in the /etc/networking/interfaces file. Comment out lines in /etc/networking/interfaces, leaving only the loopback interface. Make a backup copy first ! I had to use vi, the other editor I tried left invisible characters which messed up the file completely.

    sudo cp /etc/network/interfaces /etc/network/interfaces.bak
    sudo vi /etc/network/interfaces

    Your /etc/network/interfaces should look something like this after the edit:

    This file describes the network interfaces available on your system

    and how to activate them. For more information, see interfaces(5).

    The loopback network interface

    auto lo
    iface lo inet loopback

    This is a list of hotpluggable network interfaces.

    They will be activated automatically by the hotplug subsystem.

    auto eth1

    iface eth1 inet dhcp

  2. Next, get a DHCP address for eth1, overriding NetworkManager:

    sudo dhclient

  3. OK, we now have Internet access again and can use apt-get to reinstall a broken package

    sudo apt-get --purge install avahi-autoipd --reinstall

  4. Reboot.

After the reboot, Network Manager showed a proper IP address and not 0.0.0.0
I got Internet access back, and things were back to normal.

Using System->Administration->Network Tools->Devices, now showed, after fix:

* lo
* eth0 (IPv4, IPv6)

These links helped me fix the problem:

* <!-- m --><a class="postlink" href="https://help.ubuntu.com/community/WifiDocs/NetworkManager">https://help.ubuntu.com/community/WifiD ... orkManager</a><!-- m -->
* <!-- m --><a class="postlink" href="https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/78078">https://bugs.launchpad.net/ubuntu/+sour ... +bug/78078</a><!-- m -->
* <!-- m --><a class="postlink" href="https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/82927">https://bugs.launchpad.net/ubuntu/+sour ... +bug/82927</a><!-- m -->
* <!-- m --><a class="postlink" href="http://ubuntuforums.org/archive/index.php/t-387319.html">http://ubuntuforums.org/archive/index.php/t-387319.html</a><!-- m -->

omingo - stuff worth sharing about Ubuntu

Articles

* The dreaded eth0:avahi Ubunty Feisty bug