[오류] Firefox (beta) 사용 시 반복되는 로그인 오류 ...

우분투 64비트 / Windows XP SP3 - 이중 환경입니다. Firefox beta를 주로 사용하고 있습니다. 28.0 beta 버전을 사용 중입니다.
이전 버전 - 27.0 beta - 에서는 아무런 문제가 없었습니다. 우분투와 XP 버전 모두에서도…
(개인적으로 Firefox는 beta 버전만 사용하고 있습니다.)

로그인 후 글을 쓰려고 하면 로그인 화면이 계속 나타납니다.

로그인 후 나타나는 화면 …
[attachment=1:1gfhh6ro]01.png[/attachment:1gfhh6ro]

새글이나 댓글을 쓰려고 하면 반복적으로 나타나는 화면 …
[attachment=0:1gfhh6ro]02.png[/attachment:1gfhh6ro]

지금 이 글은 Windows XP SP3 에서 Opera 로 접속한 상태입니다.
XP 용 Google Chrome 에서도 같은 증상이 나타났었는데 업그레이드 - 삭제후 상위 버전을 재설치 - 를 한 후 이런 증상이 사라졌습니다.
아무래도 Firefox beta 의 문제인 것 같습니다.

about:config 에서 network로 검색하셔서 ipv6 사용에 true로 되어 있다면
false로 변경해 보시고 파이어폭스 옵션에서 프록시를 사용한다면 사용하지 않음으로 해 보십시오.

가끔 ipv6 오류가 발생 하더군요! 참고하십시오.

저는 익스11인데 동일증상 나타납니다. 어떨땐 잘 될때도 있구요.

안드로이드 킷켓 모바일 크롬에서도 로그인 잘 안되요.

원래 안그랬는데 요즘들어 그런것 같습니다.

[quote="workman729":zs60ormq]about:config 에서 network로 검색하셔서 ipv6 사용에 true로 되어 있다면
false로 변경해 보시고 파이어폭스 옵션에서 프록시를 사용한다면 사용하지 않음으로 해 보십시오.

가끔 ipv6 오류가 발생 하더군요! 참고하십시오.[/quote:zs60ormq]

network.dns.disableIPv6 값을 "true" 또는 "false" 로 다 설정해 봤는데 증상은 여전히 동일합니다.

프록시는 전혀 사용하지 않습니다.

얼마 전 오픈 수세에서도 비슷한 증상이 있어 고민했던 적이 있습니다만
우분투에서도 같은 증상이 있을 것 이리라고는 생각해 본 적이 없군요!

일단 제가 경험한 이상 증상과 비슷한 것 같아 경험담을 말씀 드리겠습니다.

님께서 사용하시는 DNS 서버를 체크해서 도메인을 제대로 찾는 지를 체크해 보십시오.
저의 경우 파어어폭스가 1차, 2차 네임 서버를 활용하여 큰 문제는 없었습니다만
1차 네임 서버는 확실히 도메인을 찾는 데 문제가 있어 zypper 사용시 해당 도메인을 찾지 못했던 적이 있습니다.

2차는 문제가 없어 파이어폭스 이용에 문제가 된 적은 없습니다만
network.dns.disableIPv6 가 true로 되어 있어 여러 문제가 발생 했습니다.

이를 테면 북마크를 클릭해도 해당 사이트로 이동을 하지 않거나
특별히 파일에 대한 접근이 차단되는 경우 또는 말씀 하신 우분투 커뮤니티의 로그인 문제등 이였습니다.

저는 문제가 발생하는 사이트에 ping을 날린 결과 DNS 서버, ipv6 문제로 진단하여
다음과 같은 조치를 하여 문제를 해결 했습니다.

첫째, 해당 OS에서 ipv6를 완전히 disable 시키기 위해 /etc/sysctl.conf 파일에 다음 라인을 추가하였습니다.

[quote:1lh234kc]net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1[/quote:1lh234kc]
커널 모듈 까지 blacklist에 추가하려다 그럴 필요 까지는 없을 것으로 보입니다.
그리고 KDE 네트워크 설정에서 ipv6를 자동에서 disable로 변경 하였습니다.

둘째, /etc/dhclient.conf 파일과 /etc/resolv.conf 파일을 참고해서 1,2차 네임서버의 이상 유무를 체크 하였습니다.
dhclient.conf 파일 에서 다음 라인을 추가하여 재부팅 한다음 이상이 있는 사이트의 도메인으로 ping을 날려 네임 서버의 이상 유무를 체크하였습니다.

[quote:1lh234kc]# vi /etc/dhclient.conf
supersede domain-name-servers "1차 네임 서버 아이피";

reboot

ping 도메인

vi /etc/dhclient.conf

supersede domain-name-servers "2차 네임 서버 아이피";

reboot

ping 도메인[/quote:1lh234kc]

resolv.conf 파일에 있는 네임서버를 활용 하시면 됩니다.

확인 결과 1차 네임 서버의 이상을 확인 하고 /etc/dhclient.conf 파일에서
openDNS 사이트의 네임 서버로 고정하여 모든 문제를 해결하였습니다. 참고 하시기 바랍니다.

[quote:1lh234kc]supersede domain-name-servers 208.67.222.222, 208.67.220.220, 2차네임서버 아이피;[/quote:1lh234kc]

[quote="workman729":2oxfljyz]얼마 전 오픈 수세에서도 비슷한 증상이 있어 고민했던 적이 있습니다만
우분투에서도 같은 증상이 있을 것 이리라고는 생각해 본 적이 없군요!
[/quote:2oxfljyz]

MS-Windows 에서도 같은 증상입니다. Firefox로는 로그인이 안 됩니다. Opera 브라우저에서는 정상적으로 접속이 됩니다.

다른 글타래에 해결책이 있네요.

[url:2358o8w7]http://www.ubuntu-kr.org/viewtopic.php?f=4&t=25996[/url:2358o8w7]

도메인 주소를

[code:2358o8w7]http://www.ubuntu-kr.org/
[/code:2358o8w7]
로 하니깐 정상적으로 됩니다…