Gcc 다운그레이드

우분투 10.04설치시 4.4.3이 자동설치되어있더라고요…
qt컴파일시 4.1.2를 사용해야하는데 gcc버전을 낮추는 방법이 없을까요…
rpm파일도 받아봐서 deb으로 변환해서도 해보고
소스받아서 make도 시켜봤는대 오류를 마구내뿝더라고요…
gcc 다운그레이드 좀쉽게 할수없는방법있나요?
컴파일시 스왑해서 사용하는방법도 있다던데… 휴…
갈수록 어렵네요…
도와주세요 ㅠㅠ

우분투는 gcc 버전을 다양하게 제공하고 있습니다.
apt-get install gcc-4.1
하면 10.04 에서도 gcc 4.1 버전때 사용이 가능합니다.