Hibernate후 resume시 freezing 현상

최근에 netbook에 lubuntu를 깔았습니다.
거의 매일 전원 선을 연결해서 써서 몰랐는데, 전원 선 없이 쓸 때에만 hibernation에 관련해서 문제가 있네요.
hibernate후, resume 시 시스템이 freezing합니다.
Graphical interface에서는 에러메시지도 없고 알길이 없기에
console 모드에서
pm-hibernate 를 실행해서 hibernation 했다가 resume하니
다음과 같은 에러메시지들이 뜨면서 시스템이 멈춥니다.

INFO: rcu_sched_state_detected stall on CPU 0 (t=15001 jiffies)

뭐 이런 에러메시지들이 뜹니다.

혹시 원인을 아시는 분 계신가요?
예전에도 hibernation관련 문제를 겪은 적이 있는데, 그 때에는 swap partition의 사이즈가 문제여서
이번에는 swap partition을 2기가 넘게 잡아 줬습니다. 메인메모리는 1기가입니다.

감사합니다.

추가:

무선랜 카드 문제로군요.
전원 연결이 문제가 아니라, netbook 무선랜을 켜 놨는지 아닌지에 따라 달라지는군요.
무선랜 끄니 resume이 잘 되는 것 같습니다.
무선랜 켜 놓았을 때에는 다음과 같은 메시지가 뜹니다.

rtl8187se: HwThreeWire(): CmdReg: OXFF RE|WE bits are not clear!!

혹시 해결책을 아시는 분 있나요?

제 ACER Aspire one D532h 넷북도 9.10에서 같은 증상이 있었는데요,
(무선랜 들어와 있는 상태로 최대절전/절전모드를 사용하면 복구되다 먹통되는 현상)
10.04부터는 별 문제가 없어졌습니다.
아마 무선랜 드라이버 문제일겁니다.

넷북 기종에 따라 다르기 때문에

https://wiki.ubuntu.com/HardwareSupport ... s/Netbooks

이곳을 찾아보시기 바랍니다.

draco님 감사합니다.
사실 이번에 이 넷북에 처음으로 우분투를 깔아 쓰는건 아닌데, (ubuntu 쓰다가 완전히 뒤엎고 lubuntu로 변경)
넷북임에도 거의 들고 다니면서 무선랜을 써 본 적이 없어서 예전에도 이런 문제가 있었는지조차 기억이 안 나네요;

아직 해결은 못 했지만, 좀 더 찾아보겠습니다.

휴… 드뎌 해결한 것 같네요.

관련 쓰레드:

https://bugs.launchpad.net/ubuntu/+sour ... bug/672591 https://bugs.launchpad.net/ubuntu/+sour ... bug/663784

아직까지 해결이 안 된 버그인 것 같네요. 아래와 같이 해결했습니다.

[quote:4ei1i790]
Giulio Franco (giulio-franco) wrote on 2010-10-26: #3
Solved on my pc by adding the line:
SUSPEND_MODULES="r8187se"
to the file /etc/pm/config.d/unload_module. This way, the wifi driver, which caused my pc to freeze, is unloaded before suspend and reloaded on resume.
May work on EeePc too, replacing r8187se (which is my wifi card) with the eeepc wifi module name.
[/quote:4ei1i790]