HP Deskjet K109a 프린터는 우분투에서 프린트가 안 되나요?

HP Deskjet K109a 프린터는 우분투에서 프린트가 안 되나요?

인식되었는데 안되신다는 것인지 아니면 지금 되는지만 알아보시려는건지요?

일단 HP 프린터는 HP측에서 프린터 드라이버 제공해서 다 되는 것으로 알고 있습니다.

저의 경우에는 HP Laserjet 1020을 사용하고 있는데
그냥 연결을 한 후 전원을 켜면 10.04 버전에서는 어떻게 하라는 메시지가 좌 상단에 나왔던 것으로 기억하고
지금 10.10을 새로 설치한 후에는 연결을 한 후에 필요한 플러그인??펌웨어??를 다운로드 하는 창이 나왔습니다.

예전 배포판을 사용할 때는 그렇게 동작을 하지 않아 드라이버와 유틸리티를 다운로드 했는데,
HP 리눅스용 드라이버 제공 사이트입니다.
[url:1y6lcne8]http://hplipopensource.com/hplip-web/index.html[/url:1y6lcne8]
여기에서 찾아보니 같은 이름을 가진 프린터가 드라이버 검색 목록에 있네요.
저기에 있으면 아마 그냥 연결을 하면 동작을 할 것으로 생각되고

그렇지 않으면 위 사이트에서 Download HPLIP을 선택한 후에 배포판 이름, 버전, 프린터 종류, 모델을 찾은 다음
NEXT를 두번 눌르면 검정색 Download HPLIP이라는 버튼이 나오고 그 아래에 설치 방법이 나옵니다.

위에 처럼했더니

INSTALL MISSING REQUIRED DEPENDENCIES

warning: There are 7 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: This installer cannot install ‘gcc’ for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

이렇게 나옵니다.
10.04용을 사용해서 그런지
아니면 무엇이 빠졌다는 것인지 모르겠습니다.

어떻게하면 될까요?

[quote="dudndkqk":1g4uvzao]위에 처럼했더니

INSTALL MISSING REQUIRED DEPENDENCIES

warning: There are 7 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: This installer cannot install ‘gcc’ for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

이렇게 나옵니다.
10.04용을 사용해서 그런지
아니면 무엇이 빠졌다는 것인지 모르겠습니다.

어떻게하면 될까요?[/quote:1g4uvzao]

[code:1g4uvzao]sudo apt-get install build-essential[/code:1g4uvzao]
컴파일러가 없다는 말입니다. 위와같이 실행한 뒤 설치하세요.
참고로 리눅스는 윈도와 달리 드라이버는 커널 의존이 매우 심합니다.
드라이버를 생성하면 커널 버전에 맞춰지죠.
그래서 드라이버는 그냥 복사되는 것이 아니라 컴파일 되어 설치됩니다. =.=

[quote="haze11":3obg4ndw][quote="dudndkqk":3obg4ndw]위에 처럼했더니

INSTALL MISSING REQUIRED DEPENDENCIES

warning: There are 7 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: This installer cannot install ‘gcc’ for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

이렇게 나옵니다.
10.04용을 사용해서 그런지
아니면 무엇이 빠졌다는 것인지 모르겠습니다.

어떻게하면 될까요?[/quote:3obg4ndw]

[code:3obg4ndw]sudo apt-get install build-essential[/code:3obg4ndw]
컴파일러가 없다는 말입니다. 위와같이 실행한 뒤 설치하세요.
참고로 리눅스는 윈도와 달리 드라이버는 커널 의존이 매우 심합니다.
드라이버를 생성하면 커널 버전에 맞춰지죠.
그래서 드라이버는 그냥 복사되는 것이 아니라 컴파일 되어 설치됩니다. =.=[/quote:3obg4ndw]

위에 처럼한후에 다시 설치하니 이번에는

INSTALL MISSING REQUIRED DEPENDENCIES

warning: There are 6 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: This installer cannot install ‘python-devel’ for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

이렇게 나와서
sudo apt-get install python-devel 이렇게 했더니 그런게 없다네요.
이렇게 설치하는게 아닌가봐요?
어떻게 하지요? 조금더 도와주세요.

Ubuntu 10.10에 python-dev 라는 패키지가 있는데, 그걸 설치해보면 어떨까요.

sudo apt-get install python-dev

그 다음에도 여러가지가 없다는 내용이 나왔지만 위의 jeongsw님이 알려주신 것을 바탕으로
시냅틱패키지관리자에서 대충 비슷한 것을 선택해서 설치했더니 끝까지 진행이 되어서 이제는 되는구나 싶었는데
마지막에 다음과 같은 메세지가 나오는데

PRINTER SETUP

Please make sure your printer is connected and powered on at this time.
error: hp-setup failed. Please run hp-setup manually.

어떻게 수동으로 실행을 시키라는 건지 전혀모르겠습니다.
어떻게 하면될까요?

이렇게까지 하면서 프린터써야하나 하는 회의마저 생깁니다.

Please run hp-setup manually.

hp-setup

으로 실행하시면 될 것 같습니다.

그보다 hplip 덕에 HP 프린터는 대부분 리눅스에서 기본으로 드라이버가 잡히는 편인데… 이상한 일이네요;;

떠돌이님 말씀대로 hp-setup했더니
설치가 끝까지 마무리되었습니다.
그런데도 인쇄가 안되어서 답답해하다가

메뉴를 보니 보조프로그램안에 HP디바이스 매니저라는 프로그램이 있어서
시행을 시켜보았지만
실행이 전혀되지않습니다. 설명에는 이 것을 시행시켜서
USB로 연결하는 것인지를 비롯해서 기타 등등을 정해주어야한다고 하는데 실행이 안되니 방법이 없네요.

전부 삭제하고 다시 처음부터 해보고 싶은데 어떻게 하면될까요?

음…HP 프린터의 경우에는 너무 최신 기종이 아닌 이상 다 지원이 되고, 찾아 보니 우분투 10.10에 포함된 HPLIP 버전은 k109a를 지원하는 버전이라
우분투 10.10 버전을 처음 설치하신 다음 프린터를 연결하고 전원을 켜 보시면 그냥 사용 가능하게 되었을 것 같은데요.
다시 설치하면 그냥 한번 연결하신 후에 전원을 켜 보시고 아니라면 다시 설치를 해 봐야지요…

Hplip이라는 프로그램은 원래 필요한 패키지를 자동으로 다운로드하고 사용 가능하게 딱 해주는 프로그램인데,
그게 되지 않은 것 같아서 인터넷을 뒤져보니 10.10 버전에서 약간의 문제가 있었네요.

수정 방법이 나와 있어서 수정을 한 뒤에 실행을 해 봤더니 잘 되네요.

[url:1a93pj6r]http://dl.dropbox.com/u/2021778/hplip-3.10.9.tar.bz2[/url:1a93pj6r]

위 주소에서 수정한 거시기를 압축한 놈을 받으신 후에, 압축을 풀고 hplip-3.10.9 디렉터리로 들어가셔서
./install.py라고 입력을 하고 installation mode 어쩌고 써 있는 곳에서 'a’를 입력하신 다음 배포판 확인하는 곳에서 y
관리자 권한 요구하는 곳에서 암호를 입력하신 후 기다리시면 필요한 것을 설치를 하고 마지막에

[img:1a93pj6r]http://hplipopensource.com/hplip-web/images/install_9.png[/img:1a93pj6r]

이 화면에서 프린터를 껐다 킨 후에 R을 누르고 엔터를 치거나
컴퓨터로 연결되는 USB 선을 뺐다 다시 끼우고 P를 누르거 엔터를 친 후에
프린터 추가 대화 상자가 나옵니다.

제가 예전에 겪은 문제하고 같은 게 아닐지;;

hpcups(hplip-cups) 문제였던 것 같은데 말이죠.

설치가 안 되어서 직접 했었던 것으로 기억합니다.