Jshint 패키지 설치시 다음과 같은 오류가 발생 합니다

root@lemon02-u64:/etc/apt# npm install jshint -g
npm http GET http://registry.npmjs.org/jshint
npm http 200 http://registry.npmjs.org/jshint
npm http GET http://registry.npmjs.org/jshint/-/jshint-2.5.1.tgz
npm http 200 http://registry.npmjs.org/jshint/-/jshint-2.5.1.tgz
npm http GET http://registry.npmjs.org/shelljs
npm http GET http://registry.npmjs.org/underscore
npm http GET http://registry.npmjs.org/cli
npm http GET http://registry.npmjs.org/minimatch
npm http GET http://registry.npmjs.org/htmlparser2
npm http GET http://registry.npmjs.org/console-browserify
npm http GET http://registry.npmjs.org/exit
npm http GET http://registry.npmjs.org/strip-json-comments
npm http 200 http://registry.npmjs.org/minimatch
npm http GET http://registry.npmjs.org/minimatch/-/m … -0.3.0.tgz
npm http 200 http://registry.npmjs.org/shelljs
npm ERR! error installing jshint@2.5.1

npm ERR! Error: No compatible version found: shelljs@‘>=0.3.0- <0.4.0-’
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.0.7","0.0.8","0.0.9","0.1.0","0.1.1","0.1.2","0.1.3","0.1.4","0.2.0","0.0.1-alpha1","0.0.2-pre1","0.0.4-pre1","0.0.5-pre1","0.0.5-pre2","0.0.5-pre3","0.0.5-pre4","0.0.6-pre1","0.0.6-pre2"]
npm ERR! at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
npm ERR! at next_ (/usr/share/npm/lib/cache.js:438:17)
npm ERR! at next (/usr/share/npm/lib/cache.js:415:44)
npm ERR! at /usr/share/npm/lib/cache.js:408:5
npm ERR! at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR! at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR! <http://bugs.debian.org/npm&gt;
npm ERR! or use
npm ERR! reportbug --attach /etc/apt/npm-debug.log npm
npm ERR!
npm ERR! System Linux 3.2.0-23-generic
npm ERR! command "node" "/usr/bin/npm" "install" "jshint" "-g"
npm ERR! cwd /etc/apt
npm ERR! node -v v0.6.12
npm ERR! npm -v 1.1.4
npm ERR! message No compatible version found: shelljs@‘>=0.3.0- <0.4.0-’
npm ERR! message Valid install targets:
npm ERR! message ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.0.7","0.0.8","0.0.9","0.1.0","0.1.1","0.1.2","0.1.3","0.1.4","0.2.0","0.0.1-alpha1","0.0.2-pre1","0.0.4-pre1","0.0.5-pre1","0.0.5-pre2","0.0.5-pre3","0.0.5-pre4","0.0.6-pre1","0.0.6-pre2"]
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /etc/apt/npm-debug.log
npm not ok

왜 이런 오류가 발생 할까요?