패키지 의존성 관련 질문드립니다.(lib64readline5-dev,lib64ncurses5-dev)

안드로이드 소스코드를 받아 빌드 하려고 합니다

sudo apt-get install git-core gnupg flex bison gperf build-essential
zip curl zlib1g-dev libc6-dev lib64ncurses5-dev x11proto-core-dev
libx11-dev lib64readline5-dev( or lib64readline-gplv2-dev) lib64z-dev libgl1-mesa-dev
g+±multilib xsltproc tofrodos python-markdown libxml2-utils mingw32 \

패키치 설치과정 중
lib64readline5-dev
lib64ncurses5-dev
이 두개의 패키지가 설치 되지 않습니다.

root@ais1311-System-Product-Name:~# apt-get install lib64ncurses5-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다:
lib64ncurses5-dev:i386 : Depends: lib64ncurses5:i386 (= 5.9-1ubuntu5) 하지만 %s 패키지를 설치하지 않을 것입니다
Depends: libncurses5-dev:i386 (= 5.9-1ubuntu5) 하지만 %s 패키지를 설치하지 않을 것입니다
Depends: lib64c-dev:i386
E: Unable to correct problems, you have held broken packages.

이와 같은 의존성 문제가 발생합니다.
해결방법좀 알려주시면 감사하겠습니다.
환경은
ubuntu11.10 64bit 입니다.