Mariadb 설치중에 오류가 뜹니다

hill@Localhost:~$ sudo apt-get install mariadb-server
패키지 목록을 읽는 중입니다… 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다… 완료
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다:
mariadb-server : 의존: mariadb-server-5.5 (= 5.5.33a+maria-1~precise) 하지만 %s 패키지를 설치하지 않을 것입니다
E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.
hill@Localhost:~$

이렇게 뜹니다.

여기를 보고 참고 했구요. 중간에 리포지터리 추가는

sudo add-apt-repository ‘deb http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu precise main’
이렇게 입력했습니다.
사용중인 우분투는 12.04입니다.

어떤게 문제인지 잘 모르겠네요… 도와주세요 ㅜㅜ

apt-get update 했을 때 뭔가 오류가 나진 않았습니까?

블로그 보지 마시고

https://downloads.mariadb.org/mariadb/repositories/

이걸 참고하시는게 더 정확할겁니다.

제 우분투 서버의 경우엔 굳이 mysql은 제거 안해도 되었고요.
(CentOS에선 제거 안하면 안되더군요)