Mp3 내에 파일 수정이 안되요;ㅅ ;

mp3에 노래를 넣을려고- usb를 꼽았는데,
요즘 들어서 이게 늘 읽기 전용으로 자동으로 바꿔져요;
속성에 들어가서 권한 수정을 할려고 하니깐 오류가 나네요…
처음엔 안 이랬는 데 어떡하면 좋은가요 :cry:

P.S 참고로 MP3는 iriver 사의 E100이라는 제품이랍니다 /ㅅ /
sudo (구체적인 명령어가 기억이 안 나는데…)rw 뭐…이런 명령어를 쳤는데도…
파일 쓰기, 지우기가 안되고 그냥 이 녀석이 read only file system 이다. 라는 거 밖에 말해주지 않네요ㅜ_ㅜ;;;

제목에 p 가 빠졌군요. mp3 편집한다는 얘긴 줄 알았습니다. ;

[quote="lhkim01":34w026nk]sudo (구체적인 명령어가 기억이 안 나는데…)rw 뭐…이런 명령어를 쳤는데도…
파일 쓰기, 지우기가 안되고 그냥 이 녀석이 read only file system 이다. 라는 거 밖에 말해주지 않네요ㅜ_ㅜ;;;[/quote:34w026nk]
보통 이런건 FAT32 로 되어 있지요. 그런데 그게 읽기 모드로 마운트된 모양이네요.
read only mode 로 마운트되어 있으니 권한 설정도 안되겠지요.

해결책은 rw 모드(쓰기/읽기)로 재마운트하시면 됩니다.만…
우선은 mount -l 하셔서 그 내용을 답글로 올려주시면 다른 분들이 정확한 원인을 파악하기에 도움이 될 것 같습니다.

첨에 마운트 되었을땐 잘되었다가
한 몇분 후에 속성이 바뀐 경우는 usb 케이블이 접속이 불량인 경우가 많습니다.
저도 외장 하드 중에 하나가 첨에는 파일을 새로 생성할 수 있었는데
몇분후에 보면 쓰기 불가가 되는 경우가 있어 보니
usb 접속 단자랑 케이블 문제더군요.
전 다른 usb 접속 단자에 꽂거나 usb 케이블을 바꿔서 해결했습니다만
그런 문제인지 확인할라면 언마운트 시켰다가 다시 마운트 시켜보면 됩니다.
근데 솔직히 그런 문제는 발생 원인이 천차만별이라 뭐라 꼭찝어서 말씀드리긴 힘드네요.

최근 아이리버 제품에서 간혹 그런것 같습니다. 저도 다른 플레이어는 다 멀쩡한데 아이리버의 Lplayer를 연결하면 그런현상이 나타나곤 했었거든요. 파일시스템 문제인듯… 그때는 mp3 플레이어 내부의 파일을 백업시킨다음, 기기 내부에 있는 포맷 기능으로 포맷한 후 다시 사용해보시기 바랍니다^^

mount -l 하니까 이렇게 떠요 /ㅅ /

/dev/sda2 on / type ext3 (rw,relatime,errors=remount-ro) []
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.27-11-generic/volatile type tmpfs (rw,mode=755)
none on /proc/bus/usb type usbfs (rw,busgid=125,busmode=0775,devgid=125,devmode=0664)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/lol/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=lol)
/dev/sdb on /media/E100 type vfat (rw,nosuid,nodev,uhelper=hal,shortname=mixed,uid=1000,utf8,umask=077,flush) [E100]

아무튼 언마운트 했다가 다시 마운트 하니까 괜찮아지네요~ 모두 고마워요!

[quote="떠돌이":3e5ispy8]최근 아이리버 제품에서 간혹 그런것 같습니다. 저도 다른 플레이어는 다 멀쩡한데 아이리버의 Lplayer를 연결하면 그런현상이 나타나곤 했었거든요. 파일시스템 문제인듯… 그때는 mp3 플레이어 내부의 파일을 백업시킨다음, 기기 내부에 있는 포맷 기능으로 포맷한 후 다시 사용해보시기 바랍니다^^[/quote:3e5ispy8]
왜 하필 아이리버가…ㅠ_ㅠ…그런건지…그래도 문제 해결은 된 것 같으니까 감사드려요~