명령으로 mplayer실행시의 질문

gnome-commander의 명령창에서 mapleyr 명령으로 영화를 재생하는 것이 되었었는데, 어느 순간부터 안되네요.

현재 terminal에서 mplayer실행하면 영화가 재생되지만, gnome-commander명령창에서 mplayer명령을 실행하면 mplayer창이 뜨지 않습니다.

어떤 설정을 바꿔줘야 gnome-terminal 띄우지 않고도 mplayer로 영화를 재생할 수 있을까요?

ps. alt-f2를 눌러서 명령을 실행시키면 제대로 실행이되네요. 전에는 오타로 인해 실행이 안된듯…
gnome-commander 설정문제일수도… ㅠㅠ

mplayer는 CUI(Character User Interface) 환경으로 작동하기 때문에 실행이 안됩니다.

[code:7a0ql0fm]shriekout@shriekout-desktop:~$ mplayer
MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.06GHz (Family: 15, Model: 4, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Usage: mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
-vo <drv> select video output driver (‘-vo help’ for a list)
-ao <drv> select audio output driver (‘-ao help’ for a list)
vcd://<trackno> play (S)VCD (Super Video CD) track (raw device, no mount)
dvd://<titleno> play DVD title from device instead of plain file
-alang/-slang select DVD audio/subtitle language (by 2-char country code)
-ss <position> seek to given (seconds or hh:mm:ss) position
-nosound do not play sound
-fs fullscreen playback (or -vm, -zoom, details in the man page)
-x <x> -y <y> set display resolution (for use with -vm or -zoom)
-sub <file> specify subtitle file to use (also see -subfps, -subdelay)
-playlist <file> specify playlist file
-vid x -aid y select video (x) and audio (y) stream to play
-fps x -srate y change video (x fps) and audio (y Hz) rate
-pp <quality> enable postprocessing filter (details in the man page)
-framedrop enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
<- or -> seek backward/forward 10 seconds
down or up seek backward/forward 1 minute
pgdown or pgup seek backward/forward 10 minutes
< or > step backward/forward in playlist
p or SPACE pause movie (press any key to continue)
q or ESC stop playing and quit program

  • or - adjust audio delay by +/- 0.1 second
    o cycle OSD mode: none / seekbar / seekbar + timer
  • or / increase or decrease PCM volume
    x or z adjust subtitle delay by +/- 0.1 second
    r or t adjust subtitle position up/down, also see -vf expand

      • SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *[/code:7a0ql0fm]
        mplayer를 치시면 그냥 이렇게 텍스트만 주르륵 나오고 끝납니다.
        실행하시려면 mplayer 영화제목 이렇게 하셔야 재생이 될겁니다.
        그냥 mplayer 로 영화재생화면을 띄우실려면,
        mplayer 를 넣지 말고, gmplayer 나 mplayer -gui 라고 하시면 영화재생에 관련된 창이 뜰겁니다.

ps. 그런데 alt-f2 로 해서 나오는 창에서도 mplayer 하면 창이 안 뜨지 않던가요?
링크가 꼬이면 그런 문제가 있었던걸로 아는데, 해결된게 아닌가? ;;;

mplayer 영화제목 <– gnome-commander에서는 이런식으로 입력해도 안되네요.
alt-f2로 명령을 "mplayer 영화제목" 이렇게 내리면 실행되고요.
아무래도 뭔가 gnome-commander관련해서 꼬인게 맞나봐요. 전에는 되던게 안되는 현상이 있네요.