Mplayer2에서 vdpau를 사용하면 cpu 점유율이 치솟습니다

mplayer에서 vdpau로 출력하도록 하면 이상하게도 cpu 점유율이 치솟네요. 분명 nvidia 그래픽 카드 드라이버를 current로 설치하고, mplayer stable ppa에서 최신버전을 설치해도 이러네요…

vdpau는 gpu가속을 사용하는게 아닌가요? 왜 cpu 점유율이 높게 치솟나요?

mplayer에서 gpu가속을 사용하고 싶은데, 어떻게 해야하나요?

드라이버 버전이 어떻게 되나요?

current면 304.x대 인가요? 308.x대 인가요?
그리고 우분투 버전은 13.04 인 것으로 추측 됩니다.

조금 오래 된 드라이버dls 관계로 mesa, xorg와 매칭이 안 맞는 데 아래를 참조해서
최신 드라이버로 업그레이드 하시기 바랍니다.

mpayer2는 특별히 저장소를 추가하지 않으면 오래된 버전이 설치됩니다.

sudo add-apt-repository ppa:xorg-edgers/ppa

sudo apt-get update

sudo apt-get install nvidia-319 nvidia-settings-319

드라이버 업데이트 후 xorg-edgers 저장소 필히 비활성 하거나 삭제 하십시오.
필요한 드라이버만 설치하시고 절대 업그레이드 하지 마시기 바랍니다.

mplayer2는 직접 컴파일 하시는 것을 추천 합니다만 어려우시면 아래 ppa에서 설치 하십시오.
gl3 옵션이 빠져 있습니다. 참고하십시오.

sudo add-apt-repository ppa:motumedia/mplayer-daily

sudo add-apt-repository ppa:smplayer2/daily

sudo apt-get update

sudo apt-get install mpayer2 smplayer2

mplayer 단독으로 플레이 하시려면 ~/.mplayer/config 에 아래 라인 추가 하십시오.
vo=vdpau
vc=ffh264vdpau,ffodivxvdpau,ffmpeg12vdpau, (마지막 콤마 반드시 있어야 합니다. 실수가 아닙니다.)

우분투 버전은 12.10입니다.
nvidia는 304.88-0ubuntu0.0.2버전입니다.
mplayer2는 2.1+git20130221.73b3c2c-0ubuntu1~ripps1~precise버전입니다.(앗, 저는 gl3옵션이 있네요)

mplayer 로그를 확인해 보면, 정상적으로 작동이 되고 있습니다. 오류나, 설정변경 메시지도 출력되지 않는데도 이러니 이상하네요…

vdpau가 적용되지 않는 이유는 그래픽 드라이버에 있는 건가요?
nvidia를 319로 업그레이드 시켰으나, 화면이 먹통이 되어 다시 다운그레이드 시켰습니다.
가능하면 nvidia를 업그레이드 하지 않고, vdpau를 사용하고 싶습니다. 문제가 어디에 있는지 모르겠네요 ㅜㅜ

글쎄요! 왜 업그레이드 후 화면이 먹통이 될까요?
dkms가 제대로 작동 하지 않는 것 같기도 합니다.

로그도 남지 않았다 하시니 딱히 뭐라 말씀 드리기 어렵네요!

mplayer를 직접 컴파일하시는게 좋습니다
–enable-vdpau