Nas용도 리눅스 서버구축하려고 하는데요. 파티션문제좀 문의 드려요

  1. 사용 용도
    주용도 NAS, APM, PYDIO, 아이폰과 안드로이드 파일 공유,
    (파일 외부 접근 및 내부 내트워크의 원활한 파일공유)

  2. H/W 환경
    CPU I3-4160
    RAM 8G
    HDD 2T (2개) - Raid 구성(미러링)
    (추후 하드를 추가로 구성해서 Raid 5로 구성예정)


이런 용도로 사용하려고 합니다.
우분투 14.04를 설치해서 구성하려고 합니다.

  1. 구체적인 내용은 아래와 같이 하려고 하는데요…
    웹서비스와 스마트폰의 미디어파일공유등은 어떤걸 써야 할지를 잘모르겠습니다.
    그외 추천해주고싶은 프로그램도 좋습니다.

외부 파일 공유 - PYDIO
내부 파일 공유 - SAMBA
웹 서비스(블로그, 홈페이지) - APM + ?
아이폰과 안드로이드 파일공유 - ?

  1. 위와 같은 목적으로 하려고 하는데요… 파티션 구성과 용량을 어떻게 해야할까요??
    /
    /boot
    /usr
    /usr/var
    .
    .

  2. 레이드로 묶은 4T의 하드디스크를 사용하려면 특별한 조치(?) 같은게 필요한가요??

  3. 제가 서버용 텍스트 환경을 잘쓸줄 몰라서 그러는데요… 데스크탑용으로 구성해도 무리가 없을지요??

선배님들의 많은 조언을 부탁드립니다.

레이드(미러)로 하드디스크에 우분투를 설치하는데…
새로깔기, lvm으로 설치시 너무나 많은 파티션(?)이 나오더라구요…

그래서 disks로 확인해보니
— 디바이스 —
2.0 TB Hard Disk
WDC -----------
2.0 TB Hard Disk
WDC -----------
16 GB Drive
Lexar USB Flash Drive

이런식으로 나오고요
아래쪽에

– Other Devices –
2.0 TB Block Device
/dev/dm-0
984 MB Loop Device
/cdrom/casper/filesystem.squashfs
4.3 GB Loop Device
/cdrom/casper-rw

Other Devices 쪽에 있는 2.0 TB Block Device는
설치 파티션(/, /boot, swap 등…)구성을 할수가 없고요 포멧만 되는데요… 어떻게 해야하나요?
레이드한 드라이브에는 부팅시스템을 구성할수 었나요?

  1. 일단은 레이드 상에서 설치를 완료했습니다.
    바이오스 부분에서 하드를 2개를 따로 따로 부팅순서를 주면 설치가 되지 않더군요… 음.

그런데, 문제는 다음과 같은 에러를 내면서 로긴을 하지 못합니다.
원인으로 /boot 파티션이 없다는 것 같은데… 파티션 부분을 보게 되면 없는건 맞습니다.

파티션에 /swap 과 / 두개만 보이던군요 lvm도 설치가 되어 있고요.

에러 메시지는
The disk drive for /Boot is not read yet or not present.
Continue to wait, or Press S to skip mounting or M for manual recovery.

S 를 누르면 우분투가 뜨는데… 설치되어 있는 하드가 마운트 되지 않더군요, 256M 하드 2개만 마운트 돼네요…
M 을 누르면 프롬프트가 뜨구요…

PS. 아 답글을 기다리는 마음이 애가 타는군요… 문론, 안되는 영어실력으로 이곳 저곳을 뒤져가며 해결해볼 노력을 하지만.
쩝, 힘들군요. ㅜ,.ㅜ
차라리 리눅스를 포기하고 윈도우로 가고 싶은 마음도 굴뚝같고요…

답해주신 답변 잘 보았습니다.

파티션은 알려주신 링크로 많은 도움이 되었습니다.

감사합니다.

뭐… 접근한 결론은 소프트웨어 레이드(페이크 레이드)로는 부팅 디스크를 만들수 없다는거 같습니다.

madam 으로 레이드 파티션을 설정해주었습니다.(미러)

madam -C /dev/md0 /dev/sda /dev/sdb …

페이크 레이드로 정상적으로 잡혔습니다.

파티션도 정상적으로 /, /swap, /boot 분할도 되고요.

그런데 GRUB 에러가 나더군요… 부팅이 안되요 ^^;;

뭐 다른 방법은 없는걸까요??

서버용으로 사용하려고 하는데요… ^^;;

난관이 많아서 ㅎㅎ

새로운 시도로는 "윈도우 + 우분투"를 해보려고 합니다.

윈도우 상에서는 정상적인 설치가 가능하거든요…

윈도우 설치후 우분투를 설치를 했습니다.

윈도우와 같이 설치를 선택하고 설치를 하면 이전과 같은 증상이 발생하네요…

??? ??? ?? 에러 발생 후 설치가 안되네요…

좀더 찾아 봐야 할런지… 음…

레이드를 사용하려는 이유는 데이터들이 중요한 것들이 많아서 안전장치를 두려는 의도입니다.

뭐 비싼 레이드 카드를 구입하면 해결되겠지만… 최소한의 비용으로 처리하려다 보니… 머리가 많이 빠지네요 ㅎㅎ

음 저의 경우 일반적인 설치 과정처럼 진행해서 RAID HDD에서도 문제없이 부팅가능하게 설치가 되던데요.
혹시 설치 과정에서 raid를 인식할것인지 물어보는 과정이 나오던데 이 과정에서 문제 없이 진행하셨는지요?

그리고, 혹여 설치 이후에 grub로 부팅이 되지 않는 경우가 발생하시더라도
인터넷에서 grub 복구 하는 방법을 찾으셔서 복구 과정을 거치시면 문제없이 부팅이 가능하게 만들 수 있는 것으로 알고 있습니다.

이전 버전 그러니까 12.04버전에서는 설치과정에서 grub 셋팅이 문제가 발생하였었는데,
이후 복구 과정을 통해서 grub를 /dev/mapper/에 잡힌 RAID 파티션에 강제로 설치 하였을 때
문제 없이 부팅하였습니다.

이상입니다.