Panel이 사라짐

제목 그대로입니다. 부팅 혹은 재부팅 후에 위 아래 panel이 없어져버립니다. 그래서 그때마다 패널을 초기화 시키는데 이게 살짝 귀찮더군요.
패널이 안사라지게 하는 방법이 없을까요? 지가 뭐 인어공주도 아니면서 물거품처럼 사라져버리다니 ㅡ.ㅡ

재부팅 때마다 항상 사라지나요?

저는 아이콘이 한두개 사라질때가 있는데 패널 사라진 적은 (2008년 이후로) 아직 2~3번 밖에 없습니다.

최근 사라진 패널 스크린 캡쳐
[attachment=0:1l1xqq0z]001.jpg[/attachment:1l1xqq0z]

매번 부팅할때마다 사라지고 있습니다. 디스플레이 해상도를 손 본 이후 매번 사라지더군요.

[quote="foo":11ihcnc1]매번 부팅할때마다 사라지고 있습니다. 디스플레이 해상도를 손 본 이후 매번 사라지더군요.[/quote:11ihcnc1]
두가지 해결책이 있을 것 같은데,

첫번째는 디스플레이 해상도와 패널과의 충돌 문제를 짚어보고 고치는 것이 있고,
두번째는 로그인 후에 자동으로 패널 리셋 스크립을 바로 또는 몇 초 후에 띄워서 비교적 쉽게 고치는 방법이 있습니다.

어느 방법을 선호하세요?

분명 디스플레이 해상도와 문제가 있을 수 있을 것입니다. 제가 지난달에 부팅관련 게시판에 올린것 처럼 해상도가 800600으로 고정되어 있어서 별 쇼를 다하면서 며칠전에 그 방법을 찾아 내서 원래 노트북이 갖고 있던 1024768을 맞추어 놓았거든요. 그리고 그 이전에 부팅하면서 로그인 화면이 나오기전에 세션과 터미널에 문제가 있다는 문구가 보이고 있기도 합니다.
따라서 첫번째 두번째 방법 다 알고 계시다면 둘다 시도해 볼 용의가 있습니다.

[quote="foo":3n2grzhn]분명 디스플레이 해상도와 문제가 있을 수 있을 것입니다. 제가 지난달에 부팅관련 게시판에 올린것 처럼 해상도가 800600으로 고정되어 있어서 별 쇼를 다하면서 며칠전에 그 방법을 찾아 내서 원래 노트북이 갖고 있던 1024768을 맞추어 놓았거든요. 그리고 그 이전에 부팅하면서 로그인 화면이 나오기전에 세션과 터미널에 문제가 있다는 문구가 보이고 있기도 합니다.
따라서 첫번째 두번째 방법 다 알고 계시다면 둘다 시도해 볼 용의가 있습니다.[/quote:3n2grzhn]

첫번째 방법은 그쪽 시스템 설정 파일을 다 파악하고 있어야 가능할 것 같습니다.
화면 해상도 해결하기 위해서 손본 단계와 설정 파일을 올려주시면 아시는 분께서 말씀해주실 것입니다.

두번째 방법은,
시스템 > 기본 설정 > 시작 프로그램 기본 설정
위에 있는 곳에 가셔서, 추가 하시고
이름과 설명은 원하시는 대로 알기 좋게 적으시고,
명령 칸에 다음과 같이 적어주세요.

[code:3n2grzhn]gconftool-2 --shutdown && rm -rf ~/.gconf/apps/panel && pkill gnome-panel[/code:3n2grzhn]
위 코드 앞에 "sleep 숫자 && "를 추가하시면 숫자 만큼 지연된 후 명령이 실행됩니다.

두번째 방법을 시도했습니다.

그 이후로 나타나는 현상

  1. 스크랩 설정 후 일반모드로 로그인했을 때는 아무것도 안나타난다. 바탕화면에서 마우스 오른쪽 버튼도 작동하지 않는다. 따라서 그 전에는 바탕화면에서 오른쪽 마우스 클릭 후 터미널 실행해서 패널을 리스타트했는데 그것마저 안된다

  2. 스크랩 설정 후 로그인 할때 안전모드로 실행하면 설정한 스크랩이 작동한다, 단 패널에 있던 네트워크 관리자 아이콘과 전원상태(배터리)아이콘이 사라져버렸다.

  3. 스크랩을 끄고 일반모드로 로그인하면 이전과 같이 패널이 시작되지 않고, 터미널에서 리스타트 시키면 패널에 기존에 있던 모든 아이콘이 정상적으로 나타난다.

  4. 스크랩을 끄고 안전모드로 로그인하면 패널이 나타난다, 단 패널에 있던 네트워크 관리자 아이콘과 전원상태(배터리)아이콘이 사라져버렸다.
    이상입니다.

[quote="foo":stq0jwvo]두번째 방법을 시도했습니다.

그 이후로 나타나는 현상

  1. 스크랩 설정 후 일반모드로 로그인했을 때는 아무것도 안나타난다. 바탕화면에서 마우스 오른쪽 버튼도 작동하지 않는다. 따라서 그 전에는 바탕화면에서 오른쪽 마우스 클릭 후 터미널 실행해서 패널을 리스타트했는데 그것마저 안된다

  2. 스크랩 설정 후 로그인 할때 안전모드로 실행하면 설정한 스크랩이 작동한다, 단 패널에 있던 네트워크 관리자 아이콘과 전원상태(배터리)아이콘이 사라져버렸다.

  3. 스크랩을 끄고 일반모드로 로그인하면 이전과 같이 패널이 시작되지 않고, 터미널에서 리스타트 시키면 패널에 기존에 있던 모든 아이콘이 정상적으로 나타난다.

  4. 스크랩을 끄고 안전모드로 로그인하면 패널이 나타난다, 단 패널에 있던 네트워크 관리자 아이콘과 전원상태(배터리)아이콘이 사라져버렸다.
    이상입니다.[/quote:stq0jwvo]

스크랩이 어떤 것이죠?
저는 그래픽 관련해서 스크랩 설정/해제 가 없어서요…

뭔가 또 어디가 꼬였는지 모르지만 문제를 해결했습니다.

도와주셔서 감사합니다. ^^

[quote="foo":34w4hh2k]뭔가 또 어디가 꼬였는지 모르지만 문제를 해결했습니다.

도와주셔서 감사합니다. ^^[/quote:34w4hh2k]

해결한 방법을 팁에 올려주시면 다음 분을 위해서 좋은 팁이 될 것입니다. ;)