제가 본격적으로 PGO(Profile Guieded Optimization)firefox를 빌드할까합니다.

제가 Mozconfig 를 만들줄 몰라서…

해매고 다니다가… 오늘 아치리눅스 포럼에서 좋은걸 발견해서, PKGBUILD 를 바탕으로 PGO firefox 를 만들어볼까 합니다.

특징으로는 트레스 몽키가 켜져 있고 (대체 무슨 이유인지 어떤 파폭 3.5 에서는 안켜져 있더군요. ), Xulrunner 에 의존성을 지니지 않고, PGO 형식으로 최적화 되어있어 빠릅니다.

일단 3.5.* 버젼, 3.6* 버젼중에 뭘 할지 고민중인데…

여러분들의 의견을 듣고 싶네요 ㅎㅎ… deb 파일은 Checkinstall 로 만드는수밖에 없을거 같네요. Rules 파일에서 mozconfig 를 읽어드리게 할 수 잇는 방법이 안보입니다.

P.S 제가 64비트 시스템이라;;; 제가 나중에 문서화 시키면 그에 맞추어 32비트 바이너리를 만들어주실분 구합니다. ㅎㅎ…

또 추가로 상호님한테 문의해보고 계정을 우분투 저장소로 써도 되는지 물어보고 된다면 저장소를 만들어보겠으나, 안될경우에 지원해주실분 있으시면 감사하겟습니다. ㅎㅎ

여러분 .;…

이거 일종의 설문글이에요 ㅜㅜ…

3.6 컴팔할지 3.5 컴팔할지 대답을 주셔야합니다. ㅜㅜ

3.6은 개발중이라서 안정성을 확신할 수 없다면

3.5가 나을 꺼 같은데요.

아, 아까 IRC에서 물어보셨던게 이 뜻이었군요.

그렇다면 안정된 3.5버전에 한 표 던지겠습니다.

아까는 그냥 테스트용인 줄 알고… 3.6으로 추천했습니다.

일단 3.5 하고 3.6 둘다 돌렸는데;; 둘다 같은 에러 나면서 빌드가 안되는군요;; 흠?? 빌드 의존성은 build-dep firefox-3.6 ( 3.5 ) 하고 auto-apt 로 다 맞추었는데;;

make[1]: Leaving directory /home/hanbin973/firefox-pgo-beta/mozilla-central' OBJDIR=/home/hanbin973/firefox-pgo-beta/mozilla-central/ff-pgo python /home/hanbin973/firefox-pgo-beta/mozilla-central/ff-pgo/_profile/pgo/profileserver.py INFO | automation.py | Application pid: 4856 TEST-UNEXPECTED-FAIL | automation.py | Exited with code -11 during test run INFO | automation.py | Application ran for: 0:00:00.092347 make: *** [profiledbuild] 오류 245 bash: return: can only return’ from a function or sourced script

저는 휠스크롤 가속이 기본으로 켜져 있는(또는 추가된?) 3.6에 한 표를…

아,

http://www.downloadsquad.com/2009/08/14 ... ly-builds/

3.7 나왔습니다[야]

파폭이 베타나 알파가 나온다고 해서, 부가기능[=플러그인]이 호환이 바로 되냐 안 되냐의 차이 외에는
성능상의 bug는 그다지 본 적이 없어서…뭐, 그것도 버젼 무시 부가기능을 설치하면 상관 없긴 합니다만…^^;
결론적으로는 버젼은 그다지 상관이 없다는 얘기죠…^^;;;;

저는 가능하면 한글판 최신 버젼…nightly 버젼도 상관 없습니다. 고로, 3.7 알파가 나왔다니
3.7도 환영 입니다. ^^;;;

저도 얼리어댑터용 최신버전 강추!

아시는 분 들이 많으리라 봅니다만, 혹시나 모르시는 분 들을 위한 소개를…^^;

파폭 부가기능은 파폭의 버젼 호환성 체크로 인해 최신 버젼의 파폭에서 이전 부가기능이 작동하지 않는 경우가 있습니다만,
[url=https://addons.mozilla.org/ko/firefox/addon/6543:3e8iozdu]Nightly Tester Tools[/url:3e8iozdu] 라는 것을 설치하면
최신 버젼, 혹은 개발 버젼의 파폭이라도 이전/정식 버젼의 부가기능을 사용할 수 있습니다.

설치 후, 최신 버젼 파폭에서 작동 안 되는 부가 기능 들을 모두 강제로 실행하기[혹은 강제 설치] 옵션을 주면 됩니다.

일단 3.6a1 은 제가(?) 쓸 용도로 컴팔 했는데 다되어가네요. ㅎㅎ

제가 빌드한게 성공은 했는데 seg fault 가 나는군요.

조만간에 그 deb 파일을 올려드릴테니 테스트 바랍니다.

실행유무만 테스트 바랍니다. ㅎㅎ 실사용 용도가 아니라 ㅎㅎ;;

일단 잠시동안 접을까 합니다. ㅎ;;;

시간이;; ㄷㄷ

hanbin973님, 작품 기대하겠습니다.

잘 되면 널리 전파하여 주시길.

나중에 시간이 되면, 그 때라도…

음핫핫

아잉흥행~

성공했습니다~ 그런데 언어팩 설치가 안되네요. 버젼 바꾸기 하면 xml 뭐시기 에러나고;; ㅋㅋ

어쨋거나 빠르고 좋네요. 스샷 첨부. 조만간에 32비트도 뿌리겟습니다.

[attachment=0:xze5n5cs]-2.png[/attachment:xze5n5cs]

그리고 deb 파일은 http://hanbuntu.pe.kr/firefox_3.6a1-1_amd64.deb

[quote="hanbin973":7c7xds0n]음핫핫

아잉흥행~

성공했습니다~ 그런데 언어팩 설치가 안되네요. 버젼 바꾸기 하면 xml 뭐시기 에러나고;; ㅋㅋ

어쨋거나 빠르고 좋네요. 스샷 첨부. 조만간에 32비트도 뿌리겟습니다.

[attachment=0:7c7xds0n]-2.png[/attachment:7c7xds0n]

그리고 deb 파일은 http://hanbuntu.pe.kr/firefox_3.6a1-1_amd64.deb[/quote:7c7xds0n]

저도 64bit OS로 설치한 터라…해당 파일을 테스트해 보겠습니다. ^^;

P.S> 방금 전에 한빈님 PPA를 통해서, 카탈 9.8 설치로 하이브리드 크로스파이어(785G 내장 + HD 3450)을 했습니다.

리눅스에서는 안될건데요;; 후덜덜

저는 780g + hd3450 인데;;

가르쳐 주심이 ㅎㅎ

3.5.4pre 빌드 성공했습니다.

냠냠 잘되는군요 ㅡㅡ;;

라이브러리문제로 안될때에는 IRC 로 와서 저한테 물으시면 됩니다 ㅋ;;