Php를 실행하지 못하고 다운로드하겠다고 나옵니다

Ubuntu 10.04 SERVER 사용중입니다.
LAMP Server로 사용하려고 하는데, 외부에서 접속하면 php를 실행하지 못하고 Download창이 뜹니다(익스, 파폭 모두 동일합니다.)

/var/www 에 test용 file을 넣으면 잘 동작하지만, userdir에 넣으면(/home/userid/public_html) 다운로드 하겠다고 창이 뜹니다.
(html등은 잘 보이는데…)

LAMP는 우분투 설치하면서 선택하여 설치하였고

"cd /etc/apache2/mods-enabled

ln -s …/mods-available/php5.conf php5.conf
ln -s …/mods-abailable/php5.load php5.load"

이렇게 소프트 링크 걸고, apache2 재시작하였으나 동일합니다.

검색해보니 이렇게 동작하는 분들이 간혹 있던데…이런 저런 답변들을 적용해봐도 잘 모르겠습니다.
혹시 아시는분…도움 부탁드려요.

/etc/apache2/mods-enabled/php5.conf 라는 파일을 열어 보시게 되면,

# To re-enable php in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.
<IfModule mod_userdir.c>
    <Directory /home/*/public_html>
        php_admin_value engine On
    </Directory>
</IfModule>

이라는 부분이 있습니다. 아래와 같이[b:162r6lgx] 주석처리[/b:162r6lgx] 하시고 아파치 재실행해보시기 바랍니다. sudo /etc/init.d/apache2 restart

저도 위 문제로 인하여 한 2틀 고생하다가 모님의 도움으로 알게 되었습니다.

# To re-enable php in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.
#<IfModule mod_userdir.c>
#    <Directory /home/*/public_html>
#        php_admin_value engine On
#    </Directory>
#</IfModule>

주석처리 하지 않으면 이상하게 php를 인식하지 않고 다운로드 되버리거나 그대로 출력해버리는 문제가 생깁니다.