Python 관련 질문

프로그램을 하나 설치하려는데요
Python이 꼭 필요한데
2.6 이하 버전만 컴파일이 가능하다고 하네요.
그런데 현재 Lab 컴퓨터에 2.6.2 버전이 설치되어 있습니다.
제 컴에는 2.5.x가 설치되어서 컴파일이 되는데
Lab 컴퓨터에는 더 높은 버전이 설치되어 있어서 설치가 안되네요.
Lab 컴퓨터에 설치할 방법이 있을까요?
감사합니다.^^
참고로 vmtk라는 툴킷입니다.

낮은 버전의 python을 설치하고 컴파일하시면 됩니다.

시냅틱 패키지 관리자 프로그램에서 python2.4 를 검색하시면 원하는 프로그램을 찾을 수 있습니다.

현재 파이썬(실제 발음은 ‘파이슨’ 이지만 한국 커뮤니티에서는 ‘파이썬’ 으로로 발음을 통일하였습니다.) 버젼은 3.0 까지 업데이트 되었지만,
실제적으로 많이 사용하는 버젼은 2.3, 2.4 버젼이죠.

설치하신뒤 터미널에서 python2.4 를 치시면 실행이 됩니다.

그러나… 원하시는 작업이 tk 와의 연동이므로

python2.4-tk 프로그램도 함께 설치하셔야 합니다.

감사합니다.
오늘 해볼께요

참고삼아 말씀드립니다.

python 인터프리터는 여러 버전을 동시에 설치할 수 있습니다.

그리고 그 중 어떤 것은 그냥 ‘python’ 명령어로 사용할지 지정도 가능하고요.

그냥 참고하시라고 말씀드립니다. :)

[quote="pcandme":1vx5pfju]참고삼아 말씀드립니다.

python 인터프리터는 여러 버전을 동시에 설치할 수 있습니다.

그리고 그 중 어떤 것은 그냥 ‘python’ 명령어로 사용할지 지정도 가능하고요.

그냥 참고하시라고 말씀드립니다. :)[/quote:1vx5pfju]
갠히 딴지 걸어 봅니다.
그럼 파이선 설치가 우분투에서 기본이 2.5 버전일때 2.6 또는 하위/상위 버전 설치 후
2.4 또는 2.6으로 컴파일 하려면 어찌해야 하는 지요 ?

본 질문에 중요한 게 아직 안 나온 거 같아요 ! 소스를 어찌 고쳐라 같은 …
#!/usr/bin/python 을 #!/usr/bin/python2.4로 하든 가…
조금 쉬운, 많은 이가 이해 할 설명 같은 거…

P.S. : 나 술 좀 했으니 따지지 마새요, 내일 댓글 주세요 8-)

[quote="강분도":1r3a4hjl][quote="pcandme":1r3a4hjl]참고삼아 말씀드립니다.

python 인터프리터는 여러 버전을 동시에 설치할 수 있습니다.

그리고 그 중 어떤 것은 그냥 ‘python’ 명령어로 사용할지 지정도 가능하고요.

그냥 참고하시라고 말씀드립니다. :)[/quote:1r3a4hjl]
갠히 딴지 걸어 봅니다.
그럼 파이선 설치가 우분투에서 기본이 2.5 버전일때 2.6 또는 하위/상위 버전 설치 후
2.4 또는 2.6으로 컴파일 하려면 어찌해야 하는 지요 ?

본 질문에 중요한 게 아직 안 나온 거 같아요 ! 소스를 어찌 고쳐라 같은 …
#!/usr/bin/python 을 #!/usr/bin/python2.4로 하든 가…
조금 쉬운, 많은 이가 이해 할 설명 같은 거…

P.S. : 나 술 좀 했으니 따지지 마새요, 내일 댓글 주세요 8-)[/quote:1r3a4hjl]
ㅋㅋ. 뭐 굳이 소스에다가 넣을 필요 있나요. 좀 타이핑이 늘어나지만 터미널에서 python<ver> filename.py 하면 되는데요. ㅎㅎ

물론 소스 첫 줄에다가 #!/usr/bin/python 등을 넣으면 소스 코드에 실행 권한 줘서 바로 실행할 수도 있지만요.

더 정확한 답변을 드리려면 해당 프로그램을 설치해 보아야 되는데… 이건 다른 분께 패스하겠습니다. :)

vmtk가 "the Vascular Modeling Toolkit"이 맞나요?

그렇다면 아래 페이지에서 우분투 9.04 설치 방법을 다루고 있는데요,

http://www.vmtk.org/Main/Installation

우분투 9.04용 바이너리 패키지를 제공하는데, 굳이 소스 빌드하실 필요가 있으신 건지요?

아니시라면, 위 페이지에 자세히 설명되어 있으니 참고하셔서 설치하면 될 듯 합니다.

그럼 이만.