[해결] python2.6-minimal 패키지 설치 오류

아래와 같이 나오네요.

python2.6-minimal 패키지를 푸는 중입니다 (…/python2.6-minimal_2.6.1-0ubuntu9_i386.deb에서) …
new installation of python2.6-minimal; /usr/lib/python2.6/site-packages is a directory
which is expected a symlink to /usr/local/lib/python2.6/dist-packages.
please find the package shipping files in /usr/lib/python2.6/site-packages and
file a bug report to ship these in /usr/lib/python2.6/dist-packages instead
aborting installation of python2.6-minimal
dpkg: /var/cache/apt/archives/python2.6-minimal_2.6.1-0ubuntu9_i386.deb을(를) 처리하는 데 오류가 발생했습니다 (–unpack):
pre-installation script 하위 프로세스가 오류 1번을 리턴했습니다
처리하는 데 오류가 발생했습니다:
/var/cache/apt/archives/python2.6-minimal_2.6.1-0ubuntu9_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

부분 업그레이드? 도중에 발생했는데,
저런 현상이 반복되는 군요
혹시 비슷한 증상이나 해결하신분 계신지 궁금합니다.

위 패키지 정보를 보니 9.04 군요
알파경우 패키지가 서로 의존성이 안맞을때가 있습니다.
그런경우는 [b:snqy1q8p]관리/ 업테이트 관리자[/b:snqy1q8p] 에서 업데이트 시도를 해보시고 그래도 안될시엔
[u:snqy1q8p]며칠 기다리시면 새패키지로 의존성 해결되어 업데이트 됩니다.[/u:snqy1q8p]

하하 시간이 해결해주는 문제군요;

ㅠㅠ

그런데 저만 이런가 싶기도 해서요;;
ㅠㅠ

지금 python 2.6 업데이트와 관련하여 작업이 진행중이라 그렇습니다. 작업 완료 후에 공지한다고 했으니 기다려보세요.

https://lists.ubuntu.com/archives/ubunt ... 00541.html

[quote:20xg5zoc]After the alpha-5 release we will update the python interpreter from 2.5.4 to
2.6.1. For about 24 hours you will no be able to cleanly update jaunty, until
some packages are rebuilt with python2.6. For a better upgrade experience during
this time, please add the pythoneers PPA to your sources.list, which already
has the rebuilds available:

deb http://ppa.launchpad.net/pythoneers/ppa/ubuntu jaunty main

Don’t forget to remove this line after the change is complete; [color=#FF0000:20xg5zoc]I will notice
u-d-a when the change is done for main.[/color:20xg5zoc] For universe you may experience
installability issues somewhat longer.

Matthias
[/quote:20xg5zoc]

[quote="air21c":g88ogleq]하하 시간이 해결해주는 문제군요;

ㅠㅠ

그런데 저만 이런가 싶기도 해서요;;
ㅠㅠ[/quote:g88ogleq]
업데이트 해보십시요 될 것 입니다.
파이선이 데탑 리눅스 에서 아주 중요하죠
현재 9.04 에는 2.5., 2.6, 3.0 이 설치 되어 있을 것 입니다.

[code:g88ogleq]
ii python2.5 2.5.4-1ubuntu2
ii python2.5-minimal 2.5.4-1ubuntu2
ii python2.6 2.6.1-0ubuntu9
ii python2.6-minimal 2.6.1-0ubuntu9
ii python3-minimal 3.0.1-0ubuntu2
ii python3.0 3.0.1-0ubuntu5
ii python3.0-minimal 3.0.1-0ubuntu5
[/code:g88ogleq]

네 해보니 되네요 감사합니다.

[quote="강분도":19skcs31][quote="air21c":19skcs31]하하 시간이 해결해주는 문제군요;

ㅠㅠ

그런데 저만 이런가 싶기도 해서요;;
ㅠㅠ[/quote:19skcs31]
업데이트 해보십시요 될 것 입니다.
파이선이 데탑 리눅스 에서 아주 중요하죠
현재 9.04 에는 2.5., 2.6, 3.0 이 설치 되어 있을 것 입니다.

[code:19skcs31]
ii python2.5 2.5.4-1ubuntu2
ii python2.5-minimal 2.5.4-1ubuntu2
ii python2.6 2.6.1-0ubuntu9
ii python2.6-minimal 2.6.1-0ubuntu9
ii python3-minimal 3.0.1-0ubuntu2
ii python3.0 3.0.1-0ubuntu5
ii python3.0-minimal 3.0.1-0ubuntu5
[/code:19skcs31][/quote:19skcs31]