Scim이 한영 전환이 안 됩니다

설치할 때 키멥에서 korea로 정해줬고 한국어도 지정했습니다.
설치 후 설정은 키보드 설정에서 101/104호환모드 추가해서 선택해놨고요.
언어설정에는 한국어로 설정되어 있습니다.
scim 설정에서 키보드 레이아웃은 영어 (미국)으로 되어 있고,
IM엔진 전체설정에서 한글 선택, 아래에는 한국어만 선택, 기타는 선택해제되어 있고,
한글키 설정은 Hangul과 ctrl-space 기타 여러가지로 되어 있습니다.
증상은 키보드로 한영 전환이 안 되는 현상입니다.
scim 단축키 설정에서 다른 키조합을 한글 키로 설정해봐도 다 안 먹힙니다.
마우스로 클릭해서 전환하는 건 됩니다.
8.04는 처음부터 한글이 되는 것 같던데 노트북이라서 안 되는 건가요?
예전 버전처럼 setkeycodes 같은 수정을 해줘야 하는지요?

컴을 자주 안 해서 여기 와 본지가 1년 넘은 거 같은데 회원가입을 해야되네요.
1년 전에 설치해보고 새버전이 나왔길래 또 설치해봤습니다.
윈도우가 식상해서 웹서핑만 주로 하지만 간간히 리눅스 꾸미기를 해보려고요.

첨가.
scim이 하나 더 실행되니까 그건 한영 전환이 되는데 원래 걸 전환되게 할 줄은 모르겠습니다.

포맷하고 다시 설치하니까 잘 됩니다.
역시 잘 모를 땐 포맷하고 다시 까는게 좋군요.
아까와 두가지 다른 점이 있는데, 처음에는 파티션을 수동으로 잡았는데 이번에는 자동으로 잡았고, 처음에는 설치할 때 키보드를 Korea Republic of로 했는데 이번에는 101/104 key compatible로 했다는 점입니다.
혹시나 참고가 될까 하고 적습니다.

위와 같은 경우는 xorg.conf 파일을 열어서 Section "InputDevice" 을 살펴보면
Option "XkbLayout" "xx" 에서 xx 부분이 us로 되어 있는게 보통입니다.
이걸 kr로 바꾸면 해결됩니다.

이유는 모르겠지만 제대로 변경되지 않는 경우가 종종 있는것 같네요.