[solved]우분투에서 auctex의 preview-latex 설정을 도와주세요

안녕하세요. 우분투에 입문한지 얼마 되지 않는 초보 리눅스 사용자입니다.
이번에 학교에서 레이텍 강의가 있어서 레이텍을 집에서도 써보자 생각하여 학교와 동일한 환경의 구축을 위해서 리눅스 상에 이맥스를 설치하고 그곳에 auctex를 설치하였는데, preview-latex라는 좋은 기능이 있어서 써보려고 삽질을 했지만 하루종일 해도 답이 안나옵니다. :roll:

과정은 다음과 같습니다.(ko.tex의 설치는 하지 않았습니다. 한글 환경은 나중에 도입할 생각입니다)

sudo apt-get install emacs
sudo apt-get install texlive-full
sudo apt-get install auctex

이 다음에 이맥스로 .tex파일을 열어보니 분명히 라이온 아이콘도 떠있고, 미리보기 아이콘도 떠있어서 제대로 설치되었다고 생각하고, 적당한 샘플파일로 위키피디아의 샘플 코드로 시험을 해봤습니다.

http://en.wikipedia.org/wiki/LaTeX

위 페이지에 있는 코드로요.

그런데 다음과 같은 에러가 뜨면서 프리뷰가 안됩니다. :cry:

[code:2heomdig]
Running Preview-LaTeX' on region’ with ``latex -interaction=nonstopmode "&prv_test" region.tex’’
This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian)
entering extended mode
(./region.tex
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, farsi, arabic, croatian, bulgarian, ukrainian, russian, czech, slov
ak, danish, dutch, finnish, french, basque, ngerman, german, german-x-2009-06-1
9, ngerman-x-2009-06-19, ibycus, monogreek, greek, ancientgreek, hungarian, san
skrit, italian, latin, latvian, lithuanian, mongolian2a, mongolian, bokmal, nyn
orsk, romanian, irish, coptic, serbian, turkish, welsh, esperanto, uppersorbian
, estonian, indonesian, interlingua, icelandic, kurmanji, slovenian, polish, po
rtuguese, spanish, galician, catalan, swedish, ukenglish, pinyin, loaded.
CUSTOMISED FORMAT. Preloaded files:
.
article.cls 2007/10/19 v1.4h Standard LaTeX document class
size12.clo 2007/10/19 v1.4h Standard LaTeX file (size option)
amsmath.sty 2000/07/18 v2.13 AMS math features
amstext.sty 2000/06/29 v2.01
amsgen.sty 1999/11/30 v2.0
amsbsy.sty 1999/11/29 v1.2d
amsopn.sty 1999/12/14 v2.01 operator names
.
No file region.aux.
(/usr/share/texmf/tex/latex/preview/preview.sty
(/usr/share/texmf/tex/latex/preview/prtightpage.def)
(/usr/share/texmf/tex/latex/preview/prauctex.def
No auxiliary output files.

(/usr/share/texmf/tex/latex/preview/prauctex.cfg))
(/usr/share/texmf/tex/latex/preview/prfootnotes.def)
Preview: Fontsize 12pt
) !name(test.tex) !offset(-3)

LaTeX Warning: No \author given.

!name(test.tex) !offset(0) )
No pages of output.
Transcript written on region.log.

Preview-LaTeX finished with nothing to show at Sat Oct 15 20:25:07
LaTeX: LaTeX found no preview images

[/code:2heomdig]

도와주세요… 하루를 몽땅 썼는데도 해결이 안됩니다.

---------8<----------8<-----------

해결했습니다.
문제는 간단해서, auctex와 ghostscript 사이에 문제가 있었다는것 같습니다.

이미 보고된 문제로, auctex 개발자들에 의해 해결되어 있었습니다.

다만 우분투의 apt-get으로 얻는 소프트웨어가 그 해결되기 전 버전의 소프트라서 문제가 생기는것 뿐으로,

http://packages.debian.org/sid/auctex

에서 최신의 auctex를 도입하면 문제해결됩니다.