Ssd 관련 설치문제인데 도움 구합니다

이전에 irc로도 한번 도움을 구해보았는데 여의치가 않았습니다.
제가 월초에 ssd를 구입해서 제 노트북에 설치하고 기존의 hdd는 노트북업체에서 따로 파는 멀티부스트라는 cd 롬을 탈거하고 그 자리에 hdd를 장착할 수 있게 해주는 것을 이용해서 꽂은 후에 우분투를 설치하였는데(usb설치) 설치 완료후에 첫 부팅을 하는데 부팅이 되지 않더군요

그래서 그 멀티부스트라는 것을 제거하고 설치하니 부팅은 됩니다만 이번에는 그 멀티부스트 드라이브가 인식이 안되는 겁니다. 디스관리에 보면 기계는 인식을 하는데 마운트하려고 하면 오류가 있어서 안된답니다. 그래서 다시 파티션 재설정해주고 포맷하면 될까했는데 그래도 인식이 안되더군요

이 후에 다시 설치를 시도하면서 일단 usb부팅시에는 멀티부스트를 탈거했다가 설치를 진행중에 하드웨어 인식전에 다시 멀티부스트를 장착시켜 보았습니다. 이번에는 분팅이 되고 인식도 되었습니다. 그러나 부팅중에
udevd-work[351]: open /dev/null failed: No such file or directory
를 보여주더군요

그리고 이것저것 설정하는 소음좀 줄일 요량으로 중에 hdd 스핀오프설정을 전원관리에서 해주었지만 스핀오프가 한시간이 지나도 안되네요

여러가지 궁리와 수차례의 재설치를 하고 결국 다시 윈도우로 일단 후퇴하였습니다. ㅠㅠ

그 동안 보니까 그 멀티부스트의 하드를 보니 이것을 장착하고 부팅을 해보면 이 hdd가 sda로 되어 있고 시스템을 설치한 ssd는 sdb로 되어 있는 겁니다. 처음 설치 때는 그 hdd를 탈거한 체로 해서 sdd가 sda로 되어있었는데 말이죠. 그런데 이게 sda가 sdb로 바뀌면서 뭐가 문제가 생겨서 위의 부팅중 메시지가 보이는 것 같습니다. 이건 설치usb로 부팅을 할 때 hdd를 장착한 체로 설치할 때의 파티션 설정시 디스크 인식된 것도 hdd가 sda로 sdd가 sdb로 되어 있습니다. hdd를 sdb로 인식하게 할 수 있으면 좋을 텐데…

긴글 읽어주셔서 감사하고요 위의 상황에서 제가 궁금한것은

  1. sdb에 우분투를 설치하면 왜 부팅이 되지 않는지
  2. 현 hdd의 인식시 sda로 인식하지 않고 sdb로 인식할 수 있게 할 수 있는 방식은 없는지
  3. hdd스핀오프가 되게 하는 방법은 없는지
  4. ahci 스핀오프설정시 시간 설정하는 방법입니다.

hdd부분은 hdd의 마스터 슬레이브 점퍼설정 문제인가 싶은데 hdd가 2.5인치 웨스턴디지탈 320g 모델입니다. 그래서 웨스턴디지탈 홈페이지에 찾아 봤더니 점퍼설정을 할 필요가 없다고 되어 있군요 점퍼설정하는 소켓을 4핀짜리가 있는데도 말이지요 제가 점퍼설정은 3.5.인치 밖에 해본 적이 없는지라 2열 8핀은 해보겠는데 4핀은 어떻게 하는 것인지 모르겠군요

스핀오프 시간설정은 구글을 해보니 랩탑모드 활성화 시켜서 설정파일에서 설정하는 것이 나오는데 이 랩탑모드를 설치하고 활성화 시키면 오히려 ahci관련기능을 지워버려서 전원관리의 절전이나 하이버네이션관련 메뉴가 없어지더군요

혹시 이글을 보시는 능력자분 계시면 꼭 좀 도움 말씀을 부탁드립니다.

저도 멀티부스트로 SSD 추가하여 HDD+SDD 사용하고 있습니다.
HDD는 기존 하드 자리에 SSD는 멀티부스트에 장착하여 기존 DVD자리에 설치하면
HDD는 sda로 SSD는 sdb로 잡힐 것이고
바이오스에서 부팅순서를 ssd -> hdd 순으로 바꾼 후
sdb에서 설치하시면 아무 문제 없이 설치될 것 같은데요. (저는 그렇게 사용하고 있습니다.)
GRUB은 sdb에 설치하구요. (디폴트로 sda에 되어 있다면 설치 시 변경하면 됩니다.)
저의 경우에는 ssd에 윈도우7 먼저 설치 후 우분투 10.10 설치했으며 아무 문제 없었습니다.

ssd를 sda로 변경하고 싶으시면 hdd와 위치를 바꾸어 장착하시면 될 겁니다. ^^

그것이 바이오스의 부팅순서 지정에는 멀티부스트가 잡히질 않습니다. 따라서 순서지정을 하고 싶어도 할 수가 없군요 ㅜㅜ 된장!! 컴퓨터가 워낙 저가라서 바이오스가 똥인지 작년에 한성컴퓨터 노트북이 49만에 나와서 혹해서 구입했는데 plymouth하고 콘솔모드 화면도 1024x768이 최대군요 어쨌든 그래서 그런지 멀티부스트에서는 부팅이 안돼네요 hdd에 윈도7 설치하고 멀티부스트에 ssd설치하면 grub화면에서 운영체제를 설치할 수 있어야 하는데 grub 화면은 없이 그냥 윈도우부팅이 되어 버리는군요 ㅜㅜ

그리고 hdd를 원래의 자리로 sdd를 멀티부스트로 옮겨도 항상 hdd가 sda가 되더군요 제 ssd는 인텔 g2 120g 모델인데 hdd에 왜 밀릴까요?

바이오스에 보면 원래의 hdd자리가 sata1으로 나오고 sata2가 멀티부스트로 나오거든요 점퍼설정으로 슬레이브로 놓으면 어떨까? 생각중인데 그 점퍼가 없어서…

아 그리고 grub를 sdb에 설치할 수 있습니까? 한번 찾아 보아야 겠군요 그생각은 못해 봤는데요 ㅎㅎ

방법을 아시면 링크라도 좀 걸어 주시면 얼른 해보겠습니다.