파일관리자에서 studio.sh 실행법

파일관리자에서 더불클릭하면 gedit로 들어가 벼리네요

실행화일 클릭하면 실행, 보기 이렇게 나와야 되는데요

어떻게 해야 되나요

실행 권한을 주셔야 합니다.

[quote="workman729":2lwr26ul]실행 권한을 주셔야 합니다.[/quote:2lwr26ul]
755로 되어 있는데도 gedit로 바로 들어가요

콘솔에서는 실행되고요.

GUI로 실행하시기를 원하시는 것이 맞나요? 정확히 읽어 보지 않아서…!
어째든 말씀 하신 식으로 처리하시려면 /home 파티션 또는 디렉토리에 실행 권한이 있어야 합니다.
만약 /root 파티션에 home도 들어간다면 /root 파티션에 주어야 합니다.

그러나 보안상 추천하지 않습니다. 하지마십시오.
만약 하시겠다면 /etc/fstab에서 수정 하시면 됩니다.
관련 정보는 구글링 해보시고 모르시겠다면 재질문 부탁 드립니다.

우분투 사용자 모임 메뉴얼(?)에도 관련 정보가 있더군요!

추가

옛날에 ext4 파티션을 사용시 마운트 옵션에 ro 옵션이 사용된 적이 있습니다.
이렇게 하면 노틸러스에서 실행할까요를 물어보는 데 실제로 실행되는 것은 아닙니다.

아마도 이것을 두고 말씀하시는 것 같은 데 맞는 지 모르겠군요??
만약 실행 버튼 클릭시 실제로 실행 되었다면 마운트 옵션에 exec 옵션이 들어가 있을 것 입니다.

보안상 상당한 문제점을 노출하는 데 그렇게 하지 마시고
desktop 파일을 만들어서 exec=bach -c ‘실행 파일 위치’ 주는 방법을 사용 하십시오.

desktop 파일을 만든 후 속성에 보안탭을 보시면 실행 권한 주시고
~/.local/share/applications 에 복사해 넣으시고 재 로그인 하시면 아이콘(지정 가능)을 클릭하는 것으로 실행 됩니다.

위에서 제시한 방법을 사용 하시고 자동 실행 하시려면 ~/.config/autostart에 넣어 두시면 됩니다.

참고 하십시오. 아래는 예제입니다.

[quote:r8siiamf]# vi ~/.local/share/applications/studio.desktop
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Studio Excuteable Shell Script
Comment=코멘트 적어 주시고
Exec=bash -c ‘위치/파일명 --옵션’
Terminal=false
Icon=아무거나 지정
Categories=System;Settings; (넣어두고 싶은 카테고리 선택 alacarte에도 보입니다.)[/quote:r8siiamf]

질문자의 의도를 명확히 파악하지 못한 것 같습니다.

아마도 노틸러스 설정에서 실행 가능한 파일을 실행할 것이냐의 선택 문제를 말씀 하신 것 같습니다.
이 선택을 매번 물어 보기로 선택하시면 실행할 것이냐의 창이 뜹니다.

이것을 두고 말씀 하신 것 같습니다. 맞나요?
그러나 실행이 제대로 안될텐데요…??