글꼴 중 상당수가 가장자리가 깨져 나옵니다

처음에는 그 유명한 29/69-language-sel… 파일 문제인 줄 알았습니다.
그런데 한글 글꼴에는 아무 문제가 없더군요.
그래서 자세히 보니 깨지는 글꼴의 경우 8~16크기에서만 깨져 나오네요.
스크린샷 첨부합니다.
혹시 몰라서 알려드리는데요, 전 msttcore와 중국어, 일본어 글꼴을 설치했고 글꼴 설정 xml 파일은 아무것도 건드리지 않았습니다.

올려주신 사진과 폰트가 "깨진/깨져"의 의미로 봐서, AA(Anti Aliasing)가 적용 안된다는 것을 말씀하시는 것이죠?

[quote="han9k":1w67n7hd]올려주신 사진과 폰트가 "깨진/깨져"의 의미로 봐서, AA(Anti Aliasing)가 적용 안된다는 것을 말씀하시는 것이죠?[/quote:1w67n7hd]처음에는 글꼴 관련 용어를 잘 몰라 제목을 이렇게 올렸는데 찾아보니 안티 앨리어싱 문제가 맞는 것 같습니다.

이것저것 설치하는 과정에서 AA가 빠졌나 보죠.

.fonts.conf 설정에서 강제로 AA 먹여주면 될듯 합니다.

[quote="oppor":266x5m97].fonts.conf 설정에서 강제로 AA 먹여주면 될듯 합니다.[/quote:266x5m97].fonts.conf 설정파일 작성을 제가 할 줄 몰라서 그러는데 저에게 필요한 부분 좀 알려주시면 감사하겠습니다.

혹시 저 말고 이런 문제 또 겪는 분들 안계신가요? 해결책 못지않게 원인도 알고싶네요.

[quote="jincreator":1nw7uwrn][quote="oppor":1nw7uwrn].fonts.conf 설정에서 강제로 AA 먹여주면 될듯 합니다.[/quote:1nw7uwrn].fonts.conf 설정파일 작성을 제가 할 줄 몰라서 그러는데 저에게 필요한 부분 좀 알려주시면 감사하겠습니다.

혹시 저 말고 이런 문제 또 겪는 분들 안계신가요? 해결책 못지않게 원인도 알고싶네요.[/quote:1nw7uwrn]

AA인지 힌팅인지… 뭐라고 부르는지 저도 테크니컬한 용어는 잘 모릅니다.
그냥 알아들으면 의사소통한 것이죠. ^^;

두가지 해결책이 있습니다.
첫번째는 힌팅을 강제로 입히는 것으로…
되는 폰트가 있고 안되는 것이 있을 때는 어떤 문제인지 잘 모르겠지만,
다음과 같이 하신 후에 밑에 붙여넣기해서 추가해보세요.

[code:1nw7uwrn]sudo gedit ~/.fonts.conf[/code:1nw7uwrn]

<?xml version=”1.0″ ?>
<!DOCTYPE fontconfig SYSTEM “fonts.dtd”>
<fontconfig>
<match target=”font”>
<edit name=”autohint” mode=”assign”>
<bool>true</bool>
</edit>
</match>
</fontconfig>

다음은 AA를 활성화 하는 것인데,
System > Preferences > System Settings > Appearance 가신 후에
"Look & Feel"에서 > Fonts - anti-aliasing 활성화해보세요.

[attachment=0:1pxyrooq]screenshot1.png[/attachment:1pxyrooq]

혹시 jincreator님은 좌분투 ?

보통 mscorefonts (MS 폰트) 류는 AA , Hinting 이 없어야 깔끔하기에 (굴림 비슷 글꼴들)
설치시에 글꼴 설정을 뭍는데 클레어 타입인가 선택하면, 영문 글꼴 8-16까지의 AA , Hinting을 끄는 것으로 알고 있습니다.
근데 이것이 그 그꼴에만 적용된 것이 아니고 모든 글꼴에 적용이 된것이지요.
sudo dpkg-reconfigure fontconfig-config 하여 다시 설정 해보십시오.

혹시 검색을 통해 다른 분들이 보실 까 올려주신 해결책에 대한 결과를 작성합니다.[quote="han9k":27n3iv3v]다음과 같이 하신 후에 밑에 붙여넣기해서 추가해보세요.

[code:27n3iv3v]sudo gedit ~/.fonts.conf[/code:27n3iv3v]

<?xml version=”1.0″ ?>
<!DOCTYPE fontconfig SYSTEM “fonts.dtd”>
<fontconfig>
<match target=”font”>
<edit name=”autohint” mode=”assign”>
<bool>true</bool>
</edit>
</match>
</fontconfig>[/quote:27n3iv3v]아무 일도 일어나지 않았으며 fontconfig 갱신 시 오류를 출력합니다.

[quote="han9k":27n3iv3v]다음은 AA를 활성화 하는 것인데,
System > Preferences > System Settings > Appearance 가신 후에
"Look & Feel"에서 > Fonts - anti-aliasing 활성화해보세요.[/quote:27n3iv3v]한글판은 시스템->기본 설정->모양->글꼴->자세히로 들어가 힌팅 옵션을 만지라는 뜻으로 해석했습니다만 이미 LCD용으로 힌팅이 잡혀 있으며 모든 글꼴에 대해서 AA가 안되는 것도 아니었습니다.

[quote="강분도":27n3iv3v]보통 mscorefonts (MS 폰트) 류는 AA , Hinting 이 없어야 깔끔하기에 (굴림 비슷 글꼴들)
설치시에 글꼴 설정을 뭍는데 클레어 타입인가 선택하면, 영문 글꼴 8-16까지의 AA , Hinting을 끄는 것으로 알고 있습니다.
근데 이것이 그 그꼴에만 적용된 것이 아니고 모든 글꼴에 적용이 된것이지요.
sudo dpkg-reconfigure fontconfig-config 하여 다시 설정 해보십시오.[/quote:27n3iv3v]ttf-mscorefonts-installer 패키지 설치시 사용자 약관에 대한 동의는 묻지만 글꼴 설정은 묻지 않으며 설치 시 /etc/fonts 폴더는 건드리지 않습니다.
그리고 edgy 이후부터는 sudo dpkg-reconfigure fontconfig로 명령어가 바뀌었습니다.

비록 해결책은 아니지만 도움주신 분들 감사합니다.

해결책은 찾아본 결과 /etc/fonts/conf.d/29-language-selector-ko-kr.conf 파일을 삭제하는 것입니다.
이 파일은 심볼릭 링크이므로 삭제해도 상관 없습니다.
다만 특이한 점이 이 파일의 내용은 한글 글꼴에 한해서이고 10~22사이 또는 11~16사이에만 영향을 미치게 되어 있다는 것입니다.