최대절전모드 후 사운드 불능

프로디지 7.1LT 입니다.

최대절전모드로 전원 off 후 다시 재진입 하면 소리가 안나옵니다.

시스템-기본설정-소리

에서 ALSA 나 PUSLE, OSS 기타 등등 선택할 수 있는건 다 해봤지만,

역시 같은 결과입니다.

그래서 내장사운드(엔포스3) 사용중인데, 이 놈은 최대절전모드 상관없이

잘 나오네요. 혹시 해결방법 없나요?

일단 사블 5.1 Live로 테스트 해보니…최대절전모드로 왔다 갔다 해도

소리 재생 잘 되네요. 이 문제는 특정 사운드카드에 한정되어 있나 봅니다.

그리고 윈도우의 사운드드라이버 처럼 여러 사운드효과(극장효과 등등)

할 수 있는 사운드유틸은 없나요?

좀 된 글이지만 답글이 없어 올려봅니다.
8.1 쓸때 해외 포럼 통해서 알아낸건데…

sudo vim(또는 gedit) /etc/default/acpi-support 해서
HIBERNATE_MODE=shutdown 을 HIBERNATE_MODE=platform 로 바꿔주시고 저장후 사용하시면 해결됩니다.

http://ubuntuforums.org/showthread.php?t=294275

[quote:2xl3viv8]
Another fix working for many users without having to install another kernel seems to set another hibernation mode in the acpi settings.

To try this edit /etc/default/acpi-support
and set ‘HIBERNATE_MODE=shutdown’
to ‘HIBERNATE_MODE=platform’

If hibernation still works, you should have sound again. If not, undo the changes.
This solution was posted in the same bug thread mentioned above.
[/quote:2xl3viv8]

고맙습니다. 할수 없이 포기했었는데…다시 한번 테스트해봐야 겠네요.

이런…역시 안되네요.

[quote="bandman159":34fqk1h2]고맙습니다. 할수 없이 포기했었는데…다시 한번 테스트해봐야 겠네요.

이런…역시 안되네요.[/quote:34fqk1h2]

방금 bandman159님의 글을 읽고 관련 설정들을 다시 살펴보고 몇가지 테스트를 해보고 왔는데요, 저의 경우에도 저렇게 설정 후 시스템->기본설정->소리에서 관련 설정들을 모두 alsa로 설정하면 suspend(절전)이든 hibernate(최대절전)이든 복귀후 깨지거나 안나옵니다. 그래서 전부 pulseaudio로 설정했더니 노래 틀어놓고 꺼버려도 켜지면서 복귀와 동시에 절전, 최대절전 모두 정상적으로 노래가 듣던 부분부터 자연스럽게 이어지면서 아주 잘 됩니다. 혹시 저랑 비슷한 상황일지도 모르니 이것도 한 번 시도해 보세요 ;)

참고로 위에서 말씀드린 설정에 대해서 덧붙이자면…shutdown 대신 채워넣은 platform이라는 설정은 시스템을 종료하는데 있어서 acpi 기능과 연동해서 종료하는 설정이라고 보여집니다. 대충 읽어보고 온거라서 아닐수도 있습니다만, 대강 맞을겁니다.; 따라서 본인의 컴퓨터가 acpi를 지원해야 의미가 있는거겠죠…근데 뭐 요즘 컴퓨터들이야 대강 다 지원되니…암튼 bandman159님 사운드의 쾌유를 빕니다. :D

고맙습니다. 펄스오디오로 하니 잘 나오네요. :D

[quote="bandman159":fchh7yo3]고맙습니다. 펄스오디오로 하니 잘 나오네요. :D[/quote:fchh7yo3]

와 정말 잘됐네요!!! 다행입니다. :mrgreen:

그리고 아마 알고 계시겠지만…제가 아주 가끔씩 겪는 일인데요…
혹시라도 사용중에 갑작스럽게 사운드가 불안정하게 동작하거나 에러가 나서 버벅대면 그것땜에 또 리붓하지 마시고
바로 $sudo alsa force-reload 하신 다음 볼륨조절 새로 해주시면(alsa mixer랑 pulseaudio랑 볼륨이 초기화 됨. 평소 올려두셨으면 다시 올려줘야함)
바로 이전처럼 다시 문제없이 사용 가능합니다.