자바 설치할 때 질문입니다

우분투 11.04 서버를 사용하고 있습니다.

java를 설치 하려 하는데

jdk 1.6.17 버전을 설치하고자 하는데… 가능한건가요??

아무리 찾아봐도 jdk 1.6만 설치하는 방법만 나와있지 세세한 방법이 나와있지 않네요…

음…

고민입니다.

jdk 1.6.0_17을 설치해야 하는 이유가 무엇입니까?

1.0, 1.1, 1.2, 1.3, 1.4 여기까지는 매 버젼 마다 큰 차이가 납니다만,
그이상에선 버젼 별로 그리 큰 차이가 나지 않는데… 굳이 update17을 설치해야 하는 이유를 잘 모르겠네요.

만약 프로그램에서 필요로 하는 라이브러리에 의해 문제가 생긴다면,
제작 프로그램에서 System Properties를 읽어서 버젼 체크를 할 필요는 있겠지만요…

그리고 또 세세한 방법이란 것이 무엇을 말하는 것 인지 모르겠네요.

자바가상머신은 자바기계어코드를 실행할 환경입니다.

포인트는 역시 자바기계어코드(xxx.class) 입니다.
자바가상머신은 단지 이 기계어코드를 해당 하드웨어에서 동작하게끔 만들어주는 기반일 뿐이라는 겁니다.
보통은 자바가상머신이 어떤 형태로 동작하는지 몰라도 되고, 프로그래머는 자바코드에만 주력하게됩니다.

마치 컴퓨터를 사용하는 사람이 컴퓨터의 내부동작을 몰라도 컴퓨터를 사용하는 것 과 비슷한 것이지요.

그리고 사실 jdk나 jre는 설치를 필요로 하지 않습니다.
그냥 복사해넣고, 경로만 잡아주고
실행하면 됩니다.
설치는 사실 버젼관리와 업그레이드를 위한 것이죠