[완료]한글 언어팩 설치 및 로캘 설정

안녕하세요 궁금한점이 있어 질문글 남겨봅니다.

현재 11.04 (64Bit) 사용중입니다.
언어설치 및 로케일 설정에 문제가 생겨서 여쭤봅니다.
한글 언어팩 설치를 하였는데 언어선택에서 한국어 표기도 안나오고 로케일 설정에서도 선택항목이 나타나질 않습니다.

[img:2kg0nxv8]http://i.imgur.com/GzOMB.png[/img:2kg0nxv8]

[img:2kg0nxv8]http://i.imgur.com/3K612.png[/img:2kg0nxv8]

로그아웃 후 하단 언어 선택 하는 곳에는 한국어 대신에
Unclassified (ANSI_X3.4-1968)와 English (United States) 이렇게 나오구요.

해결 방법이 있으면 도움 주시면 감사드리겠습니다.

sudo apt-get update
sudo apt-get install language-support-fonts-ko language-support-input-ko language-pack-ko language-pack-ko-base language-pack-gnome-ko language-pack-gnome-ko-base

#/etc/environment
LANG="ko_KR.utf8"
LANGUAGE="ko_KR;ko;en_GB;en"
LC_ALL="ko_KR.utf8"

#~/.bashrc
LANG="ko_KR.utf8"
LC_ALL="$LANG"
LANGUAGE="ko_KR;ko;en_GB;en"
IM=ibus
XIM=$IM
GTK_IM_MODULE=$IM
QT_IM_MODULE=$IM
XMODIFIERS="@im=$IM"
export LANG LC_ALL LANGUAGE IM XIM GTK_IM_MODULE QT_IM_MODULE XMODIFIERS

이렇게 입력하신 후
source ~/.bashrc
im-swich -c ==> ibus선택
sudo update-alternatives --config xinput-ko_KR ==>ibus선택

재그인 해보세요.

[code:u271icah]source ~/.bashrc [/code:u271icah]

[quote:u271icah]bash: warning: setlocale: LC_ALL: cannot change locale (ko_KR.utf8)
bash: 경고: setlocale: LC_ALL: 로케일을 바꿀 수 없음 (ko_KR.utf8)
[/quote:u271icah]

[code:u271icah]$ locale[/code:u271icah]

[quote:u271icah]locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=ko_KR.utf8
LANGUAGE=ko_KR;ko;en_GB;en
LC_CTYPE="ko_KR.utf8"
LC_NUMERIC="ko_KR.utf8"
LC_TIME="ko_KR.utf8"
LC_COLLATE="ko_KR.utf8"
LC_MONETARY="ko_KR.utf8"
LC_MESSAGES="ko_KR.utf8"
LC_PAPER="ko_KR.utf8"
LC_NAME="ko_KR.utf8"
LC_ADDRESS="ko_KR.utf8"
LC_TELEPHONE="ko_KR.utf8"
LC_MEASUREMENT="ko_KR.utf8"
LC_IDENTIFICATION="ko_KR.utf8"
LC_ALL=ko_KR.utf8[/quote:u271icah]

이렇게 나오는군요…

아하 로케일이 설치가 안되었군요.

sudo apt-get install locales

#/var/lib/locales/ko
ko_KR.UTF-8 UTF-8
ko_KR.EUC-KR EUC-KR

sudo locale-gen

감사합니다. 한글표시가 됩니다.
그런데 언어 도구 실행을 시키면 실행되고 1초후 자동으로 언어도구가 중지되는군요…

신경써주셔서 감사합니다. :D

[quote="nyota":3qa0iyr9]
그런데 언어 도구 실행을 시키면 실행되고 1초후 자동으로 언어도구가 중지되는군요…
[/quote:3qa0iyr9]

무슨 문제가 있나 보군요.
터미널에서 gnome-language-selector를 실행해보세요.
출력결과를 봐야 알 듯…

[quote:2y1gggx5]Traceback (most recent call last):
File "/usr/bin/gnome-language-selector", line 27, in <module>
options=options)
File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 195, in init
self.updateLocaleChooserCombo()
File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 60, in wrapper
res = f(*args, **kwargs)
File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 904, in updateLocaleChooserCombo
self.updateExampleBox()
File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 982, in updateExampleBox
self.label_example_currency.set_text(locale.currency(20457.99))
File "/usr/lib/python2.7/locale.py", line 261, in currency
s = format(‘%%.%if’ % digits, abs(val), grouping, monetary=True)
File "/usr/lib/python2.7/locale.py", line 190, in format
return _format(percent, value, grouping, monetary, *additional)
File "/usr/lib/python2.7/locale.py", line 196, in _format
formatted = percent % value
ValueError: unsupported format character ‘-’ (0x2d) at index 2
[/quote:2y1gggx5]

이와같이 출력되는군요

[quote="protochaos":3fbb6bwf]아하 로케일이 설치가 안되었군요.

sudo apt-get install locales

#/var/lib/locales/ko
ko_KR.UTF-8 UTF-8
ko_KR.EUC-KR EUC-KR

sudo locale-gen[/quote:3fbb6bwf]

우옷…
죄송 패스를 잘못 적였네요…
/var/lib/locales/supported.d/ko

그런데… 어자피 xxx.d형태로 된 디렉토리는 인클루드형식으로 쓰는거라 위 폴더에 해도 되나 봅니다? :mrgreen:

혹시 모르니 고쳐보시구요.

저건 음 python라이브러ㄹ의 문제 일지도 모르겠구… 아니면 로케일이 설정이 제대로 안되서 그런가?
sudo dpkg-reconfigure python2.7
sudo dpkg-reconfigure locales
해보세요.

[quote:2x300cf1]우옷…
죄송 패스를 잘못 적였네요…
/var/lib/locales/supported.d/ko

그런데… 어자피 xxx.d형태로 된 디렉토리는 인클루드형식으로 쓰는거라 위 폴더에 해도 되나 봅니다? :mrgreen:
[/quote:2x300cf1]

패스설정은 제가 본 경로로 알맞게 맞춰서 수정하여 실행하였습니다. ^^

[code:2x300cf1]sudo dpkg-reconfigure python2.7
sudo dpkg-reconfigure locales[/code:2x300cf1]

[quote:2x300cf1]Generating locales…
en_AG.UTF-8… up-to-date
en_AU.UTF-8… up-to-date
en_BW.UTF-8… up-to-date
en_CA.UTF-8… up-to-date
en_DK.UTF-8… 로캘 정의 파일 da_DK' 파일을 열 수 없습니다: 그런 파일이나 디렉터리가 없습니다 failed en_GB.UTF-8... up-to-date en_HK.UTF-8... up-to-date en_IE.UTF-8... up-to-date en_IN.UTF-8... 로캘 정의 파일 hi_IN’ 파일을 열 수 없습니다: 그런 파일이나 디렉터리가 없습니다
failed
en_NG.UTF-8… 로캘 정의 파일 da_DK' 파일을 열 수 없습니다: 그런 파일이나 디렉터리가 없습니다 failed en_NZ.UTF-8... up-to-date en_PH.UTF-8... 로캘 정의 파일 tl_PH’ 파일을 열 수 없습니다: 그런 파일이나 디렉터리가 없습니다
failed
en_SG.UTF-8… up-to-date
en_US.UTF-8… up-to-date
en_ZA.UTF-8… up-to-date
en_ZW.UTF-8… up-to-date
ko_KR.EUC-KR… 로캘 정의 파일 ko_KR' 파일을 열 수 없습니다: 그런 파일이나 디렉터리가 없습니다 failed ko_KR.UTF-8... 로캘 정의 파일 ko_KR’ 파일을 열 수 없습니다: 그런 파일이나 디렉터리가 없습니다
failed
Generation complete.
[/quote:2x300cf1]

우선 아래의 파일들이 있는지 확인해 보세요.

/usr/share/i18n/locales/ko_KR
/usr/share/i18n/charmaps/EUC-KR.gz
/usr/share/i18n/charmaps/UTF-8.gz

있다면
localedef -cvi ko_KR -f EUC-KR ko_KR
localedef -cvi ko_KR -f UTF-8 ko_KR

명령으로 로케일을 만들어 줄 수 있습니다

만일 없다면 첨부한 파일을
sudo tar xvfPpz locales.tgz 명령으로 풀어주세요…

그고 로케일 파일을 만들어 주세요.

[quote="protochaos":1yb54tlh]
/usr/share/i18n/locales/ko_KR
[/quote:1yb54tlh]

위의 파일만 누락되어서 올려주신 파일에서 경로로 복사하여 다시 로케일 생성했더니 잘되는군요…
감사합니다. 귀한 시간 내주셔서 덕분에 해결이 되었습니다.

정말 감사드립니다. :mrgreen:

  • 감사합니다. -

문제가 해결되면 제목에 [완료]라고 적어주는게 센스라고
누군가 글을 올린 것을 본 적이 있습니다.

8-)

[quote="protochaos":1erdvwi4]문제가 해결되면 제목에 [완료]라고 적어주는게 센스라고
누군가 글을 올린 것을 본 적이 있습니다.

8-)[/quote:1erdvwi4]

네. 감사합니다.

참 잘하셨어요.

짝짝짝!! :lol:

우분투 11.10 64비트 버전에서 정확히 동일한 증상을 겪었습니다.

로케일이 설치되어 있지 않은 경우도 있겠지만 hash collision 에러와 함께 꼬여 있는 경우도 있습니다. 그래서 아래와 같이 해결했습니다:

$ sudo apt-get install localepurge

충돌나는 ko_KR.UTF-8 같은 것들을 삭제

$ sudo dpkg-reconfigure locales