한글 폰트 설정 문제

안녕하세요? 하디 헤론으로 리눅스에 입문한 초보 사용자 입니다.

다름이 아니라 우분투 공식 사이트에서 데스크탑용 파일을 받아 라이브 CD를 만들어서 설치를 하고나니, 한글 폰트가 아래 첨부파일 처럼 나와서요. 폰트가 이렇게 바탕(?)으로 나오면 설치가 제대로 안된 것이라고 들었는데, 폰트가 제대로 나오려면 어떻게 해야하는지 가르쳐주셨으면 합니다. 나름대로 패키지 관리자에서 한글 언어팩도 다시 설치해봤구요, 언어 설정도 다시 해봤는데 무엇이 잘못된건지 모르겠습니다. 검색해봐도 제가 가닥을 못잡아서 그런지 잘 안나오네요. 허허. 도와주십쇼.

안티앨리어싱 해주셔야 할듯합니다.

#sudo gedit /etc/fonts/conf.avail/29-language-selector-ko-kr.conf

<!-- Turn off antialias and autohint for Korean fonts depending on pixelsize –>

다음 줄 부터

</match>

까지

<!-- Turn off antialias and autohint for ttf-alee depending on pixelsize –>

다음 줄 부터

</match>

까지

사이를 <!-- 과 –> 으로 주석 처리 해줍니다.

혹시 저장소를 다음으로 해놓고 추가로 언어지원 패키지를 설치하셨나요?
다음서버로 해놓으면 설치가 제대로 안되는것 같습니다.

시냅틱 꾸러미 관리자에서 저장소 서버를 kr.archive.ubuntu.com로 바꿔놓고 패키지들을 재설치 해보세요. (권장)
시스템 -> 관리 -> 언어 메뉴를 통해서 설치하시면 편리합니다.

그리고 이건 제 경우 입니다…
폰트와 관련된 설정파일은 /etc/fonts/conf.avail에 위치하고 conf.d에는 심볼릭 링크를 통해 연결되어 있는데요.
conf.d 디렉토리에 존재해야할 심볼릭 링크 몇가지가 누락되어 있더군요.
그래서 누락된 3개를 직접 링크해주었더니 폰트가 제대로 나오더군요.

터미널에 다음과 같이 차례로 입력하시면 됩니다.

[code:102f5od6]cd /etc/fonts/conf.d
sudo ln -s ../conf.avail/29-language-selector-ko-kr.conf 29-language-selector-ko-kr.conf
sudo ln -s ../conf.avail/52-languageselector.conf 52-languageselector.conf
sudo ln -s ../conf.avail/69-language-selector-ko-kr.conf 69-language-selector-ko-kr.conf[/code:102f5od6]

kmk1290님. 감사합니다! 우분투 설치 후 반드시 해야할 일에 나와있는 방법이었네요. 죄송합니다.
AA가 안티 앨리어싱인줄 몰랐어요. 아니, 안티 앨리어싱이 뭔지도 몰랐네요. 하핫;.
아무튼 가르쳐주신대로 주석처리하고 부팅했더니 말끔하게 나왔습니다. 가르쳐주셔서 감사합니다.

gweere님. 친절하게 설명해주시고, 감사합니다!
저장소 서버가 다음인지 어딘지 몰라서 그냥 말씀하신대로 kr.archive.ubuntu.com으로 바꾸었구요, 설치까지 다시 했어요.
가르쳐주신 코드도 터미널에 입력했습니다! 다시 한번, 친절하게 가르쳐주셔서 감사합니다.
두 분 덕분에 문제가 해결됐어요. 제가 부주의하긴 했지만요… 아무튼 감사합니다^^.

바탕체로 표시되면 안되는(?) 것이었군요! 방금 글타래 보고 글꼴 설정 파일에 대한 링크를 추가했습니다. 앞선 글에서 소개한 명령어는 confavail이라고 나와 있는데, conf.avail이 맞는 것이죠? 저는 아래와 같이 명령어를 적용해 보았습니다.

cd /etc/fonts/conf.d
sudo ln -s …/conf.avail/29-language-selector-ko-kr.conf
sudo ln -s …/conf.avail/52-languageselector.conf
sudo ln -s …/conf.avail/69-language-selector-ko-kr.conf

그러고 나서 X윈도우를 다시 시작하니 이 사이트의 내용이 돋움체로 이쁘게 표시가 됩니다. :-)

그런데, 한가지 궁금한 것이 있습니다. 글꼴 파일에 대한 링크를 추가하고 나니까 터미널에서 영어 알파벳에 대해서도 돋움체로 표시가 됩니다. 돋움체의 알파벳도 자꾸 보니까 나쁘지 않습니다만, 호기심에 여쭤봅니다. 터미널 등의 응용 프로그램에서 알파벳은 영어 전용 글꼴로 표시하고 한글은 한글 글꼴로 표시하려면 어떻게 해야 하나요?

자답입니다. 리스트에 황용길님이 올린 글을 보고 그대로 따라했더니 잘 됩니다.

/etc/fonts/conf.d$ sudo vi 69-language-selector-ko-kr.conf
<!-- Set preferred Korean fonts –>
<match target="pattern">
<test qual="any" name="family">
<string>serif</string>
</test>
<edit name="family" mode="prepend" binding="strong">
<string>DejaVu Serif</string>
<string>UnBatang</string>
</edit>

[quote="jeongkyu":1t06ujj4]바탕체로 표시되면 안되는(?) 것이었군요! 방금 글타래 보고 글꼴 설정 파일에 대한 링크를 추가했습니다. 앞선 글에서 소개한 명령어는 confavail이라고 나와 있는데, conf.avail이 맞는 것이죠? 저는 아래와 같이 명령어를 적용해 보았습니다.
[/quote:1t06ujj4]

모르고 넘어갈뻔했네요. 차후에 문제가 될지 몰라서 고쳐놨습니다.
지적 감사합니다.

[quote="kmk1290":76936z8r]안티앨리어싱 해주셔야 할듯합니다.

#sudo gedit /etc/fonts/conf.avail/29-language-selector-ko-kr.conf

<!-- Turn off antialias and autohint for Korean fonts depending on pixelsize –>

다음 줄 부터

</match>

까지

<!-- Turn off antialias and autohint for ttf-alee depending on pixelsize –>

다음 줄 부터

</match>

까지

사이를 <!-- 과 –> 으로 주석 처리 해줍니다.[/quote:76936z8r]

감사합니다! 저도 같은 문제가 있었는데 이제서야 해결하는군요… ^^

이상이 있는줄도 모르고있었던… 사람… 잘보았습니다. ^^

[quote="jeongkyu":2gs2n4bd]바탕체로 표시되면 안되는(?) 것이었군요! 방금 글타래 보고 글꼴 설정 파일에 대한 링크를 추가했습니다. 앞선 글에서 소개한 명령어는 confavail이라고 나와 있는데, conf.avail이 맞는 것이죠? 저는 아래와 같이 명령어를 적용해 보았습니다.

cd /etc/fonts/conf.d
sudo ln -s …/conf.avail/29-language-selector-ko-kr.conf
sudo ln -s …/conf.avail/52-languageselector.conf
sudo ln -s …/conf.avail/69-language-selector-ko-kr.conf

그러고 나서 X윈도우를 다시 시작하니 이 사이트의 내용이 돋움체로 이쁘게 표시가 됩니다. :-)

그런데, 한가지 궁금한 것이 있습니다. 글꼴 파일에 대한 링크를 추가하고 나니까 터미널에서 영어 알파벳에 대해서도 돋움체로 표시가 됩니다. 돋움체의 알파벳도 자꾸 보니까 나쁘지 않습니다만, 호기심에 여쭤봅니다. 터미널 등의 응용 프로그램에서 알파벳은 영어 전용 글꼴로 표시하고 한글은 한글 글꼴로 표시하려면 어떻게 해야 하나요?[/quote:2gs2n4bd]

에서 sudo ln -s …/conf.avail/52-languageselector.conf 가 안된다고 나오네요.
sudo ln -s …/conf.avail/52-language-selector.conf 라고 하니깐 되던데요…

어쨌든 지금까지 한글이 잘못되었다는 것도 모르고 사용했었습니다.
바꾸니 보기도 좋고 좋네요.
감사※

[quote="gweere":1dazhy2t]
conf.d 디렉토리에 존재해야할 심볼릭 링크 몇가지가 누락되어 있더군요.
그래서 누락된 3개를 직접 링크해주었더니 폰트가 제대로 나오더군요.

터미널에 다음과 같이 차례로 입력하시면 됩니다.

[code:1dazhy2t]cd /etc/fonts/conf.d
sudo ln -s ../conf.avail/29-language-selector-ko-kr.conf 29-language-selector-ko-kr.conf
sudo ln -s ../conf.avail/52-languageselector.conf 52-languageselector.conf
sudo ln -s ../conf.avail/69-language-selector-ko-kr.conf 69-language-selector-ko-kr.conf[/code:1dazhy2t][/quote:1dazhy2t]

8.10 베타버전을 사용중인데 위의 3 링크가 모두 존재합니다.

정식버전에서는 이런 작업은 해주지 않아도 될듯 하네요.

돋움체였던가?로 처음부터 정상적으로 출력이 되네요.

하지만 폰트연결과 같은 .fonts.conf파일은 수정을 해 주어야 할것 같습니다.

[quote="main":2lr2as3v]

에서 sudo ln -s …/conf.avail/52-languageselector.conf 가 안된다고 나오네요.
sudo ln -s …/conf.avail/52-language-selector.conf 라고 하니깐 되던데요…

어쨌든 지금까지 한글이 잘못되었다는 것도 모르고 사용했었습니다.
바꾸니 보기도 좋고 좋네요.
감사※[/quote:2lr2as3v]

이미 심볼릭 링크가 존재하기 때문인 듯 싶습니다. 아래 gweere님 말씀처럼 심볼릭 링크가 빠지는 경우는 특별한 경우입니다…

[quote="gweere":2lr2as3v]
그리고 이건 제 경우 입니다…
폰트와 관련된 설정파일은 /etc/fonts/conf.avail에 위치하고 conf.d에는 심볼릭 링크를 통해 연결되어 있는데요.
conf.d 디렉토리에 존재해야할 심볼릭 링크 몇가지가 누락되어 있더군요.
그래서 누락된 3개를 직접 링크해주었더니 폰트가 제대로 나오더군요. [/quote:2lr2as3v]

대부분의 경우 아래 처럼 이미 3개의 파일은 링크가 잘되어 있습니다.

[code:2lr2as3v]
/etc/fonts/conf.d
lrwxrwxrwx 1 root root 53 2008-09-20 12:06 29-language-selector-ko-kr.conf -> /etc/fonts/conf.avail/29-language-selector-ko-kr.conf
lrwxrwxrwx 1 root root 38 2008-09-20 11:49 52-languageselector.conf -> ../conf.avail/52-languageselector.conf
lrwxrwxrwx 1 root root 53 2008-09-20 12:06 69-language-selector-ko-kr.conf -> /etc/fonts/conf.avail/69-language-selector-ko-kr.conf[/code:2lr2as3v]