망가진 패키지를 어떻게 고쳐야 하는지.. 모르겠습니다

혹시 모르니 아래를 해보세요.

[code:1xfuj8gd]sudo apt-get install -f[/code:1xfuj8gd]

[code:2vaucdnu]
sudo apt-get -f install
[/code:2vaucdnu]
이 명령으로 안되시면,

[code:2vaucdnu]
sudo apt-get install aptitude
sudo aptitude -f install
[/code:2vaucdnu]

aptitude의 의존성 해결 능력이 apt-get 보다 낫습니다. 그러나 처음 로딩 속도가 느린 흠이 있죠.

[quote="protochaos":1jzdipt5][code:1jzdipt5]
sudo apt-get -f install
[/code:1jzdipt5]
이 명령으로 안되시면,

[code:1jzdipt5]
sudo apt-get install aptitude
sudo aptitude -f install
[/code:1jzdipt5]

aptitude의 의존성 해결 능력이 apt-get 보다 낫습니다. 그러나 처음 로딩 속도가 느린 흠이 있죠.[/quote:1jzdipt5]

아아아… 말씀하신데로 해보았는데…

:cry:

aptitude 패키지를 사용할 수 없습니다. 하지만 다른 패키지가 참조하고 있습니다.
해당 패키지가 누락되었거나 지워졌다는 뜻입니다. 아니면 또 다른 곳에서
패키지를 받아와야 하는 경우일 수도 있습니다.

E: ‘aptitude’ 패키지는 설치할 수 있는 후보가 없습니다

다시 깔아야 하나요…우분투…

aptitude는 main 저장소에 등록된 패키지임에도, 설치할 수 있는 후보가 없다고 나오는 것을 보면,
패키지 목록을 제대로 가져오지 못한 것이 아닌가 싶습니다.
sudo apt-get update 하신 후, wine및 aptitude 설치를 다시 시도해 보세요.

그외에, add-apt-repository 명령으로 등록한 ppa나, /etc/apt/sources.list에 수동으로 등록한 저장소에서
같은 이름의 다른 버전의 패키지가 존재하거나, 의존성이 다르게 설정되어 있을 수도 있습니다.

등록된 저장소에서, 해당되는 패키지가 여러 개 존재하는지 확인은 다음과 같이 하실 수 있습니다.
apt-cache policy wine1.4-i386
apt-cache policy aptitude
여러 개가 존재하고 ppa나 수동으로 설정된 저장소가 존재할 경우, /etc/apt/sources.list나
/etc/apt/sources.list.d/ 디렉토리에 존재하는 해당 저장소에 대해서 #을 붙여 주석처리 해주신 후,
sudo apt-get update로 패키지 목록을 갱신하신 후, 다시 설치를 해보시기 바랍니다.

그 외에, 발생할 수 있는 것은, deb파일을 다운로드하여 설치하셨을 경우,
이 패키지에 대해서는 upgrade가 불가하며, 혹은 이 패키지에 의존된 다른 패키지가 apt-get을 통해 설치 되었고,
deb파일을 언인스톨했을 경우, 의존성에 문제가 발생할 수 도 있습니다.

[quote="protochaos":3aakdwwv]aptitude는 main 저장소에 등록된 패키지임에도, 설치할 수 있는 후보가 없다고 나오는 것을 보면,
패키지 목록을 제대로 가져오지 못한 것이 아닌가 싶습니다.
sudo apt-get update 하신 후, wine및 aptitude 설치를 다시 시도해 보세요.

그외에, add-apt-repository 명령으로 등록한 ppa나, /etc/apt/sources.list에 수동으로 등록한 저장소에서
같은 이름의 다른 버전의 패키지가 존재하거나, 의존성이 다르게 설정되어 있을 수도 있습니다.

등록된 저장소에서, 해당되는 패키지가 여러 개 존재하는지 확인은 다음과 같이 하실 수 있습니다.
apt-cache policy wine1.4-i386
apt-cache policy aptitude
여러 개가 존재하고 ppa나 수동으로 설정된 저장소가 존재할 경우, /etc/apt/sources.list나
/etc/apt/sources.list.d/ 디렉토리에 존재하는 해당 저장소에 대해서 #을 붙여 주석처리 해주신 후,
sudo apt-get update로 패키지 목록을 갱신하신 후, 다시 설치를 해보시기 바랍니다.

그 외에, 발생할 수 있는 것은, deb파일을 다운로드하여 설치하셨을 경우,
이 패키지에 대해서는 upgrade가 불가하며, 혹은 이 패키지에 의존된 다른 패키지가 apt-get을 통해 설치 되었고,
deb파일을 언인스톨했을 경우, 의존성에 문제가 발생할 수 도 있습니다.[/quote:3aakdwwv]

제가 다 이해할 수는 없지만…
일단 감사합니다…ㅜ