자바버전

안녕하세요.
질문이있습니다.

현재 64비트 우분투가 설치되어있는데요
java1.4를 써야하는 상황이에요.

오라클 홈페이지에서 j2sdk-1_4_2_18-linux-ia64.bin 를 다운받았는데 오류가 나서
검색을 했더니
sudo apt-get install ia32-libs 이렇게 하라고 하더라고요.
이렇게 하니깐 설치는 된것처럼 보였는데
설치 디렉토리를 /usr/lib/jvm/__에 옮기고

sudo update-alternatives --config java
했을때 1.4가 보이지 않습니다.

1.4버전을 쓸수있게 도와주세요

sonic@ubuntu3:~$ uname -a
Linux ubuntu3 3.8.0-36-generic #52~precise1-Ubuntu SMP Mon Feb 3 21:54:46 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
sonic@ubuntu3:~$ cat /etc/issue
Ubuntu 12.04.3 LTS \n \l

버전 관리 도구에서 강제로 1.4버전을 설치하는건 어떨까요?