아래글 소리관련 문제 작성자 입니다 해결됐습니다

문제는 역시 우분투에 있었습니다

이유는 저도 잘 모르겠는데

우분투로 부팅한후 윈도우로 부팅할시에 우분투에서 재시작 을 하지 않고

완전하게 shutdown하여 노트북 전원을 off시킨후 다시 노트북 전원을 켜서 윈도우로 부팅해야 소리가 나오네요

밑글에 몇분이 댓글 달아주신대로 저 또한 당연히 별개의 os이기때문에 절대 영향이 없을것이라 생각하고

수차례 윈도우 버전별로 포맷도해보고 사운드카드 드라이브를 깔아보고 할수있는 대로 다 해봤지만 제가 너무 좁게 생각 해서 해결이 쉽게 되지 않았던것 같네요

저랑 같은 문제 겪으시는 분들은 꼭 이글보고 해결 하셨으면 좋겠습니다

글쎄요! 말씀하신 바는 멀티 부팅 이용시 상대 OS를 완전히 정지하고 이용하는 것이 당연한 사항인데
그것 때문에 사운드가 문제가 있을 것으로는 볼 수 없을 것 같습니다.

전에는 어떤식으로 사용하셨나요? 혹 가상 OS에서의 문제를 말씀하신 것은 아닐런지요?
그렇다면 이해는 되지만 멀티 부팅에서 우분투의 문제로 이해하기엔 무리가 있을 듯 합니다.

참고 하십시오.

[quote="workman729":3e9l54zj]글쎄요! 말씀하신 바는 멀티 부팅 이용시 상대 OS를 완전히 정지하고 이용하는 것이 당연한 사항인데
그것 때문에 사운드가 문제가 있을 것으로는 볼 수 없을 것 같습니다.

전에는 어떤식으로 사용하셨나요? 혹 가상 OS에서의 문제를 말씀하신 것은 아닐런지요?
그렇다면 이해는 되지만 멀티 부팅에서 우분투의 문제로 이해하기엔 무리가 있을 듯 합니다.

참고 하십시오.[/quote:3e9l54zj]

Windows가 부팅할 때, 우분투 파티션을 읽어서 그 software를 사용하는 bug가 있나 봅니다. ㅎㅎㅎ
그렇지 않고서야… 그런 버그가 없다는 증거도 없잖아요? ㅎㅎㅎ

[quote="workman729":3g7ta46e]글쎄요! 말씀하신 바는 멀티 부팅 이용시 상대 OS를 완전히 정지하고 이용하는 것이 당연한 사항인데
그것 때문에 사운드가 문제가 있을 것으로는 볼 수 없을 것 같습니다.

전에는 어떤식으로 사용하셨나요? 혹 가상 OS에서의 문제를 말씀하신 것은 아닐런지요?
그렇다면 이해는 되지만 멀티 부팅에서 우분투의 문제로 이해하기엔 무리가 있을 듯 합니다.

참고 하십시오.[/quote:3g7ta46e]

이번에 처음 설치 한거구요
C드라이브 SSD에 윈도우7 설치하여 사용하다가 D드라이브 HDD에 ubuntu를 설치했습니다

그리고 ubnutu로 부팅한후에 셧다운 하지않고 리스타트를 해서 노트북을 재부팅 한후에 다시 윈도우로 부팅하였더니

외부스피커로는 소리가 나오나 이어폰을 꽂았을시에 소리가 나오지 않았습니다

그래서 윈도우 내에서 우분투가 설치된 D드라이브 볼륨 삭제후 포맷을 하고 재부팅을 했습니다

그래도 소리가 나오지 않아서 다시 윈도우를 포맷후 재설치했구요

헌데 그래도 또 소리가 안나왔습니다 그래서 다시 우분투를 D드라이브에 설치해서 멀티부팅을 만들고

우분투로 부팅하여 이번엔 셧다운으로 아예 피시 전원을 종료 시킨후에 윈도우를 부팅하니 다시 소리가 나온것입니다

어째든 이해가 잘되지 않지만 해결하셨다니 다행입니다.

제가 보기엔 드라이버 문제인 것 같지만 우분투를 셧다운 하든 강제로 전원을 리스타트 하든
우분투와는 관련이 없어 보입니다. 왜냐면 윈도우가 부팅되면 윈도우 소관이지 우분투 소관은 아닙니다.

다음에도 이런 경우가 있다면 고깝게 듣지 마시고 사운드 카드의 최신 드라이버를 설치해 보시기를 권해 드립니다.

뭐 우분투와 관련이 없다고는 할 수 없지만, 하드웨어에 문제가 있다고 봅니다.
전원을 완전히 끄고, 다시 켰을 때에는 하드부팅이라고 해서, 롬바이오스의 시작점 부터 시작하기에,
하드웨어 초기화 루틴이 동작합니다.
하지만 윈도우즈나 우분투에서 재시작을 할 때에는, 웜부팅이라고 해서, 하드웨어 초기화를 하지 않습니다.
이미 롬바이오스에서 부팅시 장치를 인식하고, 초기화 했기 때문에, 운영체제는 그것을 이용하되,
드라이버나 펌웨어를 이용해, 장치에 대한 설정을 다시 할 뿐입니다.
보통의 하드웨어들은 그 드라이버에서, 드라이버 로드시나, 초기화 루틴을 내포하고 있지만,
그렇지 않을 경우 문제가 발생할 수 있는 것입니다.
아니면, 이런 경우 드라이버를 제조사로 부터 다운로드하여 설정해보세요.
드라이버에서 하드웨어 직접적인 조작을 해서 초기화 루틴을 동작시킬지도 모르니까요.

아! protochaos님께 한수 배울 수 있는 경우인 것 같습니다.

질문자께서는 완전히 셧다운 시킨 경우와 OS의 재시작이 아니라 전원 버튼(리셋 버튼이 아니라)을 눌러서 재시작 하셨다고 2가지 경우를 말씀 하셨습니다.
그런 경우엔 롬 바이오스에서 하드웨어 초기화가 되는 것으로 알고 있습니다. 이 경우엔 콜드 부팅이 되겠죠!

물론 OS에서 재시작 기능으로 재 부팅하였다 하더라도 이해가 되지 않는 것은 매 한가지 입니다만
질문자게서는 우분투에서 사운드 문제를 지적하지 않으셨으니 하드웨어 상의 문제는 아니라고 판단 되었습니다.

그렇다면 저는 롬 바이오스와는 관련이 없으리라 생각하였습니다.
저는 그렇게 알고 있었고 이점을 잘 못 알고 있는 경우라면 protochaos님의 지적 부탁드립니다.