인터넷이 안되요

무슨 이유이지 모르겠으나 인터넷이 안됩니다.
아래는 제가 이것 저것 알아보면 해본건데…
참고 하시고… 해답좀 알려주세요.

윈도우에서 먼저 IP 주소를 받고 우분투로 접속해서 IP 주소를 할당 받으려고 하면 종종 안되더군요.
시간이 해결을 해줍니다만… (ipconfig에 나온 내용을 봐서는 한 시간이겠네요. ^^;)

급하시면 당장에는 윈도우에서 받은 IP 주소로 수동 설정해서 이용하세요.

혹은 윈도우에서 할당받은 IP 주소를 릴리즈 하신후에 우분투로 접속하셔도 됩니다.
(할당 받은 IP의 포기 가능 여부는 DHCP 서버의 정책에 따라 다른것이라 안될지도 모릅니다.)

[quote="gweere":6yfoyagg]윈도우에서 먼저 IP 주소를 받고 우분투로 접속해서 IP 주소를 할당 받으려고 하면 종종 안되더군요.
시간이 해결을 해줍니다만… (ipconfig에 나온 내용을 봐서는 한 시간이겠네요. ^^;)

급하시면 당장에는 윈도우에서 받은 IP 주소로 수동 설정해서 이용하세요.

혹은 윈도우에서 할당받은 IP 주소를 릴리즈 하신후에 우분투로 접속하셔도 됩니다.
(할당 받은 IP의 포기 가능 여부는 DHCP 서버의 정책에 따라 다른것이라 안될지도 모릅니다.)[/quote:6yfoyagg]

그렇다면 부팅할때 우분투로 인터넷을 쓸때는 꼭 우분투로 먼저 부팅을해야하나요?
제가 리눅스 설치가 이번이 첨이라… 답변이 이해가 안가요;;

[quote="redhaze":30e45q9b]그렇다면 부팅할때 우분투로 인터넷을 쓸때는 꼭 우분투로 먼저 부팅을해야하나요?
제가 리눅스 설치가 이번이 첨이라… 답변이 이해가 안가요;;[/quote:30e45q9b]

꼭 우분투로 먼저 부팅할 필요는 없습니다. 그리고 우분투에서 먼저 IP를 할당 받으면 반대로 윈도우에서 할당받지 못해 인터넷이 안될수도 있구요. 물론 정상적인 상황이라면 보통은 어느쪽을 나중에 부팅하던 항상 IP 주소를 할당 받을 수 있어야 합니다.

간헐적으로 발생하는 문제인데 원인은 모르겠습니다. 단지 추측하건데 DHCP 서버가 이미 IP 주소를 한 번 할당해준 것으로 인식하고 정보를 내어주지 않는것 같습니다. 제가 예전에 파워콤을 쓸때 그런일이 자주 있었습니다.

윈도우에서 ipconfig /release 명령으로 할당 받은 IP 주소를 반환하고 우분투로 부팅해보세요.
그러면 아마 IP주소가 원할하게 받아질 것이라 생각됩니다.

그리고 이건 임시방편입니다만 윈도우에서 할당받은 IP주소를 우분투에서 고정IP로 사용하는 방법도 있습니다.
eth0 Properties 창에서 Enable roaming mode에 체크를 해제하시고 cofiguration에 고정 IP를 선택한뒤
아래 세 칸을 채워넣으시면 됩니다.

[quote="gweere":8giy2elr][quote="redhaze":8giy2elr]그렇다면 부팅할때 우분투로 인터넷을 쓸때는 꼭 우분투로 먼저 부팅을해야하나요?
제가 리눅스 설치가 이번이 첨이라… 답변이 이해가 안가요;;[/quote:8giy2elr]

꼭 우분투로 먼저 부팅할 필요는 없습니다. 그리고 우분투에서 먼저 IP를 할당 받으면 반대로 윈도우에서 할당받지 못해 인터넷이 안될수도 있구요. 물론 정상적인 상황이라면 보통은 어느쪽을 나중에 부팅하던 항상 IP 주소를 할당 받을 수 있어야 합니다.

간헐적으로 발생하는 문제인데 원인은 모르겠습니다. 단지 추측하건데 DHCP 서버가 이미 IP 주소를 한 번 할당해준 것으로 인식하고 정보를 내어주지 않는것 같습니다. 제가 예전에 파워콤을 쓸때 그런일이 자주 있었습니다.

윈도우에서 ipconfig /release 명령으로 할당 받은 IP 주소를 반환하고 우분투로 부팅해보세요.
그러면 아마 IP주소가 원할하게 받아질 것이라 생각됩니다.

그리고 이건 임시방편입니다만 윈도우에서 할당받은 IP주소를 우분투에서 고정IP로 사용하는 방법도 있습니다.
eth0 Properties 창에서 Enable roaming mode에 체크를 해제하시고 cofiguration에 고정 IP를 선택한뒤
아래 세 칸을 채워넣으시면 됩니다.[/quote:8giy2elr]

위의 설명대로 ipconfig /release 명령으로 반환후 재붓해도 인텃넷이 되질 않습니다. ㅜㅜ

혹시 10Mbps 라인을 이용하고 계신가요?

그 랜카드가 종종 10Mbps 라인인 곳에서 사용될때 회선 속도에 맞게 설정을 맞추지 못해 인터넷이
안되는 경우가 있는 모양입니다.

일단 테스트 삼아서 강제로 지정해보세요. 터미널에 아래 내용을 차례로 입력하면 됩니다.

[code:3c05r3cs]sudo mii-tool -F 10baseT-FD
sudo /etc/init.d/networking restart
sudo mii-tool -R[/code:3c05r3cs]

만약에 안되면 10baseT-FD을 10baseT-HD 바꿔서 테스트 해보세요.

참고로 대입 가능한 것들은 다음과 같습니다. 앞쪽에 있는 것일수록 더 나은 성능을 보여줍니다.
1000baseTx-HD, 1000baseTx-FD, 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD

인터넷이 정상적으로 가능한 설정이 발견된었다면 부팅시 자동으로 설정이 되도록 하세요.
아래 과정을 따라하시면 됩니다.

일단 rc.local 파일을 슈퍼유저 권한으로 여시구요…

[code:3c05r3cs]sudo gedit /etc/rc.local[/code:3c05r3cs]

exit 0 바로 윗줄에 아래 내용을 추가한 후 저장하고 리부팅 해보세요. XXXX 부분은 맞는 설정으로 바꾸시면 됩니다.

[code:3c05r3cs]mii-tool -F XXXX
sudo /etc/init.d/networking restart
mii-tool -R[/code:3c05r3cs]

gweere님 감사합니다… _ _)

도움받아 설치 완료했습니다.
인터넷도 잘되구요…ㅎ

-_-)b