민트7을 사용하고 있는데 김프가 실행이 되질 않습니다

이것저것 프로그램을 새로 많이 설치해서 그런 것인지, 김프를 실행하면 Starting Gimp 메세지만 작업표시줄에 보이다가 그냥 사라집니다.

소프트웨어 소스도 마찬가지인 현상을 보여줍니다…

무슨 문제일까요?

우분투에서 민트로 넘어와서 나름대로 최적화를 마쳤다고 생각했는데 가장 주력으로 사용하는 프로그램이 실행이 안되니까 정말 답답하군요…

도와주시면 감사하겠습니다^^

그놈터미널에서 gimp 쳐서 실행 하면 터미널에 나오는 메세지 올려 봐 주시기 바랍니다.

제 추측은

  1. 기존 설정파일과 민트 설정파일과 충돌
  2. 테마 문제
  3. 컴피즈 테마 문제 등으로
    추축 됩니다.

소프트웨어 소스 명령어는
gksu --desktop /usr/share/applications/software-properties.desktop /usr/bin/software-properties-gtk
입니다.

저도 민트7 글로리아입니다만…김프가 별 문제 없이 작동됩니다.

강분도님 말씀처럼 이유가 없이 프로그램이 실행 안될때는 터미널에서 명령쳐서 실행시켜보십시오.
뭔가 에러메시지가 나올겁니다.

음, 터미널에서 김프를 입력하면 실행은 되는데 아래와 같은 에러 메세지를 보여주네요…

$ gimp
/usr/local/lib/gimp/2.0/plug-ins/print: error while loading shared libraries: libgimpprint.so.1: cannot open shared object file: No such file or directory

(gimp:9957): LibGimpBase-WARNING **: gimp: wire_read(): error

터미널에서는 실행이 되는데 역시 메뉴에서는 안됩니다…^^

도와주시면 감사하겠습니다^^

gksu --desktop /usr/share/applications/software-properties.desktop /usr/bin/software-properties-gtk

위와 같이 터미널에 입력했을 때 아래와 같은 에러 메세지가 나옵니다.

gksu --desktop /usr/share/applications/software-properties.desktop /usr/bin/software-properties-gtk
File "/usr/bin/software-properties-gtk", line 104, in <module>
app = SoftwarePropertiesGtk(datadir=data_dir, options=options, file=file)
File "/usr/lib/python2.6/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 75, in init
SoftwareProperties.init(self, options=options, datadir=datadir)
File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 83, in init
self.reload_sourceslist()
File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 521, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
File "/usr/lib/python2.6/dist-packages/aptsources/distro.py", line 90, in get_sources
raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

이것도 도와주시면 대단히 감사하겠습니다^^

자꾸 번거롭게 해드려서 정말 죄송합니다…

개인적 저장소를 추가 하여 상위 또는 하위 버전 프로그램을 잘못 설치 하거나
또는 민트를 클린 설치 하지 않은 모양 입니다.

파이썬이 우분투 데탑에서 매우 중요한데 버전이 잘 맞지 않은 듯 합니다.

김프 나 소프트웨어 소스경우 파이선 버전이 다른것이 설치 된 듯 합니다.
[b:158b1uqi]저의 경우 둘다 메세지 전혀 없이 실행 됩니다.[/b:158b1uqi]

보통 블러그 글보고 추가로 어떤 패키지를 상위 버전이나 하위로
잘못 설치 할 경우 파이선 버전을 변경 또는 의존성이 깨져 그럴 수 있는데…