다른 버전의 저장소 추가해서 프로그램 설치

geant4라는 프로그램을 설치하려고 합니다.
그런데 저장소 버전이 hardy까지만 지원합니다.
하지만 제 컴퓨터는 jaunty x64
그래도 저장소를 추가한 후 keyring을 받았습니다.
그런데 시냅틱 패키지 관리자에서 안뜨더군요.
apt-get해도 깨진 패키지라고 나올 때도 있고 잘못된 작업이라고 뜰 때도 있습니다.
aptitude로 강제로 시도했는데 변화가 없습니다.
어떻게 하면 강제로 설치할 수 있을까요?

참고
설치 관련 사이트 : http://lcg-heppkg.web.cern.ch/lcg-heppk … stall.html
저장소 : deb http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian hardy hep (우분투이지만 명령줄에 데비안이 들어가더군요)

패키지 파일(deb)을 다운 받아
dpkg -i --force–all 패키지네임
으로 강제 설치를 할수 있으나 의존 패키지로 인해 문제가 있을 것입니다.

8.04 용 데비안 5용만 제공 된다면 …
소스를 컴파일 설치 하는것이 좋을것 입니다.
참고 : http://www.scribd.com/doc/17465713/Set- … -On-Ubuntu

감사합니다.
사실은 컴파일 설치를 싫어해서 편하게 가려고 했는데…
결국 문제에 정면으로 도전해보아야 겠습니다.