네트워크 설정 헬프부탁드려요

제가 8.10에서는 네트워크 컨피어쩌고? 에서 add 해서 ip4v 에서 메뉴얼 해서 설정이 됬던거 같애요 adress netmask gateway 랑 dns만
하면 apply 가 눌러졌어요

근데 9.04를 새로 깐 후에는 apply가 안 눌러지네요 ㅜㅜ 무슨 루트?인가 그걸 해야되는데

루트에서 마지막에 메트 어쩌고… 부분이 뭘 뜻하는지 모르겠어요

그리고 뭐 해서 네트워크 끄고 재부팅 하고 인터페이스랑 뭐 하나 더 바꾸고 하는데서

broadcast 라는게 있잖아요… 그게 뭘 뜻하는건지 모르겠어요 ㅜㅜ

도움점 굽신

첫번째 질문은 이해를 못했구요.

두번째 질문은…
단순한 사항은 검색만 하면 나옵니다.
그런데 기껏 길어야 한페이지 정도의 분량으로
이해하기는 힘듭니다. 상식은 되겠지요.

도서관에 가니
'후니의 쉽게 쓴 시스코 네트워킹’이란
책이 있어서 보고 있는데…
문외한도 네트워크에 대해 개념을 잡을 정도로
쉽게 씌여 있더군요.
이 책을 읽고 나서야
메뉴의 네트워크 매니저를 열어도 이해가 되고
우분투 네트워크 메뉴얼을 봐도 좀 이해가 됩니다.

배경지식, 기초지식이 중요함을 다시 느꼈습니다.
관심이 있으시면 추천합니다.

브로드 케스트

쉽게 말한다면

게임방 카운터에서 모든 컴퓨터에게 방송을 하는것입니다요.

넌 뭐냐? 뭐하는 놈이냐? 이런식으로 ㅋ

[quote="akuna":ow81xrc5]첫번째 질문은 이해를 못했구요.

두번째 질문은…
단순한 사항은 검색만 하면 나옵니다.
그런데 기껏 길어야 한페이지 정도의 분량으로
이해하기는 힘듭니다. 상식은 되겠지요.

도서관에 가니
'후니의 쉽게 쓴 시스코 네트워킹’이란
책이 있어서 보고 있는데…
문외한도 네트워크에 대해 개념을 잡을 정도로
쉽게 씌여 있더군요.
이 책을 읽고 나서야
메뉴의 네트워크 매니저를 열어도 이해가 되고
우분투 네트워크 메뉴얼을 봐도 좀 이해가 됩니다.

배경지식, 기초지식이 중요함을 다시 느꼈습니다.
관심이 있으시면 추천합니다.[/quote:ow81xrc5]

  1. 나중에 시간이 되면 책 한번 보겠습니다 감사합니다 ^^

  2. 음 나중에 스샷을 찍어 올릴게요 ㅜ

첨에 좌측 상단패널 보면 네트워크 뜨잖아요 거기서 오른쪽 마우스 눌러서 에디트 커넥션 드가면
wired 에서 ip4v 인가 거기 들어가보면, automatic이라던가 여러가지 선택하는데 거기서 Manual 하면 ip 수동지정 같은게 가능하잖아요(그니깐 고정ip)

거기서 Manual 하고 ip, 서브넷, 게이트웨이, DNS 만 적으면 제 기억으로는 8.10까지는 apply 그니까 적용이 눌러졌는데 지금은 안 눌러지네요 ㅜㅜ

[quote="kth9989":25w2aauj]브로드 케스트

쉽게 말한다면

게임방 카운터에서 모든 컴퓨터에게 방송을 하는것입니다요.

넌 뭐냐? 뭐하는 놈이냐? 이런식으로 ㅋ[/quote:25w2aauj]

그럼 broadcast 는 주소 안 적어도 상관이 없는건가요? 만약 적어야 하면 어떻게 넣어야되는지 ㅜ

사용하시는 IP address와 netmask를 알아야 알려드릴수 있을것 같네요.

만약 192.168.123.x 같은 주소를 사용하신다면
192.168.123.255를 넣어주세요.

음 제대로 올라갔을지 모르겠네요… 그림을 첨부파일로 올려서 안될지 모르겠으나…

아래와 같아요

제가 아는건 ip 주소, 서브네트 마스크, 게이트웨이, DNS 입니다(윈도우 기준으로…)

그런데 저걸 다 집어 넣어도 밑에 OK가 안뜨네요… // 저건 혹시 8.10에서는 되나 싶어서 cd부팅 한거에요… 9.04도 마찬가지

긱사라서 이걸 해야 인터넷이 되는뎅 ㅜ

network-manager 이놈이 static IP를 사용하는 경우 설정이 잘 안되더군요…
8.10부터 시작해서 9.04까지 시스템에 기본으로 되어있는 놈(network-manager)을 쓸려다가 포기 하고 wicd를 사용합니다.

일단 network-manager를 삭제하고

원시적?인 방법으로 네트워크 설정을 합니다.
interfaces 파일을 수정 합니다.[code:9zn986aq]$> sudo nano /etc/network/interfaces[/code:9zn986aq]물론 IP들은 사용하는걸로 수정… 그리고 broadcast는 보통 앞 3개까지는 같고 마지막에 255로 입력하면 맞습니다.[code:9zn986aq]auto eth0
iface eth0 inet static
address 192.168.1.3
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1[/code:9zn986aq]
다음은 DNS 설정 입니다.

[code:9zn986aq]$> sudo nano /etc/resolv.conf[/code:9zn986aq]사용하는 DNS를 다음과 같이 입력합니다.[code:9zn986aq]nameserver 192.168.1.1[/code:9zn986aq]

이제 네트워크 서비스를 재기동 합니다.

[code:9zn986aq]$> sudo /etc/init.d/networking restart[/code:9zn986aq]

마지막으로 wicd를 설치 합니다.

[code:9zn986aq]$> sudo apt-get install wicd[/code:9zn986aq]만약 network-manager삭제 하지 않았다면 삭제하고 설치 됩니다.

그외에 이런방식 [url:9zn986aq]http://linhost.info/2008/11/how-to-set-a-static-ip-on-ubuntu-810/[/url:9zn986aq]으로 그놈(우분투)에서 해결 되기도 했습니다만 Wicd를 사용하는게 편하더군요.

don’t seem to be have all the variable for eth0/inet
failed to bring up eth0

이렇게 떠요… 모든 설정하고 리스타트를 하면 ㅜㅜ…

부팅후 그놈터미널서
dmesg | grep eth0
하여 네트웍카드를 eth0 으로 인식하는 것이 존재 하는지 살펴 보십시요

존재한다면 위 interface 올바른 값으로 편집하고
sudo /etc/init.d/networking restart 하면 그냥 인터넷이 되어야 합니다.
GUI 용 네트웍매니저나 Wicd 상관 없이…

[quote="강분도":2vmexfmn]부팅후 그놈터미널서
dmesg | grep eth0
하여 네트웍카드를 eth0 으로 인식하는 것이 존재 하는지 살펴 보십시요

존재한다면 위 interface 올바른 값으로 편집하고
sudo /etc/init.d/networking restart 하면 그냥 인터넷이 되어야 합니다.
GUI 용 네트웍매니저나 Wicd 상관 없이…[/quote:2vmexfmn]

[ 6.914161] eth0 RTL8102 … 어쩌고 나오긴 나오네요…

그런데도 저 메세지를 쳐도…

안되네요 ㅜㅜ don’t seem 어쩌고…

[quote="Maboroshi":1zjh4yuo][ 6.914161] eth0 RTL8102 … 어쩌고 나오긴 나오네요…

그런데도 저 메세지를 쳐도…

안되네요 ㅜㅜ don’t seem 어쩌고…[/quote:1zjh4yuo] /etc/resolv.conf 에 보편적 dns 를 넣고 networking 데몬 재시작 해보십시요
sudo gedit /etc/resolv.conf 하여 아래 내용 삽입
nameserver 168.126.63.1
nameserver 168.126.63.2
저장 후 sudo /etc/init.d/networking restart 네트워킹 데몬 재시작

[quote="강분도":18ysbm0a][quote="Maboroshi":18ysbm0a][ 6.914161] eth0 RTL8102 … 어쩌고 나오긴 나오네요…

그런데도 저 메세지를 쳐도…

안되네요 ㅜㅜ don’t seem 어쩌고…[/quote:18ysbm0a] /etc/resolv.conf 에 보편적 dns 를 넣고 networking 데몬 재시작 해보십시요
sudo gedit /etc/resolv.conf 하여 아래 내용 삽입
nameserver 168.126.63.1
nameserver 168.126.63.2
저장 후 sudo /etc/init.d/networking restart 네트워킹 데몬 재시작[/quote:18ysbm0a]

음… 굉장히 귀찮게 하는거 같아서 죄송합니당… ㅜㅜ

우선 저의 모든 상태를 스샷 올릴게요

아래에 뜰거에요… 그리고 분도님 말씀대로 DNS를 보편적으로 하고도 똑같은 메세지만 나옵니다…

네트워크 메니저 문제인거 같아서 wicd인가요… 그거를 윈도로 받아서 네트워크 메니저 지우고 우분투에서 깔았습니다. 그런데 어떻게 만지는 줄도 모르겠고

끄고나서는 다시 실행조차 되지 않네요…ㅎㄷㄷ…

내일 우분투를 포멧하고 다시 깔아볼 예정입니다…

그리고 윈도7에서의 인터넷 설정 -> 우분투에서 인터넷 설정이

IP -> adress
서브넷 마스크 -> netmask
게이트웨이 -> gateway
DNS서버 -> nameserver

이렇게 따라가는게 맞나요?

address 철자가 틀렸네요.

[quote="esrevinu":2zc7r2ok]address 철자가 틀렸네요.[/quote:2zc7r2ok]
오타 발견 멋진데요! 굿샷 입니다. :D

Maboroshi님 인하대 ?
IP가 좀 보던 라인이군요

[quote="강분도":1uh2fopj][quote="esrevinu":1uh2fopj]address 철자가 틀렸네요.[/quote:1uh2fopj]
오타 발견 멋진데요! 굿샷 입니다. :D

Maboroshi님 인하대 ?
IP가 좀 보던 라인이군요[/quote:1uh2fopj]

ㅜㅜ… 글쿤요 철자가 틀린듯;

그래도 고치고 나서 한번더 해봤습니다만… 여전히 아래와 같은 에러가 ㅜㅜ

호스트를 찾을 수 없데염;

그리구 ifconfig을 쳐보라길래 쳐 본 결과입니다

제친구는 9.04 깔아서 Manual 해서 설정이 됬다던데… ㅜ

아니면 하위버젼을 깔아서 패치를 하는수밖에 없나염… 포맷하고 다시 해본건디 ㅜ

// 넹 인하대 맞습니당 ㅜ

랜카드를 eth1 로 인식 하고 있군요
/etc/network/interfaces 파일 편집
auto eth1
iface eth1 inet static
로 고친 다음 sudo /etc/init.d/networking restart

[quote="강분도":2pkj21as]랜카드를 eth1 로 인식 하고 있군요
/etc/network/interfaces 파일 편집
auto eth1
iface eth1 inet static
로 고친 다음 sudo /etc/init.d/networking restart[/quote:2pkj21as]

음… 여전히 언논 호스트라네요…

게다가 eth0, eth1 막 바뀌는듯한…

그래서 interfaces에

auto eth0
~
~
~

auto eth1
~
~
~

두개 작성해서 해도 여전히 둘다 언논 호스트라하구…

auto lo 인가요 그걸 해봣는데 그건 에러없이 OK 뜨길래 인터넷이 되나 싶었는데 마찬가지로 안되네요…

잽팅해보고 해봐두…

인하대 2차 네임서버는
134.75.30.1 인데
잘 못 적었나요?

글자나 숫자에서 오타난 부분이 있는지
다시 확인해 보세요.
방법이 맞는데 안될리가 없을 것 같네요.
처음부터 하나 하나 확인해 가면서
천천히 해 보세요.

성공하시길 바랍니다.