기본키모음 암호와 한영키 문제

에볼루션 메일을 실행할 때마다 기본키모음 암호를

물어봅니다…

이거 없애는 방법이 있나요??

그리고

키보드 레이아웃 설정을 했음에도 불구하고

한영키 입력이 되지않습니다…

정확히는

키보드 레이아웃 설정을 다시 해주면 되는데

재부팅 하면 설정은 그대로지만 한영키는 안먹는군요…

해결책 좀 알려주세요 ㅠ_ㅠ 부탁드립니다.

한영키 전환문제는
/etc/X11/xorg.conf 파일을 텍스트 편집기로 열어 키보드 레이아웃을 us에서 kr로 바꿔주면 될겁니다.
별다른 수정이 없었다면 22번째줄에 위치합니다.
정상적인 환경에서는 자동으로 변경이 되어야하는데 이상하게 안되는 분들이 많군요…

이부분을
Option "XkbLayout" "[color=#FF0000:3mg6twjh]us[/color:3mg6twjh]"

이렇게 변경하시면 됩니다.
Option "XkbLayout" "[color=#FF0000:3mg6twjh]kr[/color:3mg6twjh]"

[quote="zzuniyo":3ta0p9fm]에볼루션 메일을 실행할 때마다 기본키모음 암호를

물어봅니다…

[/quote:3ta0p9fm]
에볼루션 실생시에 기본키모음 암호를 묻는건 금시 초문 입니디. :oops:
음 홈 폴더에 히든으로 있는 .evolution 폴더를 백업 하신 후 실행 해보시기 바랍니다.

답변 감사합니다^^

에볼루션 메일 저걸 백업 어떻게 하죠?

[quote:37pvkkb3]홈 폴더에 히든으로 있는 .evolution 폴더를 백업 하신 후 실행 해보시기 바랍니다.[/quote:37pvkkb3]

홈폴더에서 컨트롤+h 로 숨긴 파일을 열으신뒤 .evolution 폴더를 찾으세요.

찾으신 다음 .evolution을 클릭하고 F2 키를 눌르면 이름바꾸기가 됩니다. evolution-bak으로 이름 바꾸기를 하시거나

.evolution을 마우스 오른쪽 클릭 > "압축파일 만들기"로 압축하여 따로 보관하시면 되겠습니다.

[quote="강분도":19211d04][quote="zzuniyo":19211d04]에볼루션 메일을 실행할 때마다 기본키모음 암호를

물어봅니다…

[/quote:19211d04]
에볼루션 실생시에 기본키모음 암호를 묻는건 금시 초문 입니디. :oops:
음 홈 폴더에 히든으로 있는 .evolution 폴더를 백업 하신 후 실행 해보시기 바랍니다.[/quote:19211d04]
말씀하신대로 home 폴더의 .evolution 폴더를 ‘이름바꾸기’ 해 놓고 에볼루션 메일(클라이언트)를 재시작 해 봤지만 똑같이 '기본키 모음 암호’를 요구합니다.

저의 경우 이-메일 보내고 받기에는 문제가 없습니다만, 에볼루션 메일을 시작할 때마다 또 새 메일을 보낼 때마다 '기본키 모음’암호를 요구받습니다.

한편
#1. 프로그램>보조 프로그램>암호 및 암호화키 에서 PGP를 생성한 후
#2. 에볼루션 메일>편집>기본설정>편집>메일 계정설정(메일 계정 선택 후)>편집>계정 편집기>보안(탭)>PGP 설정 ID 키> (윗줄 #1번에서 만든) PGP 키 iD를 입력해 줘도 결과는 마찬가지 매번 '기본키 모음 암호’를 요구합니다.

그놈 라이브러리에 있는 에볼루션 메일 사용설명서(영문)[url:19211d04]http://library.gnome.org/users/evolution/stable/encryption.html.en[/url:19211d04]을 읽어보아도 특별히 도움되는 내용은 없었으며 다면 PGP 암호화관련해서 이-메일 내용을 암호화 하는 부분만 있었는데 위 문제와는 관련 없는 내용처럼 보였습니다.
추측하건데, 어쩌면 이-메일 내용을 암호화하는데 필요한 인증키가 아니라 보안된 서버에 접속하는데 필요한 암호화 인증키를 매번 요구하는 것 아닌지…? 아직도 잘 모르겠습니다.

아시는 분들의 조언을 구합니다.

제 경우에는

홈폴더를 백업해놨을 경우에 새버전을 깔았고, 새버전에서 암호를 바꿨을 경우에

저런 메시지가 나오더군요.=_=;;

보조프로그램 - 암호 및 암호화 키에서 계정암호와 같은 암호를 키 저장소 암호로 새로 만들어주고 나서야 저 창이 안떴습니다…

[quote="떠돌이":2b7f0uxj]제 경우에는

홈폴더를 백업해놨을 경우에 새버전을 깔았고, 새버전에서 암호를 바꿨을 경우에

저런 메시지가 나오더군요.=_=;;

보조프로그램 - 암호 및 암호화 키에서 계정암호와 같은 암호를 키 저장소 암호로 새로 만들어주고 나서야 저 창이 안떴습니다…[/quote:2b7f0uxj]
저도 떠돌이님 말씀과 경우가 비슷합니다.
새로운 사용자 계정으로 로그인해서 메일 계정 설정해 보니까 '에볼루션 메일’프로그램 아이콘 부터 다르게 보이더라구요. 즉, 제가 주로 사용하는 사용자계정의 '에볼루션 메일’프로그램은 업데이트를 했더니 아이콘에 작은 스마일? 같은 모양이 하나 더 붙어 있었는데, 거기서만 기본키 모음 암호를 요구받았습니다.

새로운 사용자 계정을 만들어서 로그인 후 '에볼루션 메일’프로그램을 사용해 보니까 거기서는 기본키 모음 암호를 요구 받지 않았습니다.

결국 확인을 한 정도에 불과하고 아직 해결 전입니다.
참, 프로그램 버전은 같았습니다.

[quote:2b7f0uxj]보조프로그램 - 암호 및 암호화 키에서 계정암호와 같은 암호를 키 저장소 암호로 새로 만들어주고 나서야 저 창이 안떴습니다…[/quote:2b7f0uxj]
<— 의 댓글은 고맙습니다만, 저의 경우는 해결방법이 되지 않았습니다.

저의 경우엔 시스템 자동 로그인을 사용하면 에볼루션 실행시 기본 키모음 접근 암호를 물어보고
시스템 자동 로그인을 사용하지 않으면 안물어보더군요. 참고가 되시길…

[quote="sdnrui":6oydgg7x]저의 경우엔 시스템 자동 로그인을 사용하면 에볼루션 실행시 기본 키모음 접근 암호를 물어보고
시스템 자동 로그인을 사용하지 않으면 안물어보더군요. 참고가 되시길…[/quote:6oydgg7x]
sdnrui 님 말씀이 답이 되기는 했습니다.
좀 더 정확히 말씀드리자면, 우분투 설치때 자동 로그인을 선택하지 않고 설치후 에볼루션( 계정 설정 등)을 사용하면 기본 키모음 접근 암호를 물어보지 않는 것이 맞습니다.
단, 에볼루션(설정 및) 사용을 시작할 때, 우분투를 자동 로그인으로 시작했었다면 이 후 우분투를 수동 로그인으로 바꿔도 에볼루션에서는 기본 키모음 접근 암호를 계속해서 물어 봅니다. 영~원~히~!

그래서 저는 1. 에볼루션을 삭제한 후 2. 우분투 자동 로그인을 해제시키고 3. 에볼루션을 재설치했는데 (놀랍게도 3-1. 계정설정을 기억하더군요.) 4. 에볼루션에서는 계속해서 기본 키모음 접근 암호를 물어 옵니다.
아마도 에볼루션 삭제할 때 프로그램 디렉토리만 지웠었나봐요.

위 08년06월 글쓰신 두 분의 말씀을 참고하여 프로그램, 계정, 메일 폴더까지 다 지우고 재설치를 해야 되려나 봅니다.

나도 계속 물어보는데, 해결책이 없네.
보안이 철저한 우분투 ㅡ_ㅡ

[quote="jasonjang":2uu2zx15]그래서 저는 1. 에볼루션을 삭제한 후 2. 우분투 자동 로그인을 해제시키고 3. 에볼루션을 재설치했는데 (놀랍게도 3-1. 계정설정을 기억하더군요.) 4. 에볼루션에서는 계속해서 기본 키모음 접근 암호를 물어 옵니다.
아마도 에볼루션 삭제할 때 프로그램 디렉토리만 지웠었나봐요.[/quote:2uu2zx15]보통 개인 설정은 홈 디렉터리에 숨김 디렉터리 안에 만들어져서 걍 프로그램만 지운다고 설정이 날아가진 않죠. 다음에 그 프로그램을 다시 설치했을 때 또 설정을 할 필요 없이 쓸 수 있도록 한 것입니다. 홈 디렉터리 내에 프로그램 관련 디렉터리를 삭제해 주면 설정도 지워지겠죠.

그나저나 전 단 한 번도 이런 경우를 겪어보지 못해서 원 질문에 대한 답변은 하지 못하겠네요. 에볼루션이고 뭐고 기본 키 모음 접근 화면은 본 적이 없습니다. 아득한 옛날 기억에 기본 키 모음 사용을 disable 했던 것 같긴한데…;;

위에 떠돌이님 댓글도 있습니다만, 혹시나 도움이 될까 하여 떠돌이님의 블로그 포스트 링크 하나 걸어 둡니다. ^^

http://opensea.egloos.com/5041966