최대한 복구를 하고싶어요 [복구중...완료]

제가 쓸모없는 파일을 지운다고
전체 디렉토리에서
*.0
*.1
*.2
*.bak
*.old
*.gz
파일을 삭제했습니다.

아파치 서버만 가동이 되고
SSH, 원격접속 이 안되더라구요

재부팅뒤에는 검은화면에서 멈추었습니다.

우분투 시디로 부팅해서 시디에있는 *.0, *.1, *.2 *.old *.bak *.gz을 모두 같은 위치에 복사시켜 주었는데도
부팅이 되지를 않네요

웹서버운영 중이었는데 (백업은 해뒀어요)

다시 설치하려니, 그 많은 세팅들을 다시 해주기가 두렵네요
(하나도 모르는 상태에서 배워가며 세팅한거라서요)

어떻게하면 최대한 똑같이(설정) 복구가 될까요
어떤파일들을 복사해두면 좋을까요

지금 20시간째 다운이네요 ㅠㅠ

용기를 가지고 다시 설치하세요 -.-;;;

사실 질문하신 분의 컴퓨터의 상황을 자세히 알 수도 없고, 결정적으로 뭘 지우셨는지 알 수가 없으니까요.

/home을 백업하세요. 어떻게 세팅하셨는지는 모르지만 일단 상당부분의 설정은 건질수 있을겁니다.

서버였다면 /etc도 복사해두고 나중에 비교해가면서 수정하는 것이 좋습니다.

[quote="tinywolf":2qnza45y]서버였다면 /etc도 복사해두고 나중에 비교해가면서 수정하는 것이 좋습니다.[/quote:2qnza45y]

ㅠㅠㅠ /etc/ 받아 놓은거 믿고
/etc/apache2 통째로 지우고 옮겼는데
심볼릭 링크는 복사가 안되어 있더군요

mods-enabled 폴더속에 어떤 파일들이 있나요

[quote="b0kan2":2mra3msm]심볼릭 링크는 복사가 안되어 있더군요
mods-enabled 폴더속에 어떤 파일들이 있나요[/quote:2mra3msm]
심볼릭 링크로 되어 있다면 어딘가에 원본이 있을 것이고…
그 원본이 /etc 안에 없는 것이라면 설치를 해야하는 것이었을텐데요.
링크라 하더라도 cp명령으로 복사되지 않았나요? ls -l로 무얼 연결하고 있는지 보시는게…

그리고 /etc의 설정들은 다시 복사해 넣기 보다는 백업된 내용을 참고로 필요한 것만 수정하는게 더 낫다고 개인적으로 생각합니다.
그래서 아래와 같이 썼었지요.

[quote="tinywolf":2mra3msm]서버였다면 /etc도 복사해두고 나중에 [color=#BF0000:2mra3msm][b:2mra3msm]비교해가면서 수정[/b:2mra3msm][/color:2mra3msm]하는 것이 좋습니다.[/quote:2mra3msm]일단 아파치 클린 재설치를… :cry:

제가 우분투에서 아파치를 안 써서 잘은 모르겠지만…
폴더 이름으로 봐서는 활성화시킨 모듈들의 링크가 있었겠네요.
아 그리고 아파치라면… 웹페이지가 /var/www에 있지 않나요? 웹페이지는 백업 하셨는지… :cry:

http://www.ubuntu.or.kr/viewtopic.php?p=20081#p20081

[quote="tinywolf":38tapc5e][quote="b0kan2":38tapc5e]심볼릭 링크는 복사가 안되어 있더군요
mods-enabled 폴더속에 어떤 파일들이 있나요[/quote:38tapc5e]
심볼릭 링크로 되어 있다면 어딘가에 원본이 있을 것이고…
그 원본이 /etc 안에 없는 것이라면 설치를 해야하는 것이었을텐데요.
링크라 하더라도 cp명령으로 복사되지 않았나요? ls -l로 무얼 연결하고 있는지 보시는게…

그리고 /etc의 설정들은 다시 복사해 넣기 보다는 백업된 내용을 참고로 필요한 것만 수정하는게 더 낫다고 개인적으로 생각합니다.
그래서 아래와 같이 썼었지요.

[quote="tinywolf":38tapc5e]서버였다면 /etc도 복사해두고 나중에 [color=#BF0000:38tapc5e][b:38tapc5e]비교해가면서 수정[/b:38tapc5e][/color:38tapc5e]하는 것이 좋습니다.[/quote:38tapc5e]일단 아파치 클린 재설치를… :cry:

제가 우분투에서 아파치를 안 써서 잘은 모르겠지만…
폴더 이름으로 봐서는 활성화시킨 모듈들의 링크가 있었겠네요.
아 그리고 아파치라면… 웹페이지가 /var/www에 있지 않나요? 웹페이지는 백업 하셨는지… :cry:[/quote:38tapc5e]

네… cp 명령어로는 복사가 되는지 모르겠고요
그놈환경에서 복사 -> USB메모리로 붙여넣기 했습니다.
심볼릭 링크는 안딸려 왔네요
수동으로 링크 걸어주려고 해도 어떤파일들 링크해줘야 되는지 몰라서요…
전체를 뜻하는 . 이런식으로는 링크 안되더라고요
전부 다 해주려니까 너무 많고요 ^^

아파치 클린설치는 어떤방법인가요?
sudo apt-get remove apache2
sudo apt-get install apache2
이방법은 안되던데요

[quote="b0kan2":3bqodzhr][quote="tinywolf":3bqodzhr][quote="b0kan2":3bqodzhr]심볼릭 링크는 복사가 안되어 있더군요
mods-enabled 폴더속에 어떤 파일들이 있나요[/quote:3bqodzhr]
심볼릭 링크로 되어 있다면 어딘가에 원본이 있을 것이고…
그 원본이 /etc 안에 없는 것이라면 설치를 해야하는 것이었을텐데요.
링크라 하더라도 cp명령으로 복사되지 않았나요? ls -l로 무얼 연결하고 있는지 보시는게…

그리고 /etc의 설정들은 다시 복사해 넣기 보다는 백업된 내용을 참고로 필요한 것만 수정하는게 더 낫다고 개인적으로 생각합니다.
그래서 아래와 같이 썼었지요.

[quote="tinywolf":3bqodzhr]서버였다면 /etc도 복사해두고 나중에 [color=#BF0000:3bqodzhr][b:3bqodzhr]비교해가면서 수정[/b:3bqodzhr][/color:3bqodzhr]하는 것이 좋습니다.[/quote:3bqodzhr]일단 아파치 클린 재설치를… :cry:

제가 우분투에서 아파치를 안 써서 잘은 모르겠지만…
폴더 이름으로 봐서는 활성화시킨 모듈들의 링크가 있었겠네요.
아 그리고 아파치라면… 웹페이지가 /var/www에 있지 않나요? 웹페이지는 백업 하셨는지… :cry:[/quote:3bqodzhr]

네… cp 명령어로는 복사가 되는지 모르겠고요
그놈환경에서 복사 -> USB메모리로 붙여넣기 했습니다.
심볼릭 링크는 안딸려 왔네요
수동으로 링크 걸어주려고 해도 어떤파일들 링크해줘야 되는지 몰라서요…
전체를 뜻하는 . 이런식으로는 링크 안되더라고요
전부 다 해주려니까 너무 많고요 ^^

아파치 클린설치는 어떤방법인가요?
sudo apt-get remove apache2
sudo apt-get install apache2
이방법은 안되던데요[/quote:3bqodzhr]

클린설치 했습니다…
sudo apt-get remove --purge apache2.2-common && apt-get install apache2.2-common

viewtopic.php?f=21&t=3143

복구중