[해결]tp 울트라베이스에서 헤드셋이 안됩니다~

안녕하세요~ kde 64bit 환경 사용 중입니다. 하드웨어는 lenovo x200에 울트라베이스 사용 중입니다.
노트북에 내장된 스피커나 헤드셋 단자로는 소리가 잘 들립니다. 다만 문제는
울트라베이스에 헤드셋을 연결시에 소리가 노트북 내장 스피커로 출력이 된다는 문제가 있습니다.

kde 사용자가 거의 없을 듯하고 울트라베이스 사용자도 없을 듯 하지만 일단은 글을 올려봅니다.

커널은 3.10-3-amd64를 사용하고 있습니다. 레드헷 버그리포트에서 비슷한 사항을 찾았는데
해결은 안되고 있습니다
[url:2rtmtex4]https://bugzilla.redhat.com/show_bug.cgi?id=810697[/url:2rtmtex4]
커널 버전도 3.10이나 되는데 아직도 이런 문제인게 이해가 되진 않습니다만
그래서 도움을 요청합니다

약간 이상한건 pulse를 설치했는데 phonon에서 보면
[attachment=1:2rtmtex4]스냅샷2.png[/attachment:2rtmtex4]
built-in audio만 인식을 하고 있습니다. 아마 이거 때문에 문제가 발생한건 아닐까 하는데
아무리 찾아봐도 모르겠군요…

[attachment=2:2rtmtex4]스냅샷3.png[/attachment:2rtmtex4]
그리고 보시다 시피 인식을 한거 같긴 한데 계속 이런 메시지만 뜨고 있습니다.
장치라도 보이면 어떻게 하겠는데 그게 아니라서 황당합니다.

[code:2rtmtex4]
$ cat /etc/libao.conf
default_driver=pulse
quiet
[/code:2rtmtex4]

[code:2rtmtex4]
$ cat /etc/modprobe.d/alsa-base.conf

autoloader aliases

install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

Cause optional modules to be loaded above generic modules

install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

Keep snd-pcsp from beeing loaded as first soundcard

options snd-pcsp index=-2

Keep snd-usb-audio from beeing loaded as first soundcard

options snd-usb-audio index=-2

Prevent abnormal drivers from grabbing index 0

options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

options snd-hda-intel index=-2 model=lenovo-x200
[/code:2rtmtex4]

[code:2rtmtex4]
$ dpkg -l | grep pulse
ii gstreamer0.10-pulseaudio:amd64 0.10.31-3+nmu1 amd64 GStreamer plugin for PulseAudio
ii libpulse-mainloop-glib0:amd64 4.0-6+b1 amd64 PulseAudio client libraries (glib support)
ii libpulse0:amd64 4.0-6+b1 amd64 PulseAudio client libraries
ii libpulsedsp:amd64 4.0-6+b1 amd64 PulseAudio OSS pre-load library
ii pulseaudio 4.0-6+b1 amd64 PulseAudio sound server
ii pulseaudio-module-bluetooth 4.0-6+b1 amd64 Bluetooth module for PulseAudio sound server
ii pulseaudio-module-jack 4.0-6+b1 amd64 jackd modules for PulseAudio sound server
ii pulseaudio-module-x11 4.0-6+b1 amd64 X11 module for PulseAudio sound server
ii pulseaudio-utils 4.0-6+b1 amd64 Command line tools for the PulseAudio sound server
ii vlc-plugin-pulse 1:2.0.8-dmo5 amd64 PulseAudio plugin for VLC
[/code:2rtmtex4]

[code:2rtmtex4]
$ lsmod | grep ‘^snd’ | column -t
snd_hda_codec_conexant 56942 1
snd_hda_intel 48664 3
snd_hda_codec 194680 2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 13613 1 snd_hda_codec
snd_pcm 107180 2 snd_hda_codec,snd_hda_intel
snd_page_alloc 18798 2 snd_pcm,snd_hda_intel
snd_seq 66061 0
snd_seq_device 14497 1 snd_seq
snd_timer 29989 2 snd_pcm,snd_seq
snd 73821 15 snd_hwdep,snd_timer,snd_hda_codec_conexant,snd_pcm,snd_seq,snd_hda_codec,snd_hda_intel,thinkpad_acpi,snd_seq_device
[/code:2rtmtex4]

[code:2rtmtex4]
$ cat /proc/asound/cards
1 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf2620000 irq 47
29 [ThinkPadEC ]: ThinkPad EC - ThinkPad Console Audio Control
ThinkPad Console Audio Control at EC reg 0x30, fw 7XHT22WW-1.04
[/code:2rtmtex4]

[code:2rtmtex4]
$ cat /proc/asound/card1/id
Intel
$ cat /proc/asound/card29/id
ThinkPadEC
[/code:2rtmtex4]

더 필요한 정보가 뭔지 모르겠습니다…

pulseaudio를 완전히 제거하면 해결이 될지도 모른다는 생각이듭니다.

[quote="zeromon":2248ynzk]pulseaudio를 완전히 제거하면 해결이 될지도 모른다는 생각이듭니다.[/quote:2248ynzk]

하지만 그 경우 virtualbox에서 오디오 문제가 발생하여 소리가 들리지 않게 됩니다
설정에서 alsa로 설정을 해도 마찬가지고 다른 걸로 설정을 해도 여전히 문제가 발생합니다

지우고 나서(물론 설치하기 전에 virtualbox로 확인한 결과입니다) 둘 다 안될까봐
지우지는 못했습니다

이전에는(이번에 kde를 새로 설치했습니다) phonon에서 다른 장비도 보였는데
이번에는 보이지도 않고 문제가 많습니다…

제목만 보고 헤드셋이 아에 안된다고 잘 못 댓글을 달았네요. 다시 원래 질문을 읽고 답해봅니다.
터미널에서 alsamixer를 실행시켜보면 Auto-mut이라는 것이 있는데 그것이 enabled되 있는지 확인하세요. 헤드셋 꼽았을때 자동으로 노트북 스피커를 mute해 주는 기능입니다.

해결했습니다. 설정에 조금 문제가 있었네요

정상적으로 동작을 잘 합니다

답변 모두 감사드립니다~